Jump to content

fs1

New ATC and Airport Operations Application Testing

Recommended Posts

10 hours ago, Balint Szarka said:

Hi

Since updating to V5 HF1 I am experiencing CTD's due to the program. It can be easily reproduced if you select a different time upon loading up the sim at any airport then changing time to any time you wish or just placing yourself somewhere else on the planet. 

 

Kind regards,

Balint

With 5.1 HF 1 I can confirm the issue that Balint describes. However, the features themselves work nicely and as intended. 


Best,
Christoph

Display resolution: 1920x1080 (8xSSAA)    GPU: 1080TI     CPU: i7-7700K (5.0 OC)    RAM: 16GB     SSD: Samsung 850Evo     Monitor: 27K

FSBetaTesters3.png

Share this post


Link to post

I've been spotting at the new EDDB for a while now. For some reason the "Enable Roll then takeoff" doesn't work anymore. So aircraft keep waiting until the landing aircraft has fully vacated the runway. 

Share this post


Link to post
6 minutes ago, fclaass said:

I've been spotting at the new EDDB for a while now. For some reason the "Enable Roll then takeoff" doesn't work anymore. So aircraft keep waiting until the landing aircraft has fully vacated the runway. 

Can you show me your config file?

Edited by fs1

Federico Sucari

Share this post


Link to post

<?xml version='1.0' encoding='utf-8' ?>
<Parameters>
    <Airport>
    <ICAO>EDDB</ICAO>
    <ActiveTakeOffRunway>
        <Runway>R25L</Runway>
    </ActiveTakeOffRunway>
    <ActiveTakeOffRunway>
        <Runway>R25R</Runway>
    </ActiveTakeOffRunway>
    <ActiveLandingRunway>
        <Runway>R25L</Runway>
    </ActiveLandingRunway>
    <ActiveLandingRunway>
        <Runway>R25R</Runway>
    </ActiveLandingRunway>
    </Airport>
    <enableFastTakeOffs>1</EnableFastTakeOffs>
    <enableRollthenTakeOff>1</enableRollthenTakeOff>
    <allowTakeOffDistance>9000</AllowTakeOffDistance>
    <taxiSpeedLimiter>30</TaxiSpeedLimiter>
    <nonBlockingUserAircraft>1</nonBlockingUserAircraft>
    <minCrossingRny>2000</minCrossingRny>
    <isGUIVisible>1</isGUIVisible>
    <deployEarlyFlaps>0</deployEarlyFlaps>
</Parameters>

Share this post


Link to post

The issue here is that if there is an AI landing and it is less than 6000 meters(see <allowTakeOffDistance>6000</AllowTakeOffDistance>) the min take off is not set to permit the new AI take off, so the AI will wait for the landing AI to land. Can you check this that there are no AIs trying to land on that runway? Thanks 

Edited by fs1

Federico Sucari

Share this post


Link to post

Yes usually there's already another AI on final, but I think it's further than 6000m away.  I have now set this one to 9000 though. Do you think that should be lower?

Share this post


Link to post

Try setting <allowTakeOffDistance>1000</AllowTakeOffDistance>)  to 1000, a smaller value and check if the AI takes off


Federico Sucari

Share this post


Link to post
3 minutes ago, fclaass said:

Yes usually there's already another AI on final, but I think it's further than 6000m away.  I have now set this one to 9000 though. Do you think that should be lower?

Correct. Try a smaller value just for testing purposes. In your XML you have 9000 which is quite high

Edited by fs1

Federico Sucari

Share this post


Link to post

Ok that worked, thank you. However, 6000 is a little tight in my opinion. I get some go-arounds because aircraft are still taking off when another aircraft is quite close with landing.

Share this post


Link to post

Great. I am working on a spacing algorithm so landings will be more separated to each other.

Edited by fs1

Federico Sucari

Share this post


Link to post

I can confirm 6000 leads to many go arounds. Trying to find a happy medium right now. Will try with 8000-10000 and see if that is better. 

Share this post


Link to post
2 minutes ago, DChockey08 said:

I can confirm 6000 leads to many go arounds. Trying to find a happy medium right now. Will try with 8000-10000 and see if that is better. 

This will be resolved once I space out the landing arriving AIs. This will be done in next builds, and will be able to keep lower values 


Federico Sucari

Share this post


Link to post

I have update the links with a new build that fixes CTD. Thanks

  • Like 2

Federico Sucari

Share this post


Link to post
15 hours ago, DChockey08 said:

I can confirm 6000 leads to many go arounds. Trying to find a happy medium right now. Will try with 8000-10000 and see if that is better. 

The flight dynamics of the AI aircraft and the runway layout do also influence the traffic flow. Most AI aircraft have a too short and too slow rollout phase, which will let them not reach the suitable runway exits. Back with FS2004 there was a FDE set by Jan Martin that improved the values of all AI. Sadly, P3D had some changes to the Flight dynamics that made the old AI FDE sets unsuitable. The user Urmel has done a significant work to improve it for AIG OCI. But it is a difficult task to find a balanced setting for approach speeds and landing distance that works at various airport configurations. 


Best,
Christoph

Display resolution: 1920x1080 (8xSSAA)    GPU: 1080TI     CPU: i7-7700K (5.0 OC)    RAM: 16GB     SSD: Samsung 850Evo     Monitor: 27K

FSBetaTesters3.png

Share this post


Link to post

Great work!

Tested on RJTT with the xml entrrence below:

	<Airport>
	<ICAO>RJTT</ICAO>
	<ActiveTakeOffRunway>
		<Runway>R05</Runway>
	</ActiveTakeOffRunway>
	<ActiveTakeOffRunway>
		<Runway>R34R</Runway>
	</ActiveTakeOffRunway>
	<ActiveTakeOffRunway>
		<Runway>R16L</Runway>
	</ActiveTakeOffRunway>
	<ActiveTakeOffRunway>
		<Runway>R16R</Runway>
	</ActiveTakeOffRunway>
	<ActiveLandingRunway>
		<Runway>R23</Runway>
	</ActiveLandingRunway>
	<ActiveLandingRunway>
		<Runway>R22</Runway>
	</ActiveLandingRunway>
	<ActiveLandingRunway>
		<Runway>R16L</Runway>
	</ActiveLandingRunway>
		<ActiveLandingRunway>
		<Runway>R16R</Runway>
	</ActiveLandingRunway>
	</Airport>

What I noticed:

AI pick only the listied runway as well, no more 04/05 landing and 22/23 Take off!

I see one instance ATC tells AI to go 35L which is for "crosswind runway" trick, I guess the crosswind runway trick in ADE/AFCAD is nolonger needed?

Despite I set wind 020/16, AI still picks runway all over the airport, and even head-on takeoff with landing on like 34L/16R or 05/23.

I didn't noticed the "probability based on the number of entries", it seems 22 is the most used rwy for landing and followed by 16L/R, with them low on the entries (and north wind). And I only see one T/O on Rwy05 when it's listed on the top (it's far from apron, compare to default, it's good that any flight actually use it)

Edited by C2615

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,560.00 of $25,000.00 Donate Now
×
×
  • Create New...