Sign in to follow this  
Guest moonrunner

FSX Slew Problem

Recommended Posts

Does anyone know how to correct the 'take off on my own nonstop slew afterburner effect" in FSX. :-samurai Specifically first of all I disconnect my joystick controller fromFSX before entering slew mode. When using Scenery Shortcuts from Abacusall seems to be fine until I attempt to rotate the aircraft 'used as a pointer device' to the right or left. At this time the aircraft 'pointer' starts to move continually in whatever direction I indicate and it will not stop no matter what keys I hit, numeric 5 or F2, until I stop the Scenery Object placement tool. At that point Ican regain control but I have lost the scenery objects that I have just placed with the scenery object placement tool.What my question boils down to is there any adjustments that canbe made in the slew xml that will give me better control over theslew function? I already set the sim speed to slowest.Gary

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Moonrunner, I can't believe that nobody has responded to your post! I'm having similar problems: the slew controls are really flaky, and since I've never used Slew without SDK I'm not sure whether SDK is the problem or whether Slew Mode is screwed up.I'm finding it unusable the way it is... have you found any information anywhere?If so, I'd appreciate your letting me know.Barney Bornn

Share this post


Link to post
Share on other sites

This has been bugging me for a long time as well. I've had this problem in previous versions of MSFS, so it's either a problem with MSFS in general or with my controller. Great to have the problem narrowed down, eh?One solution I have not tried is to pay for FSUIPC. The payware version will allow users to custom calibrate their controllers, which can fix some issues.The other solution, which seems to help me in FSX, is to switch the control to "Mouse Yoke" in the menus as you fly. With the mouse as my primary flight control, the slew seems to behave better. I hope this helps!Jeff ShylukSenior Staff Reviewer, Avsim

Share this post


Link to post
Share on other sites

I went into settings/controls, reset the joystick buttons/axis to default and this went away for me.

Share this post


Link to post
Share on other sites

Hi Jeff, thanks for your response.The first time I tried working with SDK I had the controller for my yoke on. The reason I turned it off was because of control problems. But it doesn't work any better with the controller off, so I don't think paying for FSUIPC would help anyway.Maybe I'll try Micrtosoft support. The problem with that is that you spend huge amounds of time, effort, and sometimes money, and the problem never seems to get solved. Barney

Share this post


Link to post
Share on other sites

Hi Peter,Thanks for your response. I should have mentioned that I turned off my controller... It didn't fix the problem.Barney

Share this post


Link to post
Share on other sites

I'm guessing this all has to do with the sensitivity of the controller when trying to slew within FSX? If so, there are adjustments that can be made to "slow the slew"!Located in the following area; C:Documents and SettingsApplication DataMicrosoftFSXControls is a file named Standard.XML. This can be opened with Notepad, as it's just a plain text file. Down at the bottom for my MS Sidewinder joystick is an area that controls the slew capabilites. Microsoft SideWinder Force Feedback 2 SLEW {65918E60-7590-11DB-8002-444553540000}XAxis0AXIS_SLEW_SIDEWAYS_SET30 <-------this is 100 on default 36YAxis1AXIS_SLEW_AHEAD_SET30 <-------this is 100 on default 36RzAxis5AXIS_SLEW_HEADING_SET30 <-------this is 100 on default 36Dropping the three settings above slows things to a managable speed. I don't like to use the sim speed to slow things down, as that renders the top down view zoom in/out inoperable. Adjust the setting, mine is at 30, to meet your expectations.There are also settings that will allow for adjusting the mouse slew rate, if that is the preferred method.As always, make a backup copy of the file, just in case things get royally messed up.....

Share this post


Link to post
Share on other sites

Meshman, thanks for your response. However, my problem happens whether the controller is on or off. It's not simply a matter of speed, either. Some of the controls don't work properly.I plan to start a new thread when I can be more precise about what happens when I use Slew controls, but I've been out of town and have some other things I MUST do first.I'll post a note here when I start the new thread.Thanks again,Barney

Share this post


Link to post
Share on other sites

I found the answer!It seems that you must turn Num Lock OFF if you want to use the Slew Mode commands that use the Num keys.Thank you all for your responses. If I'd been more precise in my first post it might have saved us all a lot of work.Barney

Share this post


Link to post
Share on other sites

Nope sorry but that didnt fix it for me.Every time I oress the Y (slew) button offit goes. No NUM LOCK or whatever.______________________________________Rob YMA002 - Compass Airlines Australia - a new direction!2846.png

Share this post


Link to post
Share on other sites

Brute force may fix it!I had this problem. In the control assignment window - remove all assignments for slew mode for your controls (yoke/joystick/rudder pedals/throttle quadrants) (except the view commands). All of them!Assign keyboard commands for the slew commands you want to use.Close FSX down. Edit your Standard.xml file (found in the folder "...Documents and SettingsApplication DataMicrosoftFSXControls" if you run WinXP). Examine all entries that reference slew devices and make sure there are no assignments defined.This is an example how it should look like for a throttle quadrant: CH Throttle Quadrant USB SLEW {426DF5E0-5FBA-11DB-8002-444553540000}And for my yoke: Saitek Pro Flight Yoke SLEW {ADF5B4A0-71C1-11DC-8001-444553540000}0PAN_VIEW1This way nothing happens in slew mode until I press my assigned keyboard commands. Take a backup copy of you Standard.xml file before you edit.Hope this helps.Ulf B

Share this post


Link to post
Share on other sites

Funny that this thread should crop up just this moment. Yesterday I found a work-around for the slew issue that didn't involve using the mouse yoke.I wanted to start a slew, so I paused the sim, activated slew, unpaused the sim, and instead of a random, wild jumpy ride as usual, the plane was coasting leisurely backwards. It turns out that some of the clutter on my desk was applying back pressure to the joystick.I tried it several times: apply some back pressure just before using slew, and the airplane doesn't zoom around like a two-year-old hopped up on Lucky Charms. It simply moves back a little, making it much easier to set up screenshots that involve slew. It works for me, I don't know if it will work for you, but I sure hope it does.Jeff ShylukSenior Staff Reviewer, Avsim

Share this post


Link to post
Share on other sites

Aaargh, a self reply. I even had to hunt down this thread to reply to it.My previous information was incorrect. It did work for a while, it doesn't now, and I just don't know why. Ah, well, back to the drawing board.Jeff ShylukSenior Staff Reviewer, Avsim

Share this post


Link to post
Share on other sites

Jeff,What you can also try (apart from deleting ALL controller axis to Slew functions, and only use keys or buttons for Slew):Press F1 before exiting Slew mode, which sets the aircraft on the ground again if it's not on an exact flat surface.Rob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this