Jump to content
Sign in to follow this  
Smoothie02

Route Planner setting Cruising Altitude wrong

Recommended Posts

Hey, I just installed Pilot2ATC to my new computer. I have been trying to fly from EDDF to LSZH and copied the Waypoints out of my Simbrief plan, yet when trying to set a cruising altitude it won't set it correctly.  For example: I set flight level to FL220, and the ATC just randomly set it to FL070. Regardless of what I set (Even tried FL22000 or FL1800000, also tried FL070 which set it to FL021) it will always set the Flight Level to something like FL046, FL0670. I have my flight set to IFR and checked the config settings too, but can't seem to find a setting that would change that. I tried re-installing the whole ATC which didn't help at all, which leaves me thinking this issue is something super obvious that I can't seem to figure out, also I haven't found anyone else having this issue.

I use XPlane 11 and the newest version of Pilot2ATC.

 

Share this post


Link to post
Share on other sites

The default behavior is for the program to enforce Bearing Based Altitude rules as found in much of the world:

Easterly Flights: Odd altitudes

Westerly Flights: Even altitudes

If it makes a change for this rule, it would always just add 1000 feet to the altitude.

You can turn this off by checking the option "ATC Ignores Bearing Based Altitudes" on the FltPlan tab of Config.

It could also be that you are entering airways that have restrictions.  You can check the "Ignore Airway Altitude Restrictions" option on the same page of Config.

Dave

Share this post


Link to post
Share on other sites
20 hours ago, Dave-Pilot2ATC said:

The default behavior is for the program to enforce Bearing Based Altitude rules as found in much of the world:

Easterly Flights: Odd altitudes

Westerly Flights: Even altitudes

If it makes a change for this rule, it would always just add 1000 feet to the altitude.

You can turn this off by checking the option "ATC Ignores Bearing Based Altitudes" on the FltPlan tab of Config.

It could also be that you are entering airways that have restrictions.  You can check the "Ignore Airway Altitude Restrictions" option on the same page of Config.

Dave

I had already tried that, tried unchecking the options and checking them again and that also didn't work. Regardless what I set it will choose a random Altitude from 0 to FL100. I have also tried picking Flight levels at which Satellites probably orbit at and it will still give me something below 10'000 ft. I also tried unchecking the 'Calculate Safe EnRoute Altitude' with no success.

Here's a link to 2 screenshots, (avsim won't let me insert them)

https://imgur.com/a/2BFHmEO

Share this post


Link to post
Share on other sites

Try updating to the latest Public Beta.  It fixes some issues with TOD and related altitudes. 

Share this post


Link to post
Share on other sites

As this particular route is pretty much due South (180 degrees) you would think it should also be an even altitude (FL180, 200, 220 etc). But it seems as though it is structured for traffic and EDDF-LSZH operate at odd altitudes (190, 210, 230 etc). Just something to note in your planning. Pretty common in the real world.


i7-8700K, 16gb DDR4 3200,  RTX 3080 ti, Win 10, P3d V5x, MSFS

Share this post


Link to post
Share on other sites
On 3/24/2022 at 5:40 PM, Dave-Pilot2ATC said:

Try updating to the latest Public Beta.  It fixes some issues with TOD and related altitudes. 

Coming back to this issue. I have now installed version 2.6.3.1 - it connects to X-Plane 11 (version 11.55) and I keep having the same problem. When entering the planned flight level, no matter if I enter 210, 220, 230 -> 250 I usually get FL 67 or with FL250 p2atc sets it to 76. Trying something crazy I set FL500 and it sets it to 152. I am totally out of ideas. Nothing seems to work - any ideas? Running as Admin, disabling plug-ins etc. all tried - de- and re-install too...

Share this post


Link to post
Share on other sites

It very much sounds as if you have the ATC settings set to METRIC as the figures you mention convert to suggested feet.

Check the setting is METRIC-FEET or USA if you prefer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...