Sign in to follow this  
Guest aeroscout

SDK

Recommended Posts

Do you have to install the SDK update also with SP1? Did SDK automatically install when I downloaded from the Disk?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You install the SDK from the disk.You should then go get the SDK update 1 (not the famous SP1)Whether SP1 it needs it I dont know but if you have deluxe you should install the SDK anyways...al

Share this post


Link to post
Share on other sites

There is no need to install the SDK 'anyways'. With Deluxe or not. It's not needed at ALL for regular FS X use! I don't have it installed, so... You only need it if you want to make your own addons or edit complicated stuff. So if you do not need it, just don't install it. It will not benefit you in any way.

Share this post


Link to post
Share on other sites

>There is no need to install the SDK 'anyways'. With Deluxe or>not. It's not needed at ALL for regular FS X use! I don't have>it installed, so... You only need it if you want to make your>own addons or edit complicated stuff. So if you do not need>it, just don't install it. It will not benefit you in any way.Apparently you have never used the }cool toys" in the TrafficToolbox then...Radar Map View of all AI trafficSortable Text List of all AI trafficThe ability to take over and "control" any AIThe ability to "create and control" a new AI a/cet cetera. :-beerchug

Share this post


Link to post
Share on other sites

No, I clearly haven't. And I still do not feel the need to do so. ;) As I said, for REGULAR use the SDK is not necessary. :(But er... it makes you wonder if there are any other (real) goodies hidden in the SDK... ;)

Share this post


Link to post
Share on other sites

On the flipside of the coin, if you plan to use a Utility such as changing a stock airport parking or adding taxiways (old AFCAD) you will need the deluxe version of FSX.The No 1 DVD has a setup for the SDK and then you also need the SDK update version 1a which is on FSInsider.The FSX SP1 also uses the companion 1a version SDK update for certain design/AI taffic features to work correctly.There are Utilities in General Public Beta that work like the FS9 AFCAD program did but you must have a legal copy of the SDK and version 1a update which gives you the current BGLCompiler and schema file that MS uses. These new Airport Utilities are not suppose to have the BGLComplier but use a path statement to the SDK folder that has the version 1a compiler.If you use any type AI Plane traffic the SDK also has the TrafficToolBox dll files which adds a dropdown menu to FSX for working with default and 3rd party addon FP's and AI planes.

Share this post


Link to post
Share on other sites

FWIW I believe you can install the SDK update 1a over the default version with or without having applied the Dec 06 update 1. If you didn't install to the default folder, you might want to run the configSDK.exe tool prior to running the SP1a update (if you haven't already done it). Not sure it is required, but might be good to be on the safe side. scott s..

Share this post


Link to post
Share on other sites

Thanks guys for all the help,I wont be installing the SDK anytime soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this