Sign in to follow this  
Guest kolaf

FSX performance halves in vista vs XP

Recommended Posts

Hi,I recently installed Vista in a dual boot configuration with XP on my C2D E8650, 2GB ram, GeForce8600GT 256MB. With this setup I get around 30 fps as a given location for a given quality (FSX+SP1), but in Vista with various drivers I get about half of that at the same location of the same settings.The main difference I notice between the two operating systems is that when running FSX under XP the CPU utilisation is maxed out for one core and fairly high for the other, while for Vista, utilisation of both cores lie around 60 to 70%. In other words, there seems to be something holding FSX back for some reason, but while loading both cores work at full blast for some time...Does anyone have any good ideas? I would like to get it to work to be able to benefit from the DX10 work implemented in the acceleration expansion pack when it arrives.Any help is appreciated.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Normally XP gives a performance boost compared to Vista, which is why I'm staying with XP, but it's normally around 20-30% faster.You are probably just a bit unlucky it's as high as 50% slower though.On the plus side at least you can prove to yourself XP is faster.You will probably find this difference in improvements is dependent on the settings of FSX such as autogen etc.I don't think you are going to find a magic cure for this but if you do I'll certainly be one of the folks out there to consider changing to Vista if you do.

Share this post


Link to post
Share on other sites

I've found that Vista is very strict with its security protocol. I've found that I've had to run some things as Adminitrator to get them to work as thay would have in XP. I believe that it's all about the User Account Control, but I'm uninclined to disable this feature because it defeats the purpose of having an emphasis on security. It's possible that Vista reserves resources for some of its security features.Another suggestion might be to enable special permissions in the Properties/Security dialogue for FSX.exe, but I'd try running the program as Administrator first.Mike.

Share this post


Link to post
Share on other sites

Fair enough, but the problem isn't that Vista uses too much resources, rather that 40% of my CPU-power is unutilized.

Share this post


Link to post
Share on other sites

>Normally XP gives a performance boost compared to Vista,>which is why I'm staying with XP, but it's normally around>20-30% faster.Thanks for the info. I was considering to install Vista after the release of the SP2 to utilize the fps boost by the DX10 support. But the net result will be no change of fps. I'll stick with XP :-)Ulf B

Share this post


Link to post
Share on other sites

I was thinking the same thing. Smart Close is something I use. Pretty easy, shuts services and programs down then starts them back up when I'm done.Also, may want to disable real time virus scanning or even shut down the anti-virus software completely.

Share this post


Link to post
Share on other sites

I had a similar issue when I first ran FSX on my Dell Inspiron 1520 notebook with Vista. It turned out the power saving setttings were throttling the CPU an not letting it get to 100% load. I ended up installing RightMark CPUClock, which allows you to force the CPU to max performance no matter what the power saving setting is in Vista. All is now good for me on that system with FSX :-)Gary

Share this post


Link to post
Share on other sites

Don't let anyone who doesn't actually use Vista tell you "thats just the way it is, Vista is 30% worse"...etc. Its a common line people see and continue to repeatYes outa the box it is, because Vista has many more things running. Personally I have Vista 64 running at the same exact FPS that my barebones XP install was.What I did was first off google for "Vista performance tweaks"...There are several good guides. The main thing is superfetch. Vista is also very easy as far as shutting down automatic processes. Simply go to CP-Administrative tools-services and disable anything you don't need. No confusing filenames like kda223 etc., everything is described and named with regular words No need for 3rd party addons like in XP.Also do not run Aero. I still keep the new Vista interface, just don't enable aero. Its not worth it anyway.Make sure you have the latest video drivers. The latest forceware pretty much match XP performance at this point. Its gotten alot better over the past few months.Finally, MS released a patch for Vista that fixes a problem with FSX and some memory problem. It works wonders. I found it stickied on the top of a forum somewhere, but a quick search should show it. Its like "Vista OOM" patch or something.If you do all this you shouldn't lose any funtionality that XP had, and you'll have Vista and XP running nearly identical (in FSX and regular windows use). Your also ready for Acceleration and SP2/DX10.

Share this post


Link to post
Share on other sites

Thanks for many good suggestions. I've tried some, confirmed I'm not power-saving, shut down extra services, turned off Aero, set administrator mode for FSX, but to no avail.I do not think this is the problem. If you look at the attached screenshot, you'll see that it runs at 100% while loading, but when in flight it drops, and giving me only approx. 15fps, with cpu-power to spare.http://forums.avsim.net/user_files/178771.jpg

Share this post


Link to post
Share on other sites

Ok, then try this.Add this line to your fsx.cfg file.[JOBSCHEDULER]AffinityMask=nn=2 (do not do 3 like some tweak pages say, if you do that your just telling fsx to utilize 2 cores, which it already does).This will force FSX to stop threading across multiple cores. Don't ask why or how it works, but it gives me and everyone who uses it a 5-10 fps boost. You'd think the more cores the better, but for whatever reason this tweak works great.Do not forget to download that vista patch I mentioned either. Its a must to run FSX on vista.

Share this post


Link to post
Share on other sites

>Thanks for many good suggestions. I've tried some, confirmed>I'm not power-saving, shut down extra services, turned off>Aero, set administrator mode for FSX, but to no avail.>>I do not think this is the problem. If you look at the>attached screenshot, you'll see that it runs at 100% while>loading, but when in flight it drops, and giving me only>approx. 15fps, with cpu-power to spare.>Did you try the update for Vista and games + the 3 GB switch ?How much physical memory do you have?http://i5.photobucket.com/albums/y156/awf1/sign1.jpg

Share this post


Link to post
Share on other sites

I found that XP and Vista run FSX the same on my machine. I do set affinity at 3 to use both cores. Your primary core will still take most of the load except when loading FSX or heavy scenery. SP2 for FSX should help from what the experts are saying.You may have something throttling your system with Vista that is not in XP. Are you using the latest Vista drivers for your video card?

Share this post


Link to post
Share on other sites

The vista OOM patch has already been installed for some time. Setting affinitymask=2 only made things worse. Instead of running both cores at 70%, only one core ran at 70%, while the other idled. My best guess is at some throttling mechanism, but I have no idea of what that might be.Edit: Forgot to mention that I have 2GB RAM, and I just confirmed that my C2D E6850 runs at full speed, 3GHz while running fsx.

Share this post


Link to post
Share on other sites

Check the Blackviper October 9 entry under Current News.[http://www.blackviper.com/]I have no idea what the implications of this are and apparently either does BV yet, but it does make me wonder.Anybody?

Share this post


Link to post
Share on other sites

In my case it was my virus checker. Even disabling it while running fs still something got in the way.I reinstalled and left the checker off-permanently.As my sim computer is not my main computer I am going to risk a future virus for the quite vast performance increase I got in return.http://mywebpages.comcast.net/geofa/pages/rxp-pilot.jpgForum Moderatorhttp://geofageofa.spaces.live.com/

Share this post


Link to post
Share on other sites

That's why I suggested running CPUClock, as one of the monitoring displays shows you both CPU core clock AND throttle (if any).Gary

Share this post


Link to post
Share on other sites

kolaf,What performance do you get if you run FSX full screen? I get terrible performance in Windowed mode (I think due to the way it reverts to Vista Basic when you run FSX) but if I go to full screen it's fine... try that and see if that's your issue too.

Share this post


Link to post
Share on other sites

Ryan,I think you have hit the nail on the head! I recall now that I was getting about half the FPS in windowed mode that I was getting in full screen mode. A bit of experimentation revealed that if any of the windowed window was behind the Vista Start button on the bottom left, that FPS halved. The solution is either to:- run FSX full screen.- run FSX windowed, but resize the window to not cover any of the Vista start button.- run FSX windowed, but set the task bar to auto hide.I use option 3!Gary

Share this post


Link to post
Share on other sites

I haven't tested it yet, but that might be it. I recall noting the big fps reduction from running in a rather small window, to running in windowed maximized. That could have been the reason. Will test and report back.

Share this post


Link to post
Share on other sites

IT WORKED! Setting the taskbar to autohide increased fps from 15 to 20-25 :))Thanks for your kind help everyone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this