Sign in to follow this  
Bob Familton

SOLVED - Can't start FSX after Acceleration Install

Recommended Posts

Hmmm...I installed. and then started FSX and registered online. I then went to load saved flight and it gave me a fatal error.So I started FSX again. It failed again.afxmodulefsx.dllHmmmmmm.....Manny

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I removed all the DLLs from the module folder and deleted the FSX,cfg and restarted.IT bombed again.

Share this post


Link to post
Share on other sites

My FSX.cfg is short.[sOUND]AmbientUIMusicVolume=-6.000000[Display]ChangeTime=4.000000TransitionTime=4.000000[Main]User Objects=Airplane, HelicopterSimObjectPaths.0=SimObjectsAirplanesSimObjectPaths.1=SimObjectsRotorcraftSimObjectPaths.2=SimObjectsGroundVehiclesSimObjectPaths.3=SimObjectsBoatsSimObjectPaths.4=SimObjectsAnimalsSimObjectPaths.5=SimObjectsMiscProcSpeed=9682PerfBucket=5Location=444,190,1476,964,.DISPLAY1[PANELS]IMAGE_QUALITY=1[Weather]WindshieldPrecipitationEffects=1MinGustTime=10MaxGustTime=500MinGustRampSpeed=1MaxGustRampSpeed=200MinVarTime=5MaxVarTime=50MinVarRampSpeed=10MaxVarRampSpeed=75TurbulenceScale=1.000000WeatherServerAddress=fs2k.zone.comWeatherServerPort=80WeatherGraphDataInDialog=0AdjustForMagVarInDialog=1DynamicWeather=2DownloadWindsAloft=0DisableTurbulence=0[DISPLAY.Device.NVIDIA GeForce 8800 GTX.0]Mode=1024x768x32[AccelerationPack]ControlsFirstRun=0HomePageFirstRun=0[CONTROLS]Controls_Default=StandardControls_Current=Standard[TextInfo.1]Latitude=1,1Longitude=1,2Altitude=1,3Heading=1,4AirSpeed=1,5WindDirectionAndSpeed=1,6[TextInfo.2]FrameRate=1,1LockedFrameRate=1,2GForce=1,3FuelPercentage=1,4[TextInfo.3]Latitude=1,1Longitude=1,2Altitude=1,3Heading=1,4AirSpeed=1,5WindDirectionAndSpeed=1,6FrameRate=2,1LockedFrameRate=2,2GForce=2,3FuelPercentage=2,4[slewTextInfo.1]Latitude=1,1Longitude=1,2Altitude=1,3Heading=1,4AirSpeed=1,5[slewTextInfo.2]FrameRate=1,1LockedFrameRate=1,2[slewTextInfo.3]Latitude=1,1Longitude=1,2Altitude=1,3Heading=1,4AirSpeed=1,5FrameRate=2,1LockedFrameRate=2,2[GRAPHICS]SHADER_CACHE_PRIMED=1693500672[Trusted]g:Program FilesAFX DemoAFXModuleFSX.dll.zaannkankkqwckeobeeboiaqireknlhaawwctczn=1E:FSXbglmanx.dll.equiqqrntoztebahaznznrarqkhtqthkebckcarw=1E:FSXGAUGESXGauge.DLL.wbureawictitnntbbktwhrrurzzqeahzihohzcte=2[DynamicHeadMovement]LonAccelOnHeadLon=-0.020000LonAccelOnHeadPitch=-0.010000RollAccelOnHeadLat=0.010000YawAccelOnHeadLat=-0.100000RollAccelOnHeadRoll=0.100000MaxHeadAngle=5.000000MaxHeadOffset=0.300000HeadMoveTimeConstant=1.000000[VirtualCopilot]VirtualCopilotActive=1

Share this post


Link to post
Share on other sites

>Hmmm...>>I installed. and then started FSX and registered online. I>then went to load saved flight and it gave me a fatal error.>>So I started FSX again. It failed again.>>afxmodulefsx.dll>>Hmmmmmm.....>>MannyIs it possible that your save flights (saved in Sp1) won't work in sp2?

Share this post


Link to post
Share on other sites

Try deleting your saved .flt and .fssave files in:C:Documents and SettingsWilliam AshleyMy DocumentsFlight Simulator X Files

Share this post


Link to post
Share on other sites

>>afxmodulefsx.dll>This is the AFX add on module. Edit your dll.xml file (in the same folder as fsx.cfg) and disable your add on dlls and se what happens when you start FSX.Ulf B :-)

Share this post


Link to post
Share on other sites

Sounds like you have an addon that interfaces with FSX via interfaces other than SimConnect. Any of those types of addons will likely need to be updated to work with the new version. I know Pete already has an XPack compatible version of FSUIPC available, you'll need to check your other addon makers and see if they have updates.You can disable one or more of the addons by editing the DLL.XML file.

Share this post


Link to post
Share on other sites

Will do that Tim.I didn't know about the DLL.XMLs to disable each addons without uninstalling themI could use that to and figure out which is the offending one.MAnnyPS I also uinstalled the acceleration reinstalled it.. But now I had to reregister. Doh! I didn't think it would ask me to reregister after an uninstall and reinstall

Share this post


Link to post
Share on other sites

Yup that was it.I had to remove this afxmodulefsx.dllfrom the xml.dll Uninstalling ASX did not help. I think the DLL file remained the HD so you have to remove it from the DLL.XML:)Now, I need put back everything else I took out. Thanks for all the helpMannyPS: All right...all my other addons seem to be ok.. and I have tons of addons...including a whole load of FS9 scenery and aircrafts modified to work in FSX. I haven't tested each one of them..atleast it doesn't prevent me from going into FSX so far. That is very good.

Share this post


Link to post
Share on other sites

Reply from Flight1:

Originally posted by FSDiscovererAn update will be available shortly (probably tomorrow).
CheersMartin

Share this post


Link to post
Share on other sites

>Hi,>>Of course not because ASX and AFX are two different programs.>We would have known if there was a problem with ASX/X>Graphics, a long time ago!!>>Thanks,>Jim>>http://www.hifisim.com/banners/hifi-community-sigbanner.jpg>http://www.hifisim.com/Doh! Now, I have to reinstall ASX.But you can't blame me..you know. Its all too confusing. ;)To tell you the truth.,.when I saw that AFX...dll error message. I thought it was the Acceleration dll that I just installed thats why I came here and started the thread. IF I had realized that it was that AFX package. I would have renamed that dll file and restarted.Oh well!Thanks again.Manny

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this