Sign in to follow this  
Guest SkullxBones

I've Got the Beechcraft Blues...

Recommended Posts

I'm having a few problems with the Baron 58. No matter what I do, it's always hyper-sensitive to pitch. If I twitch my joystick about a millimeter back, the aircraft lurches up faster than cheese through a goose. I'm thinking that my joystick could be having issues, but the weird thing is, it's only with that one aircraft. Any help would be appreciated. :)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Beech aircraft are very light on the controls, one of the delights of flying them after training on Cessnas. Like going from a pickup truck to a BMW ;). The attempt to model this makes sim users think its too sensitive and compared to other models it is. You might want to lower your joystick sensitivity or if you are using a CH yoke and are using CH's manager or better yet FSUIPC payware version you can set up the joystick/yoke to have a progressive input so the first bit of movement is less sensitive.

Share this post


Link to post
Share on other sites

I have to agree with you.....the mooney is a little touchy as well....That's how it's always been with those default planes for me though...Have you calibrated your joystick lately, it could also be that...

Share this post


Link to post
Share on other sites

Here's what I did. Open your aircraft.cfg file in the beech_baron_58 directory and look for this line "elevator_effectiveness = 1.0" under the "[flight_tuning]" section, and change it to "elevator_effectiveness = 0.6" or whatever value you like.Jeff

Share this post


Link to post
Share on other sites

Geofa,I'm curious. Have you had any of the random button presses problem with your Saitek. I have it only once in awhile.Randall

Share this post


Link to post
Share on other sites

Hey, I got a better fix for the pitch problem than the one I posted above. Instead of changing the "elevator_effectiveness" setting, put it back to 1.0 and try changing the "pitch_stability = 2.0". Much softer and smoother.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this