Sign in to follow this  
Followers 0
Guest D17S

FSX stutters at high frame rates - any ideas???

19 posts in this topic

Hello Team!I am having a particularly annoying problem with FSX and once again, seek your advice to mitigate it. I have a pretty beefy machine that runs FSX at pretty high frame rates most of the time - sometimes in excess of 90fps in un-populated areas and down to high 30's in heavily populated areas with heavy scenery. The problem is that there are times when I am running a flight (at high frame rates), but the sim stutters - almost like micro stutters. When this happens, frames jump from 90 to 18 to 8 back to 50 down to 30 up to 45 down to 3 up to 65, etc.......in a matter of seconds, rendering the simulation, not unflyable, but a pain in the butt to handle. I am currently running the latest NVidia beta drivers (7.15.11.7570).Any help in mitigating this issue is appreciated.Sincerely,Dennis D. Mullert

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,Lock your fps at 25 or 30 fps, and I bet that you wont have those stutters.Ulf B

0

Share this post


Link to post
Share on other sites

Yes the first remedy is to lock the fps.I am one of those who gets better overall performance wiith it set to unlimited but try it.Almost all my stutters with fs9 and fsx were caused by a background running process. One by one,close out them out except for the ones that MUST be running and see what happens.Also plz detail when the stutters happen. In turns,random,all the time ect.Any fsx.cfg tweeks,which version.Like blurries,stutters can be hard to fix but luckily are also easier.So system,version,tweeks and stutter details.

0

Share this post


Link to post
Share on other sites

Dennis, Try this and see if it helps. Set your prerender to 1. The default is 3 and leave your FPS at unlimited. It helps me and my reasoning is that the cpu and the gpu stay more in sync with each other. I think that we are seeing the problem when they are out of sync. I use to have surges in FPS at low density rural areas untill I changed the pre render. See what happens it may work for you also.Jim

0

Share this post


Link to post
Share on other sites

>Where do I set the prerender?Thanks,RonIt's a setting in the nVidia Control Panel--it's under "Manage 3D Settings".@JimThat is an interesting suggestion, I'll have to try it@ DennisI get the same as you..on Unlimited, I get micro stutters sometimes. Therefore I am now locking at 30. Keep in mind that frames, stuttering, etc. is affected by your BufferPools setting, and also by your TEXTURE_BANDWIDTH_MULT setting. Research those two to find a good mix for your system.As far as I can tell, the interrelationship of 1) framelocker2) bufferpools3) TEXTURE_BANDWIDTH_MULTis the key to FSX smoothness I think.RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

0

Share this post


Link to post
Share on other sites

Hey Rhett!Thanks for your reply!I went back to nHancer and set the pre-render from 3 to 1. I also locked my frams within FSX to 30. My Texture_Bandwith is set to 4096. So far I noticed better performance in teh area where I was running into trouble. Will continue to test.Thanks again!Sincerely,Dennis D. Mullert

0

Share this post


Link to post
Share on other sites

>Hey Rhett!>>Thanks for your reply!>>I went back to nHancer and set the pre-render from 3 to 1. I>also locked my frams within FSX to 30. My Texture_Bandwith is>set to 4096. So far I noticed better performance in teh area>where I was running into trouble. Will continue to test.>I think you mean MAX_TEXTURE_LOAD is 4096. (4096 for FEX's new clouds)I was talking about TEXTURE_BANDWIDTH_MULT and if you have TEXTURE_BANDWIDTH_MULT at 4096, that is not a value you want. You want something like 20,30,40,60, or 80 there.RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

0

Share this post


Link to post
Share on other sites

I agree. The trick is smoothness at an acceptable framerate.One trick is to lock frames at a minimum sustainable level. For instance if frames are bouncing between 25 and 100, lock them at 25. The HP the system had been using to drive FPS to > 25 will then be Forced to other tasks. 25 FPS is just shy of cinema quality frame rates. An actual 25FPS will be (virtually) smooth as a movie. Any "stuttering" at 25FPS means every frame is NoT making it to the screen. Some are simply repeating. Thus, "the stutters." The trick then, is NoT to increase the FPS. The trick is to allow Every one of those 25FPS to make it to the screen. As was suggested, work with the fsx.cfg line: {DISPLAY}TEXTURE_BANDWIDTH_MULT=XFor instance, if you are locked at 25FPS and have TBM set to 40, the system will render (in the background) 40 FPS and attempt to "Fire" then into your 25FSP environment. The idea is to fill-in any of those 25 FPS the system is failing to xfer to the screen. If this strategy is successful, the stuttering effect will be reduced. However, there will be a point of diminishing returns. This additional rendering uses resources. Lots. Once the HP loss becomes > the frame fill-in return, higher TBMs will actually Reduce performance. Find that number, then back-off a couple of clicks. With our current 128SP cards, 80 is about as high as we can go. It will be interesting to see if the 280 can use this function any better. In any case, above 100 is A LoT. There's no way Any system is going to render 4000FPS. Just use common sense. It appears this is what the Nvidia control panel's new function "Maximum pre-rendered frames" is doing. We'll have to see how these two (seemingly identical) functions play together. They could turbocharge or auto-destruct. We'll see. If there are pauses or big uber-stutters when panning to view in a new direction, there's hope. MSFS has confirmed FSX CaN use greater than 512M. Good news! So type in the New lines (Square brackets):{BUFFERPOOLS}Poolsize=XThis will set aside a portion of your vcard's memory for quick access. It's like a manual Vcache setting. With my 512M card, I'm using 50M (50000000). If you have a gig on board, go crazy. But not too crazy. Watch for decreased performance as you shift Vram away from ops into cache (the BP).{GRAPHICS}TEXTURE_MAX_LOAD=1024This tells FSX the maximum amount of Vram available on your card. Might be best to leave that alone.BTW, are you running a 32 or 64 bit op system? We're gonna want to see how your system's virtual ram is holding up. OOMs might end up being a bigger problem with these new 1G cards.

0

Share this post


Link to post
Share on other sites

Hi Rhett!I have mine set to 40. Do you recommend I lower it????????Sincerely,Dennis D. Mullert

0

Share this post


Link to post
Share on other sites

Thank you for your explanation, Sam. There are some confusing statements that may very well mislead other users, so perhaps we can take the opportunity to clear this up.TEXTURE_BANDWIDTH_MULT: please note that setting higher than the equivalent of your locked frame rates will tend to increase stutters, not decrease them.BUFFERPOOLS is not some kind of Vcache but rather the size of each pool of vertex and index buffers.TEXTURE_MAX_LOAD is not the amount of VRAM available, it is just the maximum size of textures loaded. The equivalent setting is Global Max Texture Size in the Options - Display menu. The default max value will load a maximum texture size of 1024 x 1024 pixels. Setting to 2048 in the cfg file will allow the use of textures that are 2048 x 2048 pixels.Once again, here are the comments from Phil Taylor made on his blog and repeated on this forum many times. By the way, he refers to Raf, who is Rafael Cintron, one of the very knowledgeable developers at ACES.TEXTURE_BANDWITH_MULT (EDIT:this is in DISPLAY, not GRAPHICS)The mysterious sounding TEXTURE_BANDWITH_MULT is our first target. This is a setting in the {DISPLAY} section of the file, formatted like this:{DISPLAY}TEXTURE_BANDWIDTH_MULT=nWhere n can range from 10 to some reasonable value that is related to your frame rate limit.From Rafael Cintron, part of the FS Graphics and Terrain team, comes this description:

0

Share this post


Link to post
Share on other sites

Dennis,There is no way to say what setting will work best for your system. When I set mine lower I get more stutters than when set higher. What I would try is this to determine what is best.Set your TBM to 40, add a bufferpools tweek and try a setting of 56000000 and lock your frame rate at 28. Fly a test in a area where you know you will get good performance, that way you will be able to see what effect the settings have easier and actually know for sure that it is a setting that made a difference or stutter rather than a scenery problem. Try LSZA for a location. Load the default Cesna and see how smoothe or not it is when looking around the VC. Take off and fly around. DONT LOOK AT THE FPS COUNTER. Just get a feel for smoothness and stutters. Do the same again but change the TBM to 20 and leave your FPS locked at 28. Perform viewing and flying and once again dont look at the FPS counter. After that change your TBM to 56 and perform flight. Also Try this with the Pre Render set at 2, the default is 3. For me the last works best with very smoothe and virtually stutter free flight. Many people may say 56000000 is too high for the bufferpool but for some reason it works fine for me. You may find it needs to be lower. If all the above has problems or you see no improvement then something else is not right. Also it is very important to make sure your Hard Drive(s) are properly defraged. A fragmented HD will always cause problems with FSX.Good Luck and let us know how it went.Jim

0

Share this post


Link to post
Share on other sites

Thanks Jim!I will follow your advice and give it a try.Thanks!Sincerely,Dennis D. Mullert

0

Share this post


Link to post
Share on other sites

Yep as Jim was saying you must test it all yourself. There are too many system variables at work here, to tell you what you should be running.I am running a TBM of 40 (was 60, just moved it back), with Bufferpools of variously 12 million to 64 million. I am presently framelocking at 30. I'm still testing myself...since I just built this machine about 2 months ago.RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0