Archived

This topic is now archived and is closed to further replies.

Manny

Weird sound problem in FSX - please help!

Recommended Posts

Hi,I have a very strange problem with the sound in FSX after I've loaded an a/c. From start after loading an a/c all is fine but after some time the sound starts to crunch almost like my speakers were broken and then after a couple of more minutes all sound in FSX is gone - both the a/c specific sounds like from the engines etc but also all other sounds like the ATC voice - FSX goes 100% silent just as if I had switched the sound off. After this happens and exiting FSX I don't get any sound when listening to a song in Media Player either and this problem remains until I log out from Windows (Vista) and then logon again when the sound is back to normal. When I have this problem I have checked my sound devices and Windows reports they are working just fine which unfortunately isn't the case...Anyone had a similar problem?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

My only problem has been with intermittent loss of the right channel. Some things to check would be:1. Reinstall latest sound driver.2. Set sound to 16 bit if currently at 24 bit.3. Eliminate background applications.4. Try another sound card.ArtBiostar TF560-A2+, Athlon 64X2-6000+, 4GB RAM, Geforce 8800GTS-320MB, 500W PSU, 250GB HD, FSX (SP1-SP2), Vista Home Premium 32 bit, CH Yoke & Pedals, 22" WS LCD monitor

Share this post


Link to post
Share on other sites

Hi Art and thanks for your input!I have just re-installed the latest version of the drivers for my soundcard and will now see if that has solved the problem. If not I will check those other things you mentioned.Thanks again!

Share this post


Link to post
Share on other sites

>Hi,>>I have a very strange problem with the sound in FSX after I've>loaded an a/c. From start after loading an a/c all is fine but>after some time the sound starts to crunch almost like my>speakers were broken and then after a couple of more minutes>all sound in FSX is gone - both the a/c specific sounds like>from the engines etc but also all other sounds like the ATC>voice - FSX goes 100% silent just as if I had switched the>sound off. After this happens and exiting FSX I don't get any>sound when listening to a song in Media Player either and this>problem remains until I log out from Windows (Vista) and then>logon again when the sound is back to normal. When I have this>problem I have checked my sound devices and Windows reports>they are working just fine which unfortunately isn't the>case...>>Anyone had a similar problem?I get that once in awhile with my wilco 737 on external view while taxi'ng. (S) key. when I cycle back to cockpit view then external view again it seems to clear up.

Share this post


Link to post
Share on other sites

I found out by now that I only get this problem when using the Super80 a/c, however I have part from this problem recently had quite alot of OOM errors which are truely annoying when FSX just quits by itself onced you got this so I now plan to switch over to 64bit Vista which will hopefully make better use of the 4GB RAM I have installed and maybe if I'm lucky the totally fresh install of Vista and FSX and all addon products will also solve the sound problem I have with the Super80.

Share this post


Link to post
Share on other sites

I have that problem too and I have to reboot. I suspect its the memory corruption.Have your OCed your machine?Manny

Share this post


Link to post
Share on other sites

Hi Manny,Yes, my PC is overclocked but 100% stable and very well cooled with help from watercooling both for the CPU, the graphics card and the North bridge so I doubt that is what's causing the OOM errors I've seen. I rather think they are due to a far from optimally written FSX...

Share this post


Link to post
Share on other sites

You maybe right.. But I have been puzzled about this for a while now. and for some reason I suspect the memory. Either the RAM or the Video memory. In fact, I am thinking or ordering another pair of stick to see if my hunch is right. :)But this is not some scientific analysis. Its just a hunch!The sure way to find out is..We should note down all our OC settings and then reset to standard stuff and use it for a few days to see if our problem exist. That would narrow it down a little bit. :)Manny

Share this post


Link to post
Share on other sites

I agree. 1st try resetting the FSB to its default setting. That 'Fixed' a previous sound problem I had. I had the sound problems at > 380mhz/FSB. All was OK at 370. Go figure. If it works, give it some time to settle in . . . then try an earlier (or later) release of your Vcard driver. Also remove all 3rd party codac packages. This sound problem started, and continued for months during that last dry spell when Nvidia wasn't releasing any new drivers. At 400Mhz, removing the sound device in Device Mgr, then in & out of "Sleep" fixed it until the next reboot. That was a real pain, so I just left the FSB clock at 370. Sometime during this latest flurry of drivers (and cards) the problem magically resolved and I could finally reset my FSB to its previously (also) stable 400Mhz-O/C. All's well and I still don't know (100%) what it was.

Share this post


Link to post
Share on other sites

Yep...for sure hardware/overclocked-related issues can be interesting and tricky and not always do they seem logic ;)

Share this post


Link to post
Share on other sites

>Hi Manny,>>Yes, my PC is overclocked but 100% stable and very well cooled>with help from watercooling both for the CPU, the graphics>card and the North bridge so I doubt that is what's causing>the OOM errors I've seen. I rather think they are due to a far>from optimally written FSX...The cause and solution for OOM in FSX has been cussed and discussed ad nauseaum.Please read this Wiki article to first understand the cause, and then apply the solution provided... ;)http://www.fsdeveloper.com/wiki/index.php?title=OOM_ErrorPlease take note that this article I authored has been vetted by Phil Taylor at MS/ACES, and is recommended in his official blog... ;)

Share this post


Link to post
Share on other sites

Thanks for pointing out this interesting reading and from what I understood the best possible thing you can do currently to avoid these OOM errors is to get at least 4 GB of RAM or more and then go with Vista 64 bit - correct?

Share this post


Link to post
Share on other sites

Almost. Physical ram is NoT involved in OOMs. This stuff is kind of a tally-sheet the ops system keeps to forecast ram the program Might need in the immediate future. It's called VS or Virtual Size. With a 32bit system, each program has a default limit or 2Gs. The 3G switch takes that limit to 3Gs. A 64bit system takes that limit to 4Gs for a 32bit program. Finally, a 64bit program running on a 64bit system takes that limit to 8 terabits. That ought to do it. BTW, I've been able to OOM FSX at > 4Gs on a Vista 64. FS11 had Better be (at least available as) a 64 bit program.

Share this post


Link to post
Share on other sites

Thank you for a very easy to understand explanation, guess I'll try the Vista 64bit approach since I already have 4 GB RAM in my box and hopefully that will if not totally solve the OOM errors at least make them happen not so often.

Share this post


Link to post
Share on other sites