Archived

This topic is now archived and is closed to further replies.

sniper31

FSX SP2

Recommended Posts

Hi AllI wonder if someone could clarify a few queries I have with FSX SP2. I always thought that it gave you a DX10 preview mode and solved some issues with multi player mode but I have noticed recently that addons are now requiring SP2 to be installed e.g. Aerosoft Mega Frankfurt and CS 757. As I don't think my graphics card will support DX10a (an 8800 GTS) and I don't use multi player mode I have never bothered to install SP2 but I am now begining to wonder whether I should.I have read in another post that in SP2 is installed it can be removed without causing any problems with FSX so I think I will give it a go.Other forums suggest that the addons I have should work provided DX10 preview is turned off but can anyone say if I am likely to have any issues with theseLevel-D 767PMDG 747Wilco Airbus 1 & 2 and 737, 777CLS DC10Feelthere ERJ145DA FokkerFlight 1 ATRUK2000Traffic 2005Any comments would be appreciatedThanksPhil

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Phil, for DX10 you need to be running Vista - are you? If not, no DX10. You're 8800GTS is a DX10 compliant board, but not DX10a, and it's nothing to worry about. So, if you don't see the DX10 preview option in the FSX menu - you must be using XP. I'll leave the option of using SP2 up to you. I use it and yes, some addon's now require it and that will likely become more and more prevelant. Regards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - 174.74 beta Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites

If you have some of the earlier UK2000 Extreme airports, they may need a free update for SP2, but the later releases are fine, and the VFR Airfields release is fine. They will all work with SP1 as well. Check their forum for more info. http://www.uk2000scenery.com/I don't have any of your other listed items, so can't help there, sorry. ;)

Share this post


Link to post
Share on other sites

Kendall, TimThanks for your replies. I am running Vista Home Premium edition but to be honest it's not DX10 thats the attraction to SP2 but compatibility with some of the new addons. I'll just have to install SP2 and download that updates where necessary and see what happens.ThanksPhil

Share this post


Link to post
Share on other sites

Phil,You should be okay. BTW, I just recently upgraded my system, and before that, I was running a GeForce 8800 GTS video card with FSX and SP2 without any problems. I did enable the DirectX 10 preview from within FSX after installing SP2, and it DID work with that video card, albeit my FPS were a bit slower. Furthermore, SP2 does offer more than just DirectX 10 support. Of major note for me, was better support for quad core and eight core processors, and some sound config options that made using a second sound device easier. Bottom line, it should work for you just fine.

Share this post


Link to post
Share on other sites