Sign in to follow this  
Guest craigjjs

Problem with CH Yoke button assignments

Recommended Posts

Hi,I am using a CH Yoke. I assign green to Button 9 (a button on top of the left handle) and red to key "Q". Sometimes Button 9 works, sometimes not. Sometimes button 2 (left trigger assigned to brake) somehow becomes red command (usually after the braking test at the start of taxi). I have changed the FSX assignments to make sure the button and key were assigned to nothing in FSX. I have had this happen several times. I have previously assigned these keys in FS9 for FS2Crew Level D without any problem.I am also wondering if there is a problem from assigning one key to red, but no key to green, and assigning one yoke button to green, but no yoke button to red.Any ideas what might be happening. Thank you.Craig

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

BryanI am having the same issue with the assignment of red and green. I set it up in start center to use button 1 and 2 but neither works in flight

Share this post


Link to post
Share on other sites

Some of my beta testers used CH yokes during testing.I'll let them chime in as I dont have a CH yoke.You have the latest CH drivers installed?Bryan

Share this post


Link to post
Share on other sites

According to the CH website, there are no free standing drivers. The device is plug n play. My Vista is up to date. The yoke calibrates fine and works fine with all other applications.Craig

Share this post


Link to post
Share on other sites

I have thrustmaster top gun afterburner joystick and I have the same problem.Not possible to assign joystick button from start center, and I have the cd driver istalled that work fine with other applicationWhat can I do ?C. Branchini

Share this post


Link to post
Share on other sites

I've been attempting to figure out the CH yoke problem. Using FS9. I am unable to get the yoke to respond to the saved commands. Until I can get it to respond, I'm just clicking with the mouse, and have assigned the left/right arrows from the keyboard. The keyboard keys do respond.I'll keep messing around with it, and should I find a work around, I'll post it here.Chip B.@-@http://fs2crew.com/betateam.jpg

Share this post


Link to post
Share on other sites

My yoke will respond to the commands, if I reassign before every flight. Otherwise, I lose the assignment. The other problem is that my left trigger button (FSX default assigned to brake) starts giving red commands for no apparent reason. Finally, I have Red mapped to "Q". If I give the [control] [Q] command to change my angle of view, it gives the Red command (usually 'gear down'). I have been checking the FSX assignments to be sure they did not revert or change, but they remain unassigned as I set them. I hope this can be resolved because I really enjoy FS2Crew.By the way, I know you Airbus guys use sticks instead of yokes, but after many years of use, my hands are just too configured to a yoke to change now.Craig

Share this post


Link to post
Share on other sites

Hi Craig,I wish I had a CH yoke so I could try to reproduce this.Try using different buttons and please ensure that you "save" your assignments via the FS2Crew Start Center; that would probably explain why you're loosing the assignment after the first flight. Remember you can still use the Keyboard or Mouse to interface with FS2Crew until we figure out your CH yoke.Cheers,Bryan

Share this post


Link to post
Share on other sites

Thanks Bryan. I have been using the mouse, but I prefer the yoke. Does it matter whether you assign one key for red, but no key for green (assigning green to yoke only)? It gives an error message, but I understood it to indicate that the green would not be mapped to a key.Craigjjs

Share this post


Link to post
Share on other sites

I have a ch yoke and I have had no problems with the keys as I have key 3 green set to my top red button on the left handle and my red set to the bottom red button.During my part of beta testing I had good luck with the yoke and pedals.I will try and set the keys to other buttons and see what happens. Jeff

Share this post


Link to post
Share on other sites

I use Saitex X52 and me neither can't set keys to stick.Not that it matters to me, as I don't use those anyway but just to let you know.Even key assigments don't work for me. (I know it must be at my end now heh).But product is just grrreatt...

Share this post


Link to post
Share on other sites

I'm glad to hear you like it :-)FS2Crew is just using Direct X (Direct Input)... it's pretty universal.The one controller that I know will not work is an XBox controller, but what real flight simmer would use that other than TDragger :-)Have you ever had issues with other addons that use Direct Input?May I ask what you mean by "stick"?Cheers,Bryan

Share this post


Link to post
Share on other sites

Joystick was what I meant. I don't actually know other problems as I only use this for fs9.And I have a profile for it, so it may cause problems setting up keys.But as I said, its not a problem for me, hopefully it's just at my end and not a real bug.

Share this post


Link to post
Share on other sites

Jeff above reported no problems with his CH joystick...Ergo, it's just a matter of figuring out why some of you have issues with your CH joystick while others do not.What's the common denominator between you? There must be something.Cheers,Bryan

Share this post


Link to post
Share on other sites

Ergo, I have tried to make a problem and so far everything is working.Is there a conflict with FSUIPC on your computer and the CH Yoke? Jeff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this