Archived

This topic is now archived and is closed to further replies.

Kimber

Increasing FSX max memory from 2GB to 3GB plus?

Recommended Posts

Hi thereI have been having a few problems with FSX crashing on me. It happens every time FSX goes over 2GB...I have been informed by PMDG support it

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There is some risk involved that your system could act up, but in theory it shouldn't.This is my boot.ini file ...[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /usepmtimermulti(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional 3GB userva" /fastdetect /NoExecute=OptIn /usepmtimer /3GB /userva=2560I added the second line where you see /3GB /userva=2560The 2560 was recommended by I think someone from ACES. If you have a ton of memory you probably could double this value.This change made a huge difference on my FX-62 system and did nothing for my i7 965 system.Check out this webpage --> http://blogs.msdn.com/ptaylor/archive/2007...aks-in-sp1.aspxWhen your system boots you will have 30 seconds (timeout) to decide which line to choose, so if you are going to use FSX you use the second line by arrowing down and pressing enter.To get to the boot.ini file go to Control Panel, System, Startup Recovery and then EDIT. I copied and pasted the boot line and then add the addition switches at the end of the line.BE CAREFUL NOT TO SCREW UP THIS FILE. YOUR SYSTEM WILL NOT BOOT.By the way, what motherboard are you using?

Share this post


Link to post
Share on other sites
Hi thereI have been having a few problems with FSX crashing on me. It happens every time FSX goes over 2GB...I have been informed by PMDG support it

Share this post


Link to post
Share on other sites
The 2560 was recommended by I think someone from ACES. If you have a ton of memory you probably could double this value.
This is really bad advice... the value has nothing to do with available memory!This deals with allocation of virtual memory space in a 32 bit operating system.This variable can have any value between 2048 (2 GB) and 3072 (3 GB) megabytes in decimal notation. Windows uses the remaining address space (4 GB minus the specified amount) as its kernel-mode address space.

Share this post


Link to post
Share on other sites

To clarify one thing:To get 3GB of address space for FSX, you can use the switch.To get 4GB or more of address space, you have to use 64bit version on windows, be it XP or Vista.

Share this post


Link to post
Share on other sites
This is really bad advice... the value has nothing to do with available memory!This deals with allocation of virtual memory space in a 32 bit operating system.This variable can have any value between 2048 (2 GB) and 3072 (3 GB) megabytes in decimal notation. Windows uses the remaining address space (4 GB minus the specified amount) as its kernel-mode address space.
No this is actually good advice, As you say it allocates VM but it does that not just for the program and kernel, but video memory is also addressed in this space, which could be 512mb+ (Depending on the size of your card. If you use the whole 3GB for the program, you are limiting both the system kernel, and Video memory to the remaining 1GB address space. So while you may not get a OOM from the program, you may get it from the kernel if you don't restrict the program space lower. The system needs some breathing room too. This is why Phil Taylor recommended the USERVA=2560 switch.

Share this post


Link to post
Share on other sites
No this is actually good advice,
The bad advice was "doubling the value" :(

Share this post


Link to post
Share on other sites
No this is actually good advice, As you say it allocates VM but it does that not just for the program and kernel, but video memory is also addressed in this space, which could be 512mb+ (Depending on the size of your card. If you use the whole 3GB for the program, you are limiting both the system kernel, and Video memory to the remaining 1GB address space. So while you may not get a OOM from the program, you may get it from the kernel if you don't restrict the program space lower. The system needs some breathing room too. This is why Phil Taylor recommended the USERVA=2560 switch.
What Bert was saying is bad advice is this statement: If you have a ton of memory you probably could double this value.Which is not true2560 was suggested from Phil Taylor because he understood that there were larger VM video adapters out there and more coming. 2560 is a safe value and those with larger VM cards may need to LOWER that value as many around here had to do in order to tune based on their 768-1GB video cards. Some found 2560 was still too high and OOM would still occur so they would drop the value. The value should be raised/lowered in lots of 128 for testing but can be fine tuned using the value of 64The only time the edit is needed for XP or Vista is when the following criteria are met:A. The OS is 32bitB. OOM errors appear with any memory amount installedC. Its been said editing this into any 32bit OS even when no OOM error is seen may be of benefit with FSX SP2/AccelerationThe addition of the value has been known to interfere with the function of other applications. With XP the user can set up boot.ini lines for loading Windows with and without the switch. With Vista the user must address the cache edit through the command line tool. Both of which are covered in this tuning guidehttp://www.simforums.com/forums/forum_posts.asp?TID=29041

Share this post


Link to post
Share on other sites
There is some risk involved that your system could act up, but in theory it shouldn't.This is my boot.ini file ...[boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /usepmtimermulti(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional 3GB userva" /fastdetect /NoExecute=OptIn /usepmtimer /3GB /userva=2560I added the second line where you see /3GB /userva=2560The 2560 was recommended by I think someone from ACES. If you have a ton of memory you probably could double this value.This change made a huge difference on my FX-62 system and did nothing for my i7 965 system.Check out this webpage --> http://blogs.msdn.com/ptaylor/archive/2007...aks-in-sp1.aspxWhen your system boots you will have 30 seconds (timeout) to decide which line to choose, so if you are going to use FSX you use the second line by arrowing down and pressing enter.To get to the boot.ini file go to Control Panel, System, Startup Recovery and then EDIT. I copied and pasted the boot line and then add the addition switches at the end of the line.BE CAREFUL NOT TO SCREW UP THIS FILE. YOUR SYSTEM WILL NOT BOOT.By the way, what motherboard are you using?
The Motherboard is = ASUS

Share this post


Link to post
Share on other sites
How do I get to the boot.ini file?Kimberly
Kimberly, if you are running Vista, the procedure is different, see Nick's post above.Also, if you are running Vista 64 as I suspect, although your signature says "Vista 34",the setting does not apply, period.

Share this post


Link to post
Share on other sites
The bad advice was "doubling the value" :(
Oops! That's what I get for reading and responding to a post right after I wake up! :(

Share this post


Link to post
Share on other sites

Hi, i am in fact running 64 bit...I shall be chaning my postand trying to get this issue sorted out...Kimberly RJ

Share this post


Link to post
Share on other sites
Hi, i am in fact running 64 bit...I shall be chaning my postand trying to get this issue sorted out...Kimberly RJ
first of all.. 12GB of memory is useless to FSX.. totally. FSX itself even on a 64bit OS will only use 4GB max however the OS and other apps running with FSX will each have access to additional (over and above the 4 FSX will use)You are already on a 64bit OS therefore you do not have OOM issues with the OS but the app itself is different... If you are NOT using FSX SP2 or Acceleration then you MUST manually edit the fsx.exe file to use the LARGEADDRESSAWARE flag. RTM and SP1 require that flag be in the EXE file or the application will not have access to >2GBhttp://msdn.microsoft.com/en-us/library/bb...DRESSAWARE_flaghttp://www.fsdeveloper.com/wiki/index.php?title=OOM_Error If you ARE running SP2/Acelleration on a Windows 64bit OS you got a problem that has nothing to do with OOM. It very well could be defective memory too. Unless you need 12GB of memory for video editing, large graphics projects or engineering/scientific applications that WILL actually USE it.. I say pull all but 6GB (3x2GB) leaving the blue slots populated and retest. It the crash still occurs, swap those three for the ones you pulled.

Share this post


Link to post
Share on other sites

Hi thereThe computer is used by my boyfriend who is an engineer and uses it for rendering so we need the 12GB memory.I have had the person who built the PC over tonight who looked at the memory and ran some tests which have shown there are no hardware defects including the memory.For your information I am using FSX SP2.I have now adjusted the

Share this post


Link to post
Share on other sites
Hi thereThe computer is used by my boyfriend who is an engineer and uses it for rendering so we need the 12GB memory.I have had the person who built the PC over tonight who looked at the memory and ran some tests which have shown there are no hardware defects including the memory.For your information I am using FSX SP2.I have now adjusted the

Share this post


Link to post
Share on other sites