Archived

This topic is now archived and is closed to further replies.

Guest dakrisht

Autogen Tweak

Recommended Posts

Hey All:Do Autogen tweaks still apply for FSX + Acceleration Pack (I believe the latter updates FSX to SP2?)If I have autogen at minimum, I don't see any buildings in Los Angeles (including downtown or the stadiums) but if I go up one setting in autogen, I get a little performance degradation... I've read that this is because of the trees?Curious what you guys/gals have to say about autogen tweaks and FSX... And if they still apply, a link to what I need to do would be fantastic.Running Win XP-32 | FSX + Acceleration Pack | Ultimate Terrain X | AMD Phenom II X4 940 OC'd @ 3.5Ghz | nVidia GeForce 9800 GTX |Thanks everyone!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I've read that others still use autogen tweaks successfully, tweaking the cfg file and also using replacement autogen downloads. I've also read where it's of the opinion that these particular tweaks are not applicable to FSX SP2, Accel. I've used all of the autogen tweaks with FSX SP2 and I'm still unsure whether there was degradation of performance or performance help.

Share this post


Link to post
Share on other sites
I've read that others still use autogen tweaks successfully, tweaking the cfg file and also using replacement autogen downloads. I've also read where it's of the opinion that these particular tweaks are not applicable to FSX SP2, Accel. I've used all of the autogen tweaks with FSX SP2 and I'm still unsure whether there was degradation of performance or performance help.
Thanks, Deke.I've heard the same about FSX SP2 - would love to hear some more thoughts...

Share this post


Link to post
Share on other sites

The autogen tweak is on of the best there is. One of the main benefits of using the tweak over the slider alone is that you can use a higher slider setting with it which allows for denser autogen fill up close, while limiting the number of objects. I made a post at Orbx with comparison images and more info:http://orbxsystems.com/forums/index.php?to...g84306#msg84306When using the tweak the ratio between trees and buildings can make a big difference. The default ratio is 3/2. For example 2200/1600 gave me 3fps less than 2200/1700.Here's an example you can use which produces excellent results, meaning the appearance of denser autogen while giving a higher framerate. Test this with dense or very dense autogen set in game and see how it goes. For me to use extremely dense set in game I need to use a 300MB Buffer Pool to eliminate stutters. With this tweak and extremely dense set in game I maintain 100% autogen coverage within a radius ofthe plane, and the reductions are all msde outside of the radius. [TERRAIN]TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2400TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=1600Also take a look at this post, and if you want read through the thread as people are getting good results, specifically with the 200MB-400MB Buffer Pool. http://orbxsystems.com/forums/index.php?to...g85361#msg85361

Share this post


Link to post
Share on other sites

Well, I've heard that auto-gen tweaks are not practical for FSX - SP2, including fsx cfg tweaks and replacement autogen files. However, my thoughts on the subject are that I'm going to try Silly Eagle's tweaks since there's nothing to lose and everything to gain.

Share this post


Link to post
Share on other sites
With this tweak and extremely dense set in game I maintain 100% autogen coverage within a radius ofthe plane, and the reductions are all msde outside of the radius. [TERRAIN]TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2400TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=1600
AFAIK This tweak simply limits the maximum amount of objects on every square km (or something like that). So when you fly above an area where there are a lot of trees (like the default FSX maximum) you will most certainly see less trees around there with this tweak when you have the slider at extreme: the amount will be limited to what you set in the cfg. It's logical fps will be better because there is less autogen. You most certainly will not maintain 100% autogen coverage around the plane at all times! When you fly above area's with less autogen, you will see indeed just as much autogen as you would without this tweak... because you haven't reached the maximum yet... But then of course the fps will also be the same. The ONLY advantage this tweak gives you AFAIK is that you will have real extreme FSX default autogen in places where the amount of objects is less than the set maximum: as soon as there are more objects by default, the tweak will limit the objects. Without this tweak and simply a lower autogen setting ingame, autogen would be less everywhere, also in rather empty area's: but with this tweak rather empty area's will still have extreme dense autogen while maximized area's will have less (the max you set). Er... does anyone still follow me...? :( Sounds rather complicated... Let me explain it with some (fake) numbers:Default autogen settings in cfg is 4500 (if I am not mistaken). So with autogen at extreme you will see 4500 trees in a maximized area. In an area with less trees you will see (for instance) 1500.With autogen at normal (for instance) you will see 2000 trees in a maximized area and 750 in an area with less trees (again: fake numbers, it's the idea that counts). So there is less to be seen everywhere.But with autogen trees at 2400 in the cfg and the slider to extreme, you will see 2400 in a maximized area (so it's limited, hence higher fps) but... 1500 in an area with less trees (so it's not limited, hence the same fps).Again, the numbers are fake and I don't know how this EXACTLY works (so correct me if I am wrong), but I do know that you will NOT maintain 100% autogen coverage in all area's! You will only keep 100% coverage in area's where the amount is below the max and hence fps will stay unchanged.Man, I used way to much words to explain something simple... :(

Share this post


Link to post
Share on other sites

Thanks everyone, I'll try adding the autogen settings in my .cfg file.Question: Should my Autogen slider be set to Maximum? Wouldn't that destroy fps? Maybe normal? How about "scenery complexity"?Finally, why does everyone keep saying to use FPS limiter at 30fps?

Share this post


Link to post
Share on other sites
So when you fly above an area where there are a lot of trees (like the default FSX maximum) you will most certainly see less trees around there with this tweak when you have the slider at extreme:
Well take a look at this. I'm using a value of 3000/2000 here, yet I stuill get 100% autogen fill around the aircraft. If avsim deletes the image for being over size you can view the post/thread below with several other images with various max per cell values. http://orbxsystems.com/forums/index.php?to...g84544#msg84544goldset6.jpg

Share this post


Link to post
Share on other sites
Well take a look at this. I'm using a value of 3000/2000 here, yet I stuill get 100% autogen fill around the aircraft. If avsim deletes the image for being over size you can view the post/thread below with several other images with various max per cell values. http://orbxsystems.com/forums/index.php?to...g84544#msg84544
Nice screens!I've used the values you mentioned:[TERRAIN]TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2400TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=1600And set my Autogen Density Slider to MAX and my Scenery Complexity in the middle.I'm gadding some jaggies when turning/climbing, not to my liking at all! ;) It just not smooth...Could nHancer solve these issues?Edit: Tried using nHancer with the settings specified in Nick's post, still not able to achieve a smooth flight... Autogen just feels like its loading graphics every time I go forward a few feet while flying???Thanks!!!

Share this post


Link to post
Share on other sites

With that 4.2 GHz i7 you could probably run it at 10,000/10,000 :( I've had weird experiences with autogen. I can run max autogen slider in downtown chicago with incredibly smooth FPS (locked at 36), but if I go out into the great plains where there is next to nothing, it stutters like crazy. MAKES NO SENSE!!!

Share this post


Link to post
Share on other sites
With that 4.2 GHz i7 you could probably run it at 10,000/10,000 :( I've had weird experiences with autogen. I can run max autogen slider in downtown chicago with incredibly smooth FPS (locked at 36), but if I go out into the great plains where there is next to nothing, it stutters like crazy. MAKES NO SENSE!!!
Yes it doesYou have to think outside the box... or at least know the box a bitthe reason is because of NO or little autogen. The application has issues when there is no load on the system as well as too much... that is why the FPS LIMITER solution works. Those places where you have little autogen and stutters are throttled by the limter and will not allow FSX to stutter. Those places such as cities where you need more resources it allows them because the frame lock is set to UNLIMTED but the FPS limter controls the output and does not allow the frame rate to go hi/low creating stuttersSee here for details: http://forums1.avsim.net/index.php?s=&...t&p=1551461It corrects the issue of running UNLIMITED frame lock and stutters caused by Vsync introduced with SP1/Sp2

Share this post


Link to post
Share on other sites
Yes it doesYou have to think outside the box... or at least know the box a bitthe reason is because of NO or little autogen. The application has issues when there is no load on the system as well as too much... that is why the FPS LIMITER solution works. Those places where you have little autogen and stutters are throttled by the limter and will not allow FSX to stutter. Those places such as cities where you need more resources it allows them because the frame lock is set to UNLIMTED but the FPS limter controls the output and does not allow the frame rate to go hi/low creating stuttersSee here for details: http://forums1.avsim.net/index.php?s=&...t&p=1551461It corrects the issue of running UNLIMITED frame lock and stutters caused by Vsync introduced with SP1/Sp2
Sorry Nick but that little app did nothing for my system. In fact it gave me less consistent performance than I had previously when locked at 36 from within FSX. The bufferpool setting doesn't change anything on my system either.This is of course assuming my problem was stutters. What was happening was that every second or so i got some static sound. When it went static-ey, my FPS dropped at the same time. I lowered my autogen setting to dense and since then it has stopped. Over downtown chicago with max slider I didn't get ANY of this static sound. Only out in the middle of nowhere. I used to get it on my "old" laptop occasionally too.

Share this post


Link to post
Share on other sites
Well take a look at this. I'm using a value of 3000/2000 here, yet I stuill get 100% autogen fill around the aircraft. If avsim deletes the image for being over size you can view the post/thread below with several other images with various max per cell values. http://orbxsystems.com/forums/index.php?to...g84544#msg84544goldset6.jpg
Not to be a downer-but does anyone think that shot looks very real...at least what a shot from an aircraft at that altitude would look like?A confession of one who has never thought autogen looked very real-so take it as that..

Share this post


Link to post
Share on other sites
Not to be a downer-but does anyone think that shot looks very real...at least what a shot from an aircraft at that altitude would look like?A confession of one who has never thought autogen looked very real-so take it as that..
Agreed, which is why I use the autogen tweak to remove buildings entirely and pack in the trees, which don't look right either, but better than nothing.

Share this post


Link to post
Share on other sites
Sorry Nick but that little app did nothing for my system. In fact it gave me less consistent performance than I had previously when locked at 36 from within FSX. The bufferpool setting doesn't change anything on my system either.This is of course assuming my problem was stutters. What was happening was that every second or so i got some static sound. When it went static-ey, my FPS dropped at the same time. I lowered my autogen setting to dense and since then it has stopped. Over downtown chicago with max slider I didn't get ANY of this static sound. Only out in the middle of nowhere. I used to get it on my "old" laptop occasionally too.
If you have a 1GB 285 or 280 card the solution for the sound static/cracke issue in relation to autogen level IS to raise bufferpools to between 450-490Condition: http://forums1.avsim.net/index.php?s=&...t&p=1552508Solution: http://forums1.avsim.net/index.php?s=&...t&p=1552743http://forums1.avsim.net/index.php?s=&...t&p=1552773Result: http://forums1.avsim.net/index.php?s=&...t&p=1553055It can and has been repeated/confirmed as a fix for that exact issue but it does require a >450MB bufferpool setting to work in which only 1GB Nvidia cards (single core) will worknow that is also specific to the chipset and the drivers being used as well.

Share this post


Link to post
Share on other sites

"If I have autogen at minimum, I don't see any buildings in Los Angeles (including downtown or the stadiums) "I didn't read the op's post closely enough-but in answer to this question-is this not the "scenery complexity" slider? Set that to the right and see if your downtown buildings show up.I run the sim with buildings turned off and trees maximized, and the scenery complexity slider to the right.For me -this gives more realism (the high res textures show thru that are normally covered by autogen)-there are trees that gives the 3d perspective, and all airport buildings-city buildings, custom structures, and obstacles appear.

Share this post


Link to post
Share on other sites
I run the sim with buildings turned off and trees maximized
How do you accomplish this, Geofa?

Share this post


Link to post
Share on other sites
How do you accomplish this, Geofa?
Open your fsx.cfg- Under the Terrain heading:TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4000TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0Then, turn your scenery complexity slider all the way to the right.Note-some have said setting the buildings to 0 can cause crashes-I have had none-but you may want to try a small number first.

Share this post


Link to post
Share on other sites
Open your fsx.cfg- Under the Terrain heading:TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4000TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0Then, turn your scenery complexity slider all the way to the right.Note-some have said setting the buildings to 0 can cause crashes-I have had none-but you may want to try a small number first.
Thanks Geofa... I will give it a shot...

Share this post


Link to post
Share on other sites

It worked for me and after 15 minutes of low and slow flying around Miami, no crashes. Thanks!

Share this post


Link to post
Share on other sites
If you have a 1GB 285 or 280 card the solution for the sound static/cracke issue in relation to autogen level IS to raise bufferpools to between 450-490It can and has been repeated/confirmed as a fix for that exact issue but it does require a >450MB bufferpool setting to work in which only 1GB Nvidia cards (single core) will worknow that is also specific to the chipset and the drivers being used as well.
I still get static even after setting bufferpool to 490000000 and using that FPS locker set to 36 fps. Albeit not as much, it is still too much to fly with. Should I try a higher bufferpool yet?I'm on the rampage formula X48 board with a Q9550 at 3.4 GHz, a GTX280 stock speed, and 8 GB DDR2 set to 1066. Vista Ultimate 64 if that matters. 182.08 drivers too.

Share this post


Link to post
Share on other sites
I still get static even after setting bufferpool to 490000000 and using that FPS locker set to 36 fps. Albeit not as much, it is still too much to fly with. Should I try a higher bufferpool yet?I'm on the rampage formula X48 board with a Q9550 at 3.4 GHz, a GTX280 stock speed, and 8 GB DDR2 set to 1066. Vista Ultimate 64 if that matters. 182.08 drivers too.
Lets not confuse a 'static' type noise when switching from interior to exterior views on certain aircraft which can be recovered by tapping the "Q" (sound on/off) button twice with constant garbled audio and higher autogen levels. The first issue I mentioned is not the same... however if this is something you can relate to autogen level and BP does make some change then it is the issue at hand.I can tell you that the problem can change with video drivers versions although there is no 'magic' version that works for everyone, and there have even been a few I have seen report that setting PCIE SPREAD SPECTRUM in the BIOS to DISABLED (which everyone should anyway) can have an positive effect on the issue. Past that most of the posts I have seen around raising bufferpools on the 2x series Nvidia cards to beteen 450 and 490 does the trickFor a test you could try 512000000 (512MB) however that may cause autogen graphic spikes at the same time

Share this post


Link to post
Share on other sites

Raising it to 512 didn't improve it any. Setting the autogen slider to dense does make the static go completely away. Even at very dense I can hear the static and see its effects on my FPS.

Share this post


Link to post
Share on other sites
Raising it to 512 didn't improve it any. Setting the autogen slider to dense does make the static go completely away. Even at very dense I can hear the static and see its effects on my FPS.
The issue is specific to the motherboard/drivers and not so much FSX. It has been around for about 2 years and effects P35, x38, x48 and their variant chipsets. There have been some who have simply RMA'd their board for the issue and new product solved the problem. Vgbaron resolved this sound issue that way. You may fall unfortunately into that category. I do know that Noel could not use any driver higher than 169.21 without the problem appearing until the bufferpool tweak came alongI would say based on the autogen slider only needing to hit 'very dense' and not 100% you do have a bit of a problem with that boardI have never had a system display the issue so I have not had any way to run a local diagnostic to see if it could be pinpointed to the exact cause however I do suspect it is chipset support component or circuit design related and because the problem appears on more than one manufacture of motherboard I also suspect it has something to do with a Intel standard circuit design for their chipset products all the motherboard manufactures use to design their boards.

Share this post


Link to post
Share on other sites

That's pretty discouraging to think it might be a problem with my board. That thing cost me nearly 300 dollars. I already had to RMA the first one I got. I'm past the RMA period on this one anyways.I think this is where I blame FSX instead because all my other games work perfectly... :)I'm entirely happy with "dense" settings anyways. I just thought I would try to get it to work with max sliders because it looks pretty neat. I think I'll see what I can kick the buildings up to and set trees to something low like 500 or 1000 and see if that makes static. I like seeing lots of buildings... trees and other vegetation not so much.

Share this post


Link to post
Share on other sites