Archived

This topic is now archived and is closed to further replies.

Propeller

Everything but 60 FPS is unsmooth

Recommended Posts

HiI have an Nvidia GTX 260 and play FS9. The problem is that the sim is unsmooth if 60 FPS is not reached. If the FPS is locked at 60, it works very well if the computer can keep that value. If the FPS is locked to a lower value, 30 for example, the sim is stuttering, but the FPS is still stable and kept at 30. Also setting it to Unlimited makes the same problem.I'm quite sure that the problem is because of my video card (GTX 260), had a 7900GTX before, and bought the GTX 260 a few months ago. I have tried with new PSU (Corsair 650W), new CPU (Phenom II X4 3.2 GHz) , new RAM (4GB) , and new HD (WD caviar black), and still having this problem. I've also tried many drivers, two OS (win XP and 7) but the problem remains.Anyone knows why?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try enabling Vsync.
I've already done that. I've tried APPLICATION, OFF, ON, and also combined with TRIPPLE BUFFERING. ON causes most stuttering. OFF seems almost smooth but gives a lot of tearing.

Share this post


Link to post
Share on other sites
Are you enabling from the application or from the driver control panel?
I'm using nHancer, and enabling from there.

Share this post


Link to post
Share on other sites
Is it even possible to control Vsync in FS9?
It's been awhile since I've run FS9 so I don't remember for sure, but ISTR the option being present.

Share this post


Link to post
Share on other sites
The problem is that the sim is unsmooth if 60 FPS is not reached. If the FPS is locked at 60, it works very well if the computer can keep that value.
It

Share this post


Link to post
Share on other sites

Hardell, I think it's just something you have to live with. I'm in the same boat as yourself. I used to have a 19inch LCD and was able to hold 60fps is pretty much all situations and everything was very smooth. Now I've upgraded to a 24inch LCD and HD clouds from REX and am struggling to maintain that 60fps in some situations. I've found in my set up that I must have fps limited to 60 or 30 FPS to get stutter free peroformance (esp when turning)...but even if fps falls off 60 just a bit, I can def tell that its not as smooth, esp because I use TrackIR. I'm now forced to lower my AA, but considering how massive this screen is, I'll take that trade.Many people will try to argue and tell you that all this is BS and the sim is very smooth at 24fps as long as it is locked there. I just believe they haven't experienced fs9 locked at 60fps on a good system, or something along those lines...but to each his own.

Share this post


Link to post
Share on other sites
Hardell, I think it's just something you have to live with. I'm in the same boat as yourself. I used to have a 19inch LCD and was able to hold 60fps is pretty much all situations and everything was very smooth. Now I've upgraded to a 24inch LCD and HD clouds from REX and am struggling to maintain that 60fps in some situations. I've found in my set up that I must have fps limited to 60 or 30 FPS to get stutter free peroformance (esp when turning)...but even if fps falls off 60 just a bit, I can def tell that its not as smooth, esp because I use TrackIR. I'm now forced to lower my AA, but considering how massive this screen is, I'll take that trade.Many people will try to argue and tell you that all this is BS and the sim is very smooth at 24fps as long as it is locked there. I just believe they haven't experienced fs9 locked at 60fps on a good system, or something along those lines...but to each his own.
Thanks for your input.So, older video cards, like my previous one (7900GTX), are in general better in keeping a smooth sim even if they can't keep the FPS at the refresh rate, right? My brother is using my old card, and everytime I try his FS9 it's a completely different experience when it comes to this. No stuttering at all. Both Unlimited and a locked value gives excellent results.I'm quite sure that something is wrong with my setup, cause the stuttering is so obvious. Like I said before, locked at 60 is the only thing that works. I wouldn't complain about this if the sim was able to keep 60 FPS all the time, but it can't do that. Every single slight drop gives a stutter. Unlimited is worse. And locking it to another value than 60, makes it even worse, even though the FPS is kept stable at the locked value.

Share this post


Link to post
Share on other sites

It can't be that your old 7900GTX is better for FS9 than your brand new GTX 260. Is that possible?FS stuff is so confusing... I'm getting afraid of buying a new system.

Share this post


Link to post
Share on other sites
It can't be that your old 7900GTX is better for FS9 than your brand new GTX 260. Is that possible?
If we're talking about how much FPS the card can deliver, the GTX 260 is way better than 7900GTX. But when it comes to smooth playing, if not 60 FPS is reached, then the 7900GTX was much much better, for me.Is it possible that my GTX 260 card is broken or damaged in anyway?

Share this post


Link to post
Share on other sites

Hi, I need a final word about this now. I've been in contact with XFX support and they finally told me to contact the reseller, which I did. The reseller accepted my description of the problem and is now letting me send my GTX 260 to them so they can have a look at it to see if something is wrong. But, I just want to make sure that it is actually possible NOT having the problems I have in FS9 and FSX. If they can't find anything wrong with my GTX 260, I will have to pay.So, do you recognize these problems in FS9/FSX?- FSX is reporting sudden quick changes in FPS, to 100-200, often, even though V-sync is on.- FPS set to UNLIMITED in FSX, is almost unplayable. The image freezes all the time for short periods.- In FS9 the freezing/stuttering is not as bad as in FSX, but it's still there. Locked at 60 FPS works good, but anything else gives the same problem like the ones in FSX.The MAIN PROBLEM is the freezing/stuttering. Let's say you're in spot view and watch the aircraft from the side. Apply full thrust and keep the camera angle. Then focus on a static object, beside the runway, in the image, and I can see that the object is freezing for a short time, every now and then, which means the whole picture has had the same problem.It's also easy to see this if in cockpit view and making a normal, quite slow, 360 degree turn. The image outside the cockpit window freezes very short in the turn and then it's smooth for a second and then freezes short again, and so on.Is it actually possible to get rid of these problems in FS9/FSX?Is it possible to play FS9/FSX smooth without any freezing/stuttering problems?Thanks

Share this post


Link to post
Share on other sites

As ive said, I have the exact same experience you have, and have had it both with the 8800gts and gtx 260 cards. Mine has no stutters if set to 30 or 60 fps (note my monitor refresh rate is 60Hz), but if set to any other number, I get stutters. I beleive everyone has this but just interprets the stutters as being smooth...same as some people are more then happy with getting 25 fps while im not happy if I dont get above 40.

Share this post


Link to post
Share on other sites
HiI have an Nvidia GTX 260 and play FS9. The problem is that the sim is unsmooth if 60 FPS is not reached. If the FPS is locked at 60, it works very well if the computer can keep that value. If the FPS is locked to a lower value, 30 for example, the sim is stuttering, but the FPS is still stable and kept at 30. Also setting it to Unlimited makes the same problem.I'm quite sure that the problem is because of my video card (GTX 260), had a 7900GTX before, and bought the GTX 260 a few months ago. I have tried with new PSU (Corsair 650W), new CPU (Phenom II X4 3.2 GHz) , new RAM (4GB) , and new HD (WD caviar black), and still having this problem. I've also tried many drivers, two OS (win XP and 7) but the problem remains.Anyone knows why?
It's time for Nick's guide ... http://www.simforums.com/forums/forum_posts.asp?TID=29041

Share this post


Link to post
Share on other sites

I've been experiencing the exact same thing. I had an AMD Athlon 64 with a Radeon X800 and I remember how 30fps felt very smooth.I've since upgraded, and with both an 8800GT and my current GTX285 I've been having the stutter issue. But as you say, when locked at 60 it's great, smooth as silk.Locking to anything other than 60 gives a stutter at a steady rate that depends on what you locked to.I'm now in the process of tuning my FS9 setup to maintain >60 fps at all times. That seems to be the only solution.

Share this post


Link to post
Share on other sites
I've been experiencing the exact same thing. I had an AMD Athlon 64 with a Radeon X800 and I remember how 30fps felt very smooth.I've since upgraded, and with both an 8800GT and my current GTX285 I've been having the stutter issue. But as you say, when locked at 60 it's great, smooth as silk.Locking to anything other than 60 gives a stutter at a steady rate that depends on what you locked to.I'm now in the process of tuning my FS9 setup to maintain >60 fps at all times. That seems to be the only solution.
Thanks for your input. What makes me so frustrating about this is that some cards and setups seem to run quite smooth at any FPS. I tried the integrated ATI Radeon HD3300 graphics on the motherboard, and there was no problem at all locking the FPS at 30 for example. Very smooth. Actually I think the problem is about Vertical Sync. That some cards, in FS, can't handle the sync with the monitor's refresh rate, and becasue of that makes these short constant freezes if the FPS is not the same as the refresh rate. I don't know if this is true, I'm not an expert when it comes to this.I haven't been playing FS seriously for five or six months I think. Almost all my time with FS since then, I have been dealing with those stutters/freezes but I think I'm giving up now. And I don't think the reseller will find anything wrong with my GTX 260 if I let them have a look at it. It performs very well in other games, and gives good results in 3D mark, so I think, sending the card to the reseller will only result in me having to pay for the service since they wont find anything that's wrong.

Share this post


Link to post
Share on other sites
Thanks for your input. What makes me so frustrating about this is that some cards and setups seem to run quite smooth at any FPS. I tried the integrated ATI Radeon HD3300 graphics on the motherboard, and there was no problem at all locking the FPS at 30 for example. Very smooth. Actually I think the problem is about Vertical Sync. That some cards, in FS, can't handle the sync with the monitor's refresh rate, and becasue of that makes these short constant freezes if the FPS is not the same as the refresh rate. I don't know if this is true, I'm not an expert when it comes to this.I haven't been playing FS seriously for five or six months I think. Almost all my time with FS since then, I have been dealing with those stutters/freezes but I think I'm giving up now. And I don't think the reseller will find anything wrong with my GTX 260 if I let them have a look at it. It performs very well in other games, and gives good results in 3D mark, so I think, sending the card to the reseller will only result in me having to pay for the service since they wont find anything that's wrong.
You're very right about v-sync. If i force my vsync off, I get no stutters at all at any FPS but I get terrible tearing which is even worse. I've tried and failed on many occasions to correct it. Since, I have learned to live with it. The only advice I have is try an older CRT monitor and see how it is.

Share this post


Link to post
Share on other sites
HiI have an Nvidia GTX 260 and play FS9. The problem is that the sim is unsmooth if 60 FPS is not reached. If the FPS is locked at 60, it works very well if the computer can keep that value. If the FPS is locked to a lower value, 30 for example, the sim is stuttering, but the FPS is still stable and kept at 30. Also setting it to Unlimited makes the same problem.I'm quite sure that the problem is because of my video card (GTX 260), had a 7900GTX before, and bought the GTX 260 a few months ago. I have tried with new PSU (Corsair 650W), new CPU (Phenom II X4 3.2 GHz) , new RAM (4GB) , and new HD (WD caviar black), and still having this problem. I've also tried many drivers, two OS (win XP and 7) but the problem remains.Anyone knows why?
Typing fast on the fly so please excuse for mispelling and such...You dont mention if you are using DX10 preview or not, so I will assume DX9. However you can try this for both.Try this first - Make sure FSX is shutdwon, go into your Nvidia control panel Turn Vsync=OFF, Start FSX and Go into display settings in FSX and set FPS limit to 24-34. Fly, What happens? If that doesnt help you try: download Rivatuner and install it. In the Start/program menu you will find D3DOverride, start it and run it with FSX may help in some situations by forcing tripple buffering.You can download Rivatuner here: http://downloads.guru3d.com/RivaTuner-v2.2...wnload-163.htmlHope that helps you.

Share this post


Link to post
Share on other sites
Typing fast on the fly so please excuse for mispelling and such...You dont mention if you are using DX10 preview or not, so I will assume DX9. However you can try this for both.Try this first - Make sure FSX is shutdwon, go into your Nvidia control panel Turn Vsync=OFF, Start FSX and Go into display settings in FSX and set FPS limit to 24-34. Fly, What happens? If that doesnt help you try: download Rivatuner and install it. In the Start/program menu you will find D3DOverride, start it and run it with FSX may help in some situations by forcing tripple buffering.You can download Rivatuner here: http://downloads.guru3d.com/RivaTuner-v2.2...wnload-163.htmlHope that helps you.
I run almost only FS9, but when trying FSX it has been set to DX9. I've tried DX10 once, but did not make any difference. Regarding your suggestion for FSX, I actually can't try it now. I don't have FSX installed at the moment. I'll try that later.I've tried D3DOverride before and there was no difference at all.

Share this post


Link to post
Share on other sites
I run almost only FS9, but when trying FSX it has been set to DX9. I've tried DX10 once, but did not make any difference. Regarding your suggestion for FSX, I actually can't try it now. I don't have FSX installed at the moment. I'll try that later.I've tried D3DOverride before and there was no difference at all.
Sorry to be such a doofus, I read right over the FS9 part...Have you looked into reducing unnecessary services are running in the backround?Sounds like you have something running in the backround like some kind of kind of polling service, some Antivirus can be rude that way as well.

Share this post


Link to post
Share on other sites
Sorry to be such a doofus, I read right over the FS9 part...Have you looked into reducing unnecessary services are running in the backround?Sounds like you have something running in the backround like some kind of kind of polling service, some Antivirus can be rude that way as well.
I've tried with clean installation of both Win Xp and Win 7 and there was no difference and also when having optimized the OS. I am sure that the problem is not because of background services or antivirus etc. As I said before, 60 FPS is running perfect when reached, which makes a background/antivirus problem seem quite impossible. I am in contact with the reseller of my GTX 260 and, in the last mail, they told me that they've read about other people having problems with exactly the same card as I have. Now I'm waiting for a second reply, and I hope can get another card that can run FS.

Share this post


Link to post
Share on other sites