Archived

This topic is now archived and is closed to further replies.

DAL488

OOM Errors gpt the nest of me

Recommended Posts

I first starting getting OOM errors a couple years ago after installing Ultimate Terrain USA. Flights with the PMDG747 or LDS 767 would end in OOM. I applied the /3GB switch solution and have used that successfully ever since. Until recently...I purchased the Leonardo Maddog 2008, which is awesome. But I got my first OOM as I approached KBWI last weekend. I thought it was just a fluke as I was on the second leg of a 2-leg flight. I re-flew the leg this morning and got the OOM; this time I got worried. I looked at my /3GB settings and decided to change the userva from 2900 to 3070, which I calculated that I could do (I think...). So, re-flew the flight again. All worked well, and I touched down at KBWI, figuring I'd licked it, and then BAM! OOM...So, I've done all I can do with the /3GB switch. UT and the Maddog (plus traffic, etc) must just be too much.I have successfully flown to other US airports (which were surrounded by Ultimate Terrain), so I'm crossing my fingers that maybe this is a KBWI-only issue. I guess the guaranteed solution is to uninstall Ultimate Terrain, but I REALLY love it.I think that this was my first arrival at night with the Maddog. Does anyone know if Ultimate Terrain is more of a memory hog at night? Maybe shutting of those street lights would help??James

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I first starting getting OOM errors a couple years ago after installing Ultimate Terrain USA. Flights with the PMDG747 or LDS 767 would end in OOM. I applied the /3GB switch solution and have used that successfully ever since. Until recently...I purchased the Leonardo Maddog 2008, which is awesome. But I got my first OOM as I approached KBWI last weekend. I thought it was just a fluke as I was on the second leg of a 2-leg flight. I re-flew the leg this morning and got the OOM; this time I got worried. I looked at my /3GB settings and decided to change the userva from 2900 to 3070, which I calculated that I could do (I think...). So, re-flew the flight again. All worked well, and I touched down at KBWI, figuring I'd licked it, and then BAM! OOM...So, I've done all I can do with the /3GB switch. UT and the Maddog (plus traffic, etc) must just be too much.I have successfully flown to other US airports (which were surrounded by Ultimate Terrain), so I'm crossing my fingers that maybe this is a KBWI-only issue. I guess the guaranteed solution is to uninstall Ultimate Terrain, but I REALLY love it.I think that this was my first arrival at night with the Maddog. Does anyone know if Ultimate Terrain is more of a memory hog at night? Maybe shutting of those street lights would help??James
I never saw you mention that you modified your fs9.exe...Did I just misread?-P

Share this post


Link to post
Share on other sites
I never saw you mention that you modified your fs9.exe...Did I just misread?-P
OMG... I just remembered that sometime ago I installed a "no CD" fs9.exe. I just went into it and sure enough it did NOT have the "App can handle > 2gb addresset" checkmarked!!I'm crossing my fingers that that will handle.As an additional note, I realized that I didn't change the userva to 3070 from 2900; must have forgot to same or something. Anyway, will leave at 2900 for now.James

Share this post


Link to post
Share on other sites

Keep us posted.As well switching to 64bit OS cured my OOM errors. Never had one again since I ditched the 32bit OS. Loads of stuff installed (scenery, all the top planes PMDG and so on). Nary a hitch....Best FS9 add on I ever got was my 64bit OS :(

Share this post


Link to post
Share on other sites

The change to FS9.exe to allow the >2GB addresset has solved the OOM. After successfully landing at KBWI, I changed to all sorts of different views to "stress" it and all was okay. It didn't even cross my mind that I had switched to a different FS9.exe. Amazingly, it must have been nearly a year ago, and I only just started seeing the OOM errors again, primarily because I had not flown complex aircraft.So, thanks for the great reminder; you triggered my memory! Am relieved that it was just a simple fix.BTW, sorry for my stupid typos in the title of this post. It should say "...got the best of me" Kinda embarrassing...James

Share this post


Link to post
Share on other sites
The change to FS9.exe to allow the >2GB addresset has solved the OOM. After successfully landing at KBWI, I changed to all sorts of different views to "stress" it and all was okay. It didn't even cross my mind that I had switched to a different FS9.exe. Amazingly, it must have been nearly a year ago, and I only just started seeing the OOM errors again, primarily because I had not flown complex aircraft.So, thanks for the great reminder; you triggered my memory! Am relieved that it was just a simple fix.BTW, sorry for my stupid typos in the title of this post. It should say "...got the best of me" Kinda embarrassing...James
My pleasure James,Thanks for taking the time to report back. I think it was my very first IT instructor who taught me KISS:Keep It Simple Stupid and always start your troubleshooting by eliminating the most obvious and simplest fixes first because it sucks to troubleshoot for days and come back to something stupid...Also, as said above, I strongly advise the move to a 64 bit OS. Also the best move I ever made in my 15+ years of simming. I really cant echo that one enough but I will try...64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 Bit 64 BitGlad you are all sorted!-Paul

Share this post


Link to post
Share on other sites

James or Paul,I do not have >3GB yet .. but where is the checkbox for:"The change to FS9.exe to allow the >2GB addresset has solved the OOM."And does it apply to All OS's running FS9 with normal FS9.exe or just the "no-CD" fs9?

Share this post


Link to post
Share on other sites
James or Paul,I do not have >3GB yet .. but where is the checkbox for:"The change to FS9.exe to allow the >2GB addresset has solved the OOM."And does it apply to All OS's running FS9 with normal FS9.exe or just the "no-CD" fs9?
all fs9 exes. Theres a special program you use to edit it...the name slips my mind, but I just recently did it. I'm sure someone will give you the name of it, or you can search for the recent discussion of this.

Share this post


Link to post
Share on other sites
all fs9 exes. Theres a special program you use to edit it...the name slips my mind, but I just recently did it. I'm sure someone will give you the name of it, or you can search for the recent discussion of this.
Is the switch/program? permitting FS9 to use e.g. 4GB of real memory?What does it do?

Share this post


Link to post
Share on other sites
Is the switch/program? permitting FS9 to use e.g. 4GB of real memory?What does it do?
Vonmar: There's much more to the 3GB switch than just changing the fs9.exe. See this thread; scroll down to the 4th post:http://forums1.avsim.net/index.php?showtop...6&hl=memory(Note: there are some silly typos in these instructions; e.g. - I sometimes say "fsx" and just mean "fs9". So, try not to get confused.)James

Share this post


Link to post
Share on other sites
My pleasure James,Thanks for taking the time to report back. I think it was my very first IT instructor who taught me KISS:Keep It Simple Stupid and always start your troubleshooting by eliminating the most obvious and simplest fixes first because it sucks to troubleshoot for days and come back to something stupid...Also, as said above, I strongly advise the move to a 64 bit OS. Also the best move I ever made in my 15+ years of simming. I really cant echo that one enough but I will try...64 Bit 64 Bit 64 Bit 64 BitGlad you are all sorted!-Paul
I hear you Paul. I just can't justify the expense when I've got fs9 working fine with the 3GB switch. Obviously, if I started getting OOMs again, I'll reconsider.However, regarding FPS: I understand Win 7 is better than Vista, but I will still likely see a drop in FPS if I migrate to Win 7. Going to XP 64 just doesn't make sense to me, considering that Win 7 is out. So, my long range goal is to get a new system a year or two from now, and that's when I'll make the switch to a 64 bit system. James

Share this post


Link to post
Share on other sites
Vonmar: There's much more to the 3GB switch than just changing the fs9.exe. See this thread; scroll down to the 4th post:http://forums1.avsim.net/index.php?showtop...6&hl=memory(Note: there are some silly typos in these instructions; e.g. - I sometimes say "fsx" and just mean "fs9". So, try not to get confused.)James
Ok, but the link you used did not show more that one post?

Share this post


Link to post
Share on other sites
Ok, but the link you used did not show more that one post?
Hmmm, worked okay for me. Nevertheless, here's what I wanted you to see (sorry for the length):Procedures for enabling the 3GB Switch.I use WinXP; not sure about Vista. The instructions below reference WinXP Pro, but I've done this on WinXP Home. The two steps are below. Remember, you do this at your own risk. Also do searches on this forum for "/3GB switch", "OOM", and "Out of Memory" to learn more. And search google for "/3GB switch" and "/userva" and you'll find the Microsoft tech pages describing this stuff.________________________________________________________________STEP 1 -Here's how to enable the 3GB switch (thanx to Michael Swannick):Adding the 3GB switch is very simple. You first need to locate your machines Boot.ini file which should be located in the root of your main system drive. (Be aware that this file may be hidden and marked as read-only initially.) You will want to open this file in a program such as Notepad to edit it properly.Before adding the 3GB switch though it is important to note that the switch is very picky, and requires that every device and driver on your system be fully WinXP compatible in order to work at all. If anything in the system is not compatible, Windows will not load at all when restarting with the 3GB switch activated. The only way to then remove the switch from the Boot.ini file so that Windows can load is to either mount the drive in another system and manually change the boot.ini file, or reformat the drive and re-install Windows. Both solutions are far from ideal.To safely add the 3GB switch we recommend adding a second instance of the OS in the boot.ini, and add the /3GB switch to that second version.----- default boot.ini without 3GB Switch -----This is what a default boot.ini file will look like. (This may differ from system to system.)timeout=30default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWSmulti(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Pro"----- updated boot.ini with 3GB Switch -----This is what the updated version should look like. Notice the /3GB that has been added to the second instance of the OS line.timeout=30default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWSmulti(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Pro"multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Pro with /3GB" /3GBAnd if you have a 512MB or greater video card, you'll need to add the /Userva=???? also. I have a 512MB card, and 2900 works for me so:multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Pro with /3GB" /3GB /Userva=2900If you have a 640MB or 768MB card, you'll need to experiment.Once you have updated your boot.ini file accordingly and have saved the changes, simply restart your system for the changes to take affect. When your system reboots you will be given the option to choose either the standard Windows XP version or the 3GB switch enabled Windows XP version. If you choose the 3GB version and it fails to allow Windows to properly load, just restart your system and you will be given the two options once again, where you can then choose the standard Windows XP version to load. Either way, if it works or doesn't, you can then remove whatever line you don't need in the boot.ini file. Alternately, you may wish to leave both settings so that you can choose to boot without the 3GB switch should you ever have problems with drivers installed in the future. The boot loader will default to the first option listed in the file. So you may want to put the /3GB option first. You may also wish to lower the timeout value to something quicker so that you don't have to wait for 30 seconds or press enter with each boot.__________________________________________________________________STEP 2 -Now to modify to the fs9.exe (thanks to Markus and Stu):Try this only if you have at least 2 GByte of RAM and at your own risk.First download the explorer from http://www.ntcore.com/exsuite.phpNext make a copy from fs9.exe. Than start "CFF Explorer" and open the original fs9.exe file.Now go to NT Header/File Header and click File Header. There you find a button labeled "click here". Click it. And select the mark at "App can handle> 2gb adress source "Save the modified EXE, overwrite the orginal one (You have your copy saved?).

Share this post


Link to post
Share on other sites