Jump to content

Archived

This topic is now archived and is closed to further replies.

Kosta

FSX crashes since the new build...(HELP!)

Recommended Posts

Since I made a new build, I have random crashes of FSX.Actually, sometimes not so random, mostly happen when I zoom out in the 2D cockpit after flight has been loaded.Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3Faulting module name: nvd3dum.dll, version: 8.17.12.7051, time stamp: 0x4d8d89b5Exception code: 0xc0000005Fault offset: 0x003a4884Faulting process id: 0x46cFaulting application start time: 0x01cbfc67610839ccFaulting application path: E:\FSX\fsx.exeFaulting module path: C:\Windows\system32\nvd3dum.dllReport Id: ef2bee62-685a-11e0-b570-f46d0413b0a3I did:- reinstall FSX, tried all vanilla- downclocked the system to all defaults (all stability tests pass, GPU tests too)- reinstalled the driver, since I thought it was due to the driver - did all as one is supposed to, safe mode, driver sweeper etc...- tried also official driver, and also the newest beta driver (266.58 and 270.51)It keeps crashing with this one error and nothing else.I can't for the life of me find the reason.Anyone has any ideas?

Share this post


Link to post
Share on other sites

Try out my link in this thread:http://forum.avsim.net/topic/332859-if-youre-getting-app-crashes/


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites

Sorry to hear about your problem Word Not Allowed.Do you have MSI Afterburner installed? Uninstall it!Have you imported any Nvidia profile after reinstalling the driver? that could be a bad idea with the new drivers.Now, nothing helps?After uninstalling completly your driver (safe mode), open your case and remove your GPU. Clean it and put it back.Reinstall the driver from your original GPU install CD.Make some tests and report.I am 98% sure that there is a glitch with your nVidia profiles.It seems like there are some problem with profiles since the 267.84 drivers.Good luck :--)


Best regards,
David Roch
Intel 9900K@5.1, Asus Maximus XI Formula, 32Gb G.Skill TridentZ 4133 CL17, EVGA RTX 2080 Ti XC ULTRA GAMING, 3x SSD Samsung 970 Pro M.2, Corsair 1600W PSU & 49" Samsung curved 4K TV monitor@30Hz.
MSFS Alpha tester

Share this post


Link to post
Share on other sites
Sorry to hear about your problem Word Not Allowed.Do you have MSI Afterburner installed? Uninstall it!Have you imported any Nvidia profile after reinstalling the driver? that could be a bad idea with the new drivers.
Ahh... yes.Doing/having both. MSI Aft. yes, and importing profiles via Nvidia Inspector. Quicker than setting everything up! I'll trying removing those variables, thanks for the suggestion David!

Share this post


Link to post
Share on other sites

None of those solutions seem to work.Restored original profiles, ran FSX with internal AA and AF, and also tried with Ryan's suggestion - still all the same. The worst thing is... it's random.Only other solution seems to be W7 reinstall + FSX reinstall. PAIN. MAJOR PAIN.

Share this post


Link to post
Share on other sites
Guest firehawk44
Anyone has any ideas?
Exception code indicates memory violation probably while it was loading/running faulting module, nvd3dum.dll. My (almost exact system) was crashing too but with the infamous G3d.dll fault. I have fixed it (so far) by changing the memory frequency (DDR3-1600MHz) in the BIOS to Auto and changed the AI Overclock Tuner from Manual to X.M.P. Per Asus, "When XMP is enabled, BCLK frequency, CPU ratio and memory parameters will be auto optimized". That's what Stephen (SpiritFlyer) had told me to do when he helped me oc my system but I read on several forums that you should change XMP to Manual and put in the memory frequency of your memory. That was a wrong suggestion and I reverted back to what Stephen had stated and so far no more crashes. FYI, I ran several stability tests with the memory frequency set to DDR3-1600 instead of Auto and had no crashes whatsoever until I ran FSX. I'm hoping this might fix your problem too. Best regards,Jim

Share this post


Link to post
Share on other sites
I have fixed it (so far) by changing the memory frequency (DDR3-1600MHz) in the BIOS to Auto and changed the AI Overclock Tuner from Manual to X.M.P. Per Asus, "When XMP is enabled, BCLK frequency, CPU ratio and memory parameters will be auto optimized". That's what Stephen (SpiritFlyer) had told me to do when he helped me oc my system but I read on several forums that you should change XMP to Manual and put in the memory frequency of your memory. That was a wrong suggestion and I reverted back to what Stephen had stated and so far no more crashes. FYI, I ran several stability tests with the memory frequency set to DDR3-1600 instead of Auto and had no crashes whatsoever until I ran FSX. I'm hoping this might fix your problem too.
FWIW When I tried to set my ram timings manually I was really unstable. Enabling XMP with my corsair vengeance sticks solved those memory/g3ddll erors, also putting the vista uiautomationcore.dll in the fsx root directory helped.

|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites
Just a shot in the dark but have you made sure you have the uiautomationcore dll in your fsx directory. This has been the cause of fsx crashingTom
Yep
FWIW When I tried to set my ram timings manually I was really unstable. Enabling XMP with my corsair vengeance sticks solved those memory/g3ddll erors, also putting the vista uiautomationcore.dll in the fsx root directory helped.
The memory is set to XMP too. It sets all parameters correctly.

Share this post


Link to post
Share on other sites

Well if it makes you feel any better I started getting my GPU-related CTD's again tonight (g3d.dll) ... Was on vatsim for about 3 hrs straight, with very high settings. Probably my video card got hot or something.Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14Faulting module name: g3d.dll, version: 10.0.61637.0, time stamp: 0x46fadb58Exception code: 0xc0000005Fault offset: 0x000ba79fFaulting process id: 0x10b0Faulting application start time: 0x01cbfd37d3700a32Faulting application path: D:\Microsoft Flight Simulator X\fsx.exeFaulting module path: D:\Microsoft Flight Simulator X\g3d.dllReport Id: 1fbe8ff0-695f-11e0-8376-1c6f65c15b81So for testing, I've scaled the clocks back down to reference settings (its factory OCed from eVGA), and set fan speed to 60 instead of auto.Also, check out this long (but interesting) thread over at the nvidia forums about the nvlddmkm error:http://forums.nvidia.com/index.php?showtopic=100800&hl=nvlddmkm


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites

Word Not Allowed,Hum...You probably use your joystick or any pad or the keyboard to zoom.Try something that sounds stupid but could indeed help.Unplug them, change your USB ports for these devices and restart the computer.


Best regards,
David Roch
Intel 9900K@5.1, Asus Maximus XI Formula, 32Gb G.Skill TridentZ 4133 CL17, EVGA RTX 2080 Ti XC ULTRA GAMING, 3x SSD Samsung 970 Pro M.2, Corsair 1600W PSU & 49" Samsung curved 4K TV monitor@30Hz.
MSFS Alpha tester

Share this post


Link to post
Share on other sites

Thanks David, good idea. That caused my previous errors, the Memtest etc...I actually found out that my overclock is causing it. In previous tests I had a computer settings on manual, mostly controlling everything. That crashed it...Now tried auto everything. And now it's working. But great... at 3.4Ghz.I still didn't do a long term test at 3.4, but going to image/reinstall windows to see how things work out.Oh and before you ask: 4.8 with all auto, crash :mad:Right now, 356 installed programs and counting down...

Share this post


Link to post
Share on other sites

I think I've found my error!!!MEA CULPA!!This is what one gets from all those tweakin's and stuff:My old BP=0 friend was back, just this time wearing another coat.On my GTX285 I remember I was getting artifacts when I overloaded a GPU with BP=0.Now, I don't remember seeing one artifact - but all the time crashing? And now when I just thought about it a bit - and ran my vanilla test-setup FSX with all default tweaks + Bojote's online tweak-tool, look - no more crash. And that was at 5Ghz... with an absolutely amazing result of about 53fps (I'll update the excel soon, when I have ran the test 4 times).This time I overloaded the GPU with a relatively high 4x Sparse Antialiasing, which pushed it often to 100% usage, probably causing crashes.And also this is with the new Nvidia driver...Many thanks to everyone! (SOLVED, hopefully)

Share this post


Link to post
Share on other sites
And also this is with the new Nvidia driver...Many thanks to everyone! (SOLVED, hopefully)
Hopefully that is it, because I too installed the new driver. I also increased the fan speed with evga precision to 60% so the thing stays cooler.

|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites
Hopefully that is it, because I too installed the new driver. I also increased the fan speed with evga precision to 60% so the thing stays cooler.
It was BP=0 in combination with 4x Sparse Multisampling! This mode while it does really look great, puts too much on the GPU, resulting a crash with BP=0. The performance drop without BP=0 is for a me a no-go, meaning I have to find a mode which doesn't put so much strain on the card. And I noticed 8xSQ puts about 70%, which is OK, giving me some headroom, now testing some others... all are stable, so long I don't overload the GPU.

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    21%
    $5,490.00 of $25,000.00 Donate Now
×
×
  • Create New...