Jump to content

Archived

This topic is now archived and is closed to further replies.

MistyBlue

Fix for stutters?

Recommended Posts

Not really PMDG specific, but might be useful to some in prep for the NGX. Has anyone seen this supposed fix for FS stutters? I always had a lot of little micro-stutters even though I have a high-end machine with a solid video card and dedicated OS and FS SSD drives. Drove me crazy. Then I stumbled across this fix and it "seems" to have improved a bit. Don't know if it's a placebo effect (because I want it to be true) or if it really does work for others.http://ultimatecomputers.net/forum/viewtopic.php?f=7&t=3644Thoughts?

Share this post


Link to post
Not really PMDG specific, but might be useful to some in prep for the NGX. Has anyone seen this supposed fix for FS stutters? I always had a lot of little micro-stutters even though I have a high-end machine with a solid video card and dedicated OS and FS SSD drives. Drove me crazy. Then I stumbled across this fix and it "seems" to have improved a bit. Don't know if it's a placebo effect (because I want it to be true) or if it really does work for others.http://ultimatecomputers.net/forum/viewtopic.php?f=7&t=3644Thoughts?
interesting read, tony. will give it a try. seems like it can do no harm and only contribute to a better performance. though with my system I see stutters only in steep turns and currently at YBBN from ORBX whereas I have to admit that I did not really tweak my system so far and have pretty much enabled and 'to the right'.which brings me to my question: when o/c your cpu, did you only adjust the multiplier and left all other settings as is or did you apply some vcore offset and / or different memory timing than default? reason I ask is that I tried to o/c my 2500k to 4ghz and got some obviously annoying blue screen, though amazingly never when flying but rather in idle mode or when running completely different and I'd say not cpu/memory consuming tasks. all bluescreen had to do with the memory I guess judging from the error reports...thxphil

Share this post


Link to post

Hi Phil, in my case I just changed the multiplier. My ASUS Sabertooth P67 motherboard seems to do a very good job of controlling everything else. But at 4.9 GHz I'm starting to touch briefly in the red on CPU voltage now and again. So I may back off just a tad. Keep in mind I'm also using a BIG case with three 200mm fans and a huge heat sink which is helping dissipate heat a lot. BTW, I'm not a hardcore overclocker, so take this with a grain of salt :( Based on my specs, I'm seeing around 17-20 FPS with NickN's OS tweaks, the Level-D, FSDT's KDFW, REX OD, UT2 maxed, ASE, AES, dense auto-gen, and moderate airport traffic. Getting about 40-48 FPS in the air. I still get minor stuttering at KDFW when looking toward the terminals and frame rates drop into the teens while rolling down the runway, but it's manageable. I could probably get more out of it but that's fairly reasonable for now, all things considered.Now, FS9, that's a joy to fly with this setup!Cheers!

Share this post


Link to post
Hi Phil, in my case I just changed the multiplier. My ASUS Sabertooth P67 motherboard seems to do a very good job of controlling everything else. But at 4.9 GHz I'm starting to touch briefly in the red on CPU voltage now and again. So I may back off just a tad. Keep in mind I'm also using a BIG case with three 200mm fans and a huge heat sink which is helping dissipate heat a lot. BTW, I'm not a hardcore overclocker, so take this with a grain of salt :( Based on my specs, I'm seeing around 17-20 FPS with NickN's OS tweaks, the Level-D, FSDT's KDFW, REX OD, UT2 maxed, ASE, AES, dense auto-gen, and moderate airport traffic. Getting about 40-48 FPS in the air. I still get minor stuttering at KDFW when looking toward the terminals and frame rates drop into the teens while rolling down the runway, but it's manageable. I could probably get more out of it but that's fairly reasonable for now, all things considered.Now, FS9, that's a joy to fly with this setup!Cheers!
thanks tony. will try that as well, so far I possibly changed too many settings, will just try the multiplier. and I would be happy with a 40 here, let alone 49 :( cooling should be no problem in my rig, once I tried the 40 under prime the cpu never exceeded 60C max which is quite good. however, I also added some -0.3v vcore offset and changed the dram timing per one of the countless 'how to oc' guides. but then came the blue screens... anyway ,will keep trying. I am just not so much into it. but I did realize quite a performance boost under fsx and that alone is worthwile spending some more of my precious spare time :-)

Share this post


Link to post

Has anybody else tested this "stutter fix" and could report back if there are any disadvantages???

Share this post


Link to post
Has anybody else tested this "stutter fix" and could report back if there are any disadvantages???
I tried it last night after seeing this thread and didn't notice a difference one way or another. Didn't seem to be any disadvantages, but as I didn't notice any advantages, either, I just went back to the original setting.

Share this post


Link to post

I tried this setting early this morning and did notice a SLIGHT improvment. The CPU cycles are a little more stable now than they were before but it is not a huge drastic improvment. The area where I normally fly, in the Pacific North West area (ORBX of course), it did seem - SLIGHTLY - smoother. Overall not a bad tweak, it is probably more effective in games where there's fast paced action like first person shooters etc. Those games must have smooth framerate and any CPU spikes would introduce stutters that affects playability :-)Cheers,

Share this post


Link to post

That's good news, Jason. Thinking about it, I bet the fact that I'm extremely GPU limited with my 4850 is probably stopping this tweak from working the way it would on a better system. I'll have to give it another shot once I pick up a new video card.

Share this post


Link to post
That's good news, Jason. Thinking about it, I bet the fact that I'm extremely GPU limited with my 4850 is probably stopping this tweak from working the way it would on a better system. I'll have to give it another shot once I pick up a new video card.
Get the GTX570, that is what I have and its a nice card! Cheers,

Share this post


Link to post

I would think hardware would certainly factor in. If you're experiencing low frame rates already, then this probably won't help much because the PC can't keep up anyway. In my case I had plenty of power, but was still seeing some stutter mostly on the takeoff roll and in turns while looking out the side windows in VC.Good thing about this is it doesn't do any harm. If it works, great. If not, just set your registry settings back to what they were.

Share this post


Link to post
Good thing about this is it doesn't do any harm. If it works, great. If not, just set your registry settings back to what they were.
did the tweak last night and see no negative effects, possibly indeed a tad less choppiness. So I will leave it on. What did they trick immensely at YBBN was to set the fps limiter to 22 (away from the default 30) as Mr. Orbx himself advised me in the orbx forum.next thing is to raise my multiplier. see all guys here with an asus p8 p67 board and a 2500k at way beyond 4ghz and like that too. will try with the auto vcore first and see which voltage it brings me. just 1 thing for clarification: if I see BSoD when at 4ghz, telling me something about memtable or whatever memory issue I cannot remember but my RAM is (manually) at stock speed then the reason for these BSoD can still be the CPU overclocking? Or can it be also the ram? what I mean is that I was under the impression that my ram would really fail when overclocking but it could be that the o/c'ed CPU can cause memory errors, too?phil

Share this post


Link to post

I have some thoughts on the memory issue, but again, I'm no expert and don't want to give you bad advice. Ethan probably could steer you better. What surprised me is that he's running around the same CPU speed as me but with much less voltage, so I need to start manually tweaking I guess.I've seen people make mention of external frame limiters. How well do they work? Whenever I seem to limit FPS within FSX the performance just isn't nearly as smooth as setting it to unlimited.

Share this post


Link to post
I have some thoughts on the memory issue, but again, I'm no expert and don't want to give you bad advice. Ethan probably could steer you better. What surprised me is that he's running around the same CPU speed as me but with much less voltage, so I need to start manually tweaking I guess.I've seen people make mention of external frame limiters. How well do they work? Whenever I seem to limit FPS within FSX the performance just isn't nearly as smooth as setting it to unlimited.
Works great! I limit mine to 40 just because I love the fluidity that comes with 40 FPS. You set your FSX limiter to unlimited and the FPS_Limiter to 20, 30 or 40. Definitely decreases stutters and add overall smoothness. I recommend it.

Share this post


Link to post
did the tweak last night and see no negative effects, possibly indeed a tad less choppiness. So I will leave it on. What did they trick immensely at YBBN was to set the fps limiter to 22 (away from the default 30) as Mr. Orbx himself advised me in the orbx forum.next thing is to raise my multiplier. see all guys here with an asus p8 p67 board and a 2500k at way beyond 4ghz and like that too. will try with the auto vcore first and see which voltage it brings me. just 1 thing for clarification: if I see BSoD when at 4ghz, telling me something about memtable or whatever memory issue I cannot remember but my RAM is (manually) at stock speed then the reason for these BSoD can still be the CPU overclocking? Or can it be also the ram? what I mean is that I was under the impression that my ram would really fail when overclocking but it could be that the o/c'ed CPU can cause memory errors, too?phil
OCing the CPU can definitely cause ram errors. Since you have the P67 board, make sure that you're not OCing the "old" way by raising the BCLK. For your initial OC, leave it a 100 and you can tweak later, but you need that to be stable initially. Second, you should lock your VCCIO voltage. This is the memory controller voltage, and if left on auto, the mobo likes to increase this too much as you start to raise your multi. I have mine tweaked, but I'd recommend that you set the VCCIO to 1.0 manually. (it will actually run a tad higher) Also, set the DRAM voltage manually to whatever your DDR is rated at. Finally, make sure you set your DDR timings manually. This should be a good start.

Share this post


Link to post
This should be a good start.
good to know. thanks for that input. btw, I went ahead and changed the multi to 45. running like a charme as I write since 1 hour with prime. cpu temp around 76C, vcore is around 1.3V though. too high? will do some 'real' work now on the pc and later hopefully some flying. would be too funny if all I needed to do is raise the multi and nothing else. haha

Share this post


Link to post
good to know. thanks for that input. btw, I went ahead and changed the multi to 45. running like a charme as I write since 1 hour with prime. cpu temp around 76C, vcore is around 1.3V though. too high? will do some 'real' work now on the pc and later hopefully some flying. would be too funny if all I needed to do is raise the multi and nothing else. haha
Good! 1.3 is fine. =)

Share this post


Link to post
Good! 1.3 is fine. =)
really? even better. things can be so easy sometimes. will see how it behaves over time but so far still no issues. Prime now for almost 2hrs without error. cpu temps still max 76c and I am even doing some photoshopping (actually w/ gimp). niiiice!

Share this post


Link to post
really? even better. things can be so easy sometimes. will see how it behaves over time but so far still no issues. Prime now for almost 2hrs without error. cpu temps still max 76c and I am even doing some photoshopping (actually w/ gimp). niiiice!
If you want to stay at 4.5, the next thing you should do is bump down the vcore incrementally until failure. Then bump it up one notch and that's the voltage you should run.

Share this post


Link to post
If you want to stay at 4.5, the next thing you should do is bump down the vcore incrementally until failure. Then bump it up one notch and that's the voltage you should run.
thank so much for your help, very much appreciated. will eventually report back in few days (and hopefully not already hours) whether my system remains stable at 4.5cheersphil

Share this post


Link to post
ha. that's the one I used, small world. except that I started with the 4ghz part and did not succeed for whatever reason. going straight for 4.5 seems to work for me. just finished 2 flights with the js41 downunder with orbx scenery and I must say I am impressed.

Share this post


Link to post
If you want to stay at 4.5, the next thing you should do is bump down the vcore incrementally until failure. Then bump it up one notch and that's the voltage you should run.
ethan, may I come back to this (off) topic. my 2500k still runs like a champ on 4.5 and I am really amazed what it is capable of. just 1 thing I noticed which (slightly) bugs me: my pc usually goes into standby mode after some time. however, when I want to wake it then in 90% of all cases it does not (re)boot straight away; the fans start humming but I see a black screen. no bios. no win7. what helps then is to press the power button for a complete shutdown. wait few seconds. push the power button again. luckily win7 the resumes like when waking up from standby. so no real issue as nothing is lost. but a nagging detail nonetheless. any idea? I know that I did not change any of the power savings option in the bios. in case you ask which sleep/suspend mode I use: no idea really. the pc goes complete black and quiet (fans off) except that the power led is slowly flashing and not completely off.phil

Share this post


Link to post
Sounds like you need a new bios.
Not true. ___________Phil,Glad to hear that you are enjoying 4.5. Pretty darn fast eh? This is a known issue. Ideally, you don't put your PC in standby. You should go to power options and turn off standby. It is much better to just shutdown/restart albeit not convenient at times. Nonetheless, there is a fix. Restart your computer, enter the bios, go to ai tweaker, find the line "Internal PLL Overvoltage". Set this to "Disabled". This should fix your waking from sleep issue. Please Note: Changing this setting to "Disabled" can inhibit the max clock that you are able to attain, and may even cause some instability at 4.5GHz. Like I said, the best course is to leave it enabled, and disable sleep/standby.

Share this post


Link to post
×
×
  • Create New...