Archived

This topic is now archived and is closed to further replies.

ericd19320

no more ctd

Recommended Posts

Only posting this because it worked for me on my system may not be the solution for anyone else but it could be worth a try and easy to do. I changed my mem setting from unganged to ganged in the bios. Not 1 ctd since I did this.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Only posting this because it worked for me on my system may not be the solution for anyone else but it could be worth a try and easy to do. I changed my mem setting from unganged to ganged in the bios. Not 1 ctd since I did this.
Thanks for posting this. Yes, it just shows again, many FSX CTD's are caused by having the wrong settings for your memory or memory timing/voltage settings are wrong. Memory related crashes are very hard to detect. More on ganged vs unganged - http://hardforum.com/showthread.php?t=1393322 .Best regards,Jim

Share this post


Link to post
Share on other sites

UPdate...it's been over a week now still no ctd!!! Knock on wood but I feel my issues have been solved

Share this post


Link to post
Share on other sites
Only posting this because it worked for me on my system may not be the solution for anyone else but it could be worth a try and easy to do. I changed my mem setting from unganged to ganged in the bios. Not 1 ctd since I did this.
Yea I tried changing mine after reading this. Ganged works great here. New box so lots of new things to fine tune again after 5 years.

Share this post


Link to post
Share on other sites
Thanks for posting this. Yes, it just shows again, many FSX CTD's are caused by having the wrong settings for your memory or memory timing/voltage settings are wrong. Memory related crashes are very hard to detect. More on ganged vs unganged - http://hardforum.com...d.php?t=1393322 .Best regards,Jim
Hey Jim. I`ve been scrolling through the link for a while, checked my own BIOS in relation to this unganged/ganged setting, had no luck finding it in BIOS advanced mode. Does it have a different name in there?

Share this post


Link to post
Share on other sites

Ive got an Asus p8z68-v. Manual does not give me anything on ganged/unganged, nor does asus.com provide any info on the subject. I cant find anywhere in BIOS that is related to this, and im somewhat confused as to howone can find this setting at all. Any help would be greatly appreciated!

Share this post


Link to post
Share on other sites
Ive got an Asus p8z68-v. Manual does not give me anything on ganged/unganged, nor does asus.com provide any info on the subject. I cant find anywhere in BIOS that is related to this, and im somewhat confused as to howone can find this setting at all. Any help would be greatly appreciated!
Ganged equal Auto frequency mode. Unganged equal the actual frequency setting. Evidently ASUS boards automatically set voltage settings for memory at 1.65 when the memory is only rated for 1.50. So, when you have it set at auto, the memory will still work at the higher voltage for a while but will probably create a crash eventually. That's why you can run memory diagnostics/Prime 95 etc., etc., as long as you want and you will get a report that there's nothing wrong with your system memory. Setting your frequency to 1600 or 1333 (or whatever it's rated) and voltage no higher than 1.5 will give you more stability. Look in the CPU-Z program to see what frequency and voltages are allowed for your memory. There may or may not be anything in the ASUS manuals about this. I don't read manuals much. I just Google and I did find a couple of articles on Tom's Hardware forums about this. I Googled 'asus manual does not give me anything on ganged/unganged'. There are many, many more articles relating to this subject via a google search if you want more info on this subject. A lot of people had the same question you had and/or are just as confused.Best regards,Jim

Share this post


Link to post
Share on other sites

Thank you Jim. I really appreciate the help.. As you probably know, moving from a very good FS9 system to a brand new PC with old FSX, makes it really irritating when i spend most my time battling theese,, errr.. CTD`s and what not.

Share this post


Link to post
Share on other sites
Thank you Jim. I really appreciate the help.. As you probably know, moving from a very good FS9 system to a brand new PC with old FSX, makes it really irritating when i spend most my time battling theese,, errr.. CTD`s and what not.
Not to worry Yngve (I suspect you do not pronounce the 'Y' in your name?). I've gone through similar problems with new technology, news systems, etc. I'm glad to help wherever I can and I know others who might be as knowledgeable are willing to help too. Just remember: Google.com is your friend (well, the Bing search engine too over at bing.com). Ask it anything, even type in a couple of sentences to explain the problem and you'll most likely get excellent results to resolve your problem. Once you find a possible solution, you can even have it translated to any language so that you might understand it better.Best regards,Jim

Share this post


Link to post
Share on other sites

Should I then set my DRAM voltage to say 1.5 instead of auto? I think you guys are on to somthing here. Does this have any thing to do with the apphangB1 error? Just trying out new things .

Share this post


Link to post
Share on other sites
Should I then set my DRAM voltage to say 1.5 instead of auto? I think you guys are on to somthing here. Does this have any thing to do with the apphangB1 error? Just trying out new things .
Yes. Set your voltage to whatever CPU-Z tells you under the SPD tab. It will provide you with 4 columns of timing tables with the voltage for each frequency. Pretty simple. I have my BIOS set to X.M.P. so I set my voltage to 1.65000. The other timings/frequencies I could use show that 1.50000 should be set. I'm not sure whether bad timings/frequencies/voltages will cause an application to hang but I would make that my first suspect. ASUS is not very good at automatically setting memory timings. I suspect other MB manufacturers have the same problem. Therefore it is best you set your own settings based on what CPU-Z provides.Best regards,Jim

Share this post


Link to post
Share on other sites

Ok when I get home next Friday I'll see what CPU- z shows and try to figure somthing out. I just don't understand RAM very well yet. I've set it to just under 1.65 volts it's more like 1.64367 in bios the next setting was over 1.65. I don't remember exactly what its set to because I'm back on the road and away from the computer. Can you explain in more detail about the memory timings and speed and voltage settings. I do remember seeing 1.5 and 1.65 displayed on CPU-z, but do I have to set the DRAM to 1.65 and somewhere set it to 1.5? I guess I don't understand everything about RAM yet. However I have notice since I've set the DRAM to 1.64 FSX has not yet crashed or even crashed on exit with CTL+ E.Ps I using my IPad for these messages

Share this post


Link to post
Share on other sites
I just don't understand RAM very well yet.
Join the crowd. It is confusing sometimes and it took me a long time to fix my system. 1.65 sounds too high to me. Most settings are at 1.5 unless you are using the X.M.P. profile setting. That's what I'm using now. I did have my manual settings set to 1.65 when they should have been 1.5 and had no problems for a while but suddenly saw crashes. So I changed to X.M.P. and now I'm very stable.Best regards,Jim

Share this post


Link to post
Share on other sites

So is having a lower voltage than the 1.65 to say 1.5 make ram more stable then? I really thing setting it to auto is not the best choice now.

Share this post


Link to post
Share on other sites
So is having a lower voltage than the 1.65 to say 1.5 make ram more stable then? I really thing setting it to auto is not the best choice now.
Only if you use lower frequencies as shown in the CPU-Z. If you use the X.M.P. profile, I would go for the 1.65 voltage. Nick N, in his guide on setting up FSX and tuning it, suggests setting your memery to the lowest frequency.Best regards,Jim

Share this post


Link to post
Share on other sites

Ok I just had to share this with you...I managed to get home thins last weekend and changed my RAM to 1.65 volts, the updated my FSUIPC to the lates version. I HAD NO AND I REPEAT NO CTD AT ALL!!! I even used the latest Carenado Piper Malibu at YBBN under Orbx with ASE and many clouds. I was using the Reality XP GNS 530 and flew for 1 hour and didn't even have a g3d.dll crash. That one have been a plague for the Orbx YBBN area since I bought it. I've never been able to get off the ground let alone airborne from that airport without a g3d.dll CTD. Now that hase been fixed through FSUIPC. I checked the event log in the moduals folder in my FSX drive and found that the sim had 5 g3d.dll crash attempts but FSUIPC trapped them and prevented the sim from crashing. AMAZING. I had no other CTD at all. If you don't have FSUIPC get it it will save you so much frustration and make FSX much more stable. Also on the FSUIPC log I had an average frame rate of 44.6 in the YBBN and the serounding areas. All my slider were maxed except for water. That was one notch from the right. Also I had my traffic 5.2 and 70% for airlines and 50% for ga trafice 16% for cars 40% boats and ships and max for airport traffic.

Share this post


Link to post
Share on other sites