Jump to content

Archived

This topic is now archived and is closed to further replies.

GAJ52

Voice Recognition Problem

Recommended Posts

Hi,The title of this post is a little over dramatic as I only have a problem using Voice Recognition with just one word "ON". I have used the voice recognition training several times to try and solve this problem, but FS2Crew refuses to recognise when I say "On" to checklist. I have tried it in different accents, slowly, quickly, I did try it once in a drawling Texan type accent and it worked, but only the once !!I know I can use 'Set', 'Checked' or 'Next' to continue with the checklist, but is there any way to train FS2Crew to recognise my "On" command ?I remember reading a similar post some time ago but I can't find it now.Glen

Share this post


Link to post
Share on other sites

I had this exact problem with FS2Crew Voice for PMDG's J41 and in my case the solution was to do more voice training with the speech engine. I just kept reading all the text examples and in the end the problem with 'On' went away and was recognised just fine. Since then and now with the FS2Crew Voice for iFly I don't have this problem anymore.

Share this post


Link to post
Share on other sites

Hi Richard,I was hoping that would not be the answer, as I have spent some time in the Voice Recognition training area. It seems strange you had the same problem with "On" as if there is a technical hitch with this word. I use FS2Crew with the PMDG JS41 and 737 and only have a problem with "On" all other commands are recognised fine ??Sounds like I've got to get back to the training room.Thanks again RichardRegards, Glen

Share this post


Link to post
Share on other sites

No worries Glen and I'm sorry I wasn't able to provide you with a more simple solution and I agree I also find it strange why this single and very simple word is so hard to get right in the eyes (or more ears I guess) of the voice recognition engine. Maybe the reason is exactly that...that it's a very short word.Hope you will get it fixed somehow! At least you know now you're not the only one having problem with this word and also it can be overcome.

Share this post


Link to post
Share on other sites
Hi Richard,I was hoping that would not be the answer, as I have spent some time in the Voice Recognition training area. It seems strange you had the same problem with "On" as if there is a technical hitch with this word. I use FS2Crew with the PMDG JS41 and 737 and only have a problem with "On" all other commands are recognised fine ??Sounds like I've got to get back to the training room.Thanks again RichardRegards, Glen
Glen, I'm not sure where you're from but try changing up your intonation a bit if you have what might be considered a 'heavy' accent.Try saying 'on' with an American pacific north west accent.

Share this post


Link to post
Share on other sites

Hi BryanI'm from the UK. I've tried all sorts of accents, even a BBC newsreader type, I think as Richard said I will have to spend some more time in the voice training room. This is not a big problem as I can say 'Set' or 'Checked' its just bugging me why I can't get it to recognise "ON" I'll keep training till it works :( Regards, Glen

Share this post


Link to post
Share on other sites

Exactly where in the checklists are you when this "On" problem occurs?What is displayed in the green bar when you say "On"?

Share this post


Link to post
Share on other sites

Sorry for the delay in getting back to you, had the in-laws round for dinner so wasn't able to get to my computer.It starts on the first Turn Check :-Cabin Signs ......"On" CParking Brake....."On" CWhen I say ON, 'ARMED' is displayed in the green bar. I tried again with an exaggerated American accent (I'm from the UK) and it did after several attempts display 'ON' All other voice recognition works fine.Glen

Share this post


Link to post
Share on other sites
Sorry for the delay in getting back to you, had the in-laws round for dinner so wasn't able to get to my computer.It starts on the first Turn Check :-Cabin Signs ......"On" CParking Brake....."On" CWhen I say ON, 'ARMED' is displayed in the green bar. I tried again with an exaggerated American accent (I'm from the UK) and it did after several attempts display 'ON' All other voice recognition works fine.Glen
Hi Glen,"On" is in the grammar, so it should work. Just try saying 'on' using different intonations until you find one that works.Remember you can also say 'next' if you get stuck.What I'd do is load the J41, open the FS2Crew Main Panel... don't start the J41's engines, and just say 'On' over and over again until you see it in the green bar.I suspect this is just an accent issue.Cheers,

Share this post


Link to post
Share on other sites

BryanThanks for your help.I have just spent the last few minutes doing what you said, loaded the JS41 and repeated "ON" many times, in different ways, and each time the word in the green bar displays the word "Armed". Quick as a flash I thought I know what I'll get my wife to try it - every time she said 'ON' the green bar displayed ARMED.So it appears the voice recognition doesn't like the Southern UK accent, at least saying the word ON.I'll give up and just say 'Next'Glen

Share this post


Link to post
Share on other sites
BryanThanks for your help.I have just spent the last few minutes doing what you said, loaded the JS41 and repeated "ON" many times, in different ways, and each time the word in the green bar displays the word "Armed". Quick as a flash I thought I know what I'll get my wife to try it - every time she said 'ON' the green bar displayed ARMED.So it appears the voice recognition doesn't like the Southern UK accent, at least saying the word ON.I'll give up and just say 'Next'Glen
Glen,I'm wondering if it's ambient background noise that's the issue. Your southern UK accent shouldn't be a problem as we have non-native English speakers using the software, and their accents would be thicker than yours.Try again, but turn the volume way down on your computer to remove any background interference.The J41 is a very loud airplane, so that could be an issue.What kind of mic are you using?

Share this post


Link to post
Share on other sites

BryanI'm using a Logitech USB headset/microphone, normally works fine.I've established the problem has got nothing to do with FS2Crew. I have just dictated a full page of A4 using MS Word Recognition by reading text from a book. Speaking as clearly as I could, the accuracy was extremely good with very few mistakes, except every time I said "On" it wrote ARMED. Strangely if I said ARMED in the microphone it wrote armed - there's a surprise. I corrected the misspelling of "On" using the correct voice commands so hopefully it will finally get the message.After several corrections with the recognition improving slowly in MS Word, I tried it in FS2Crew / JS41 with no external sound and it still said ARMED in the green bar.I WILL train it if it kills me, I won't be beaten by a computer :( Glen

Share this post


Link to post
Share on other sites

I have the exact same problem and im from the UK to, Im from Blackburn so have a northern accent, no matter what i do when i say "on" armed is what is displayed. Tried training W7 and it has no problem at all understanding me.

Share this post


Link to post
Share on other sites
I have the exact same problem and im from the UK to, Im from Blackburn so have a northern accent, no matter what i do when i say "on" armed is what is displayed. Tried training W7 and it has no problem at all understanding me.
Hi Simon,Try PM'ing GAJ52 above.Maybe he has some further insight.But we have a good size Brit user base for this product and I've only had the two reports including yours.Try adjusting your mic sensitivity.'On' doesn't sound all that close to 'Armed', so it's an odd one.

Share this post


Link to post
Share on other sites

Yeah i find it very strange indeed, i have your product for both the iFly 737 and the JS41 and it does it on both, i'll look into it a little deeper maybe tomorrow and mess with my mic settings and report back.ThanksSimon

Share this post


Link to post
Share on other sites

Hi,I'm a newish user to the voice ifly 737 nxg and I have the problem of 'on' not being reconised by my southern english accent.After lots of training, it was still no better.'auto' and sometimes 'armed' was being displayed instead of 'on'. I now have to say 'on' in a stupid manner for it to be recognised. Kind of like taking a big bite of a juicy melon, with the sound coming from the back of my throat.Obviously all this was from July last year, so has it been solved yet?Andrew.

Share this post


Link to post
Share on other sites

Hi Andrew,Your accent should be no problem... remember we have Japanese and Eastern Europeans using voice recognition with good results, so your southern accent should pose no problem.You might want to try getting a better headset...Or, you could try this:Problem: Speech recognition is having problems detecting certain words. Can I train the speech recognition system for "specific" words?Solution:

  • Yes, you can use the dictation facility in Windows.
  • First, start 'Windows Speech Recognition' (this is not the FS2Crew Speech Recognition system, but rather the speech recognition system that comes with Windows).
  • Open a text document.
  • Next, dictate a list of words you are having trouble with.
  • Every time the speech recognizer makes a mistake, use the "CORRECT THAT" voice command. This effectively train the speech recognition engine to recognize how you pronounce these words. You may need to dictate and correct the same words multiple times until the recognition rate improves.

Share this post


Link to post
Share on other sites
Hi,The title of this post is a little over dramatic as I only have a problem using Voice Recognition with just one word "ON". I have used the voice recognition training several times to try and solve this problem, but FS2Crew refuses to recognize when I say "On" to checklist. I have tried it in different accents, slowly, quickly, I did try it once in a drawling Texan type accent and it worked, but only the once !!I know I can use 'Set', 'Checked' or 'Next' to continue with the checklist, but is there any way to train FS2Crew to recognize my "On" command ?I remember reading a similar post some time ago but I can't find it now.Glen
Ditto. I had the same issue as a Brit like you, which is why I gave up with the Voice Commander and switched to the Button Version. I thought maybe it was my accent and so nobody would have a solution. Cannot believe anyone has posted about this. Hopefully, somebody here now will have an answer.

Share this post


Link to post
Share on other sites

I have tried everything including the 'Dictation' training, as I only have the problem with one word 'On' I don't think its a problem with my headset quality, it appears to not like a UK accent for this particular word for some reason. I have got around this problem by saying 'On' in a kind of American accent, pronouncing it as "arn" this now works every time. Its a little annoying speaking like this for one word, then normally for the rest of the time but I have now just got used to it.Glen

Share this post


Link to post
Share on other sites

How would you "spell out" 'on' using a southern English accent?In the grammar file, I just write the word like "on".But maybe I could also add something like "hone" to the grammar file.

Share this post


Link to post
Share on other sites

Hi BryanI personally pronounce the 'O' as in Orange and just add the 'n. To make it work every time I have to pronouce the 'O' as 'AR'.nAs an example I pronounce 'On' exactly the same as the UK Copilot in the JS41 version of FS2Crew - we could be twin brothers :( .If the same thing happenes with the NGX version, :( it won't be a problem I can live with it. I feel its a MS Voice problem not anything to do with FS2Crew.Glen

Share this post


Link to post
Share on other sites

Hmmm.... As an experiment, trying turning down your FS volume all the way to off and see if 'On' is detected any better.The J41 is especially noisy, and that may be a factor.Based on experience, generally speaking a neutral American style mid-western accent tends to work best.Basically it's the same accent used by most American new castors on the major TV networks... or Obama.Try talking like Obama :(

Share this post


Link to post
Share on other sites

After all this, I've realised I've had the same problem, but posted it in the Jetstream rather than the ifly 737 forum. I have trained Win7 on those words, and have some success in notepad.After following the above, Win7 doesn't 'learn', no matter how many times I've 'correct that'. I'm using a Plantronics USB headset. Please find my voice in .wma here:-http://www.andrewreader.com/fsx/

Share this post


Link to post
Share on other sites

Right, I'm finally getting somewhere.So far:-'correct that' and was failing.I then recorded my voice into the dictionary of S.R. for 'on'Then in notepad, it was getting better with correct that.On 'correct that' you can say your word again to see the list of possible matches - if it's nothing like your word, you need to record/re-record it to the dictionary.'On' starts working.'Armed' doesn't work, but one step at a time.Thanks all.

Share this post


Link to post
Share on other sites

×
×
  • Create New...