Archived

This topic is now archived and is closed to further replies.

FSMP

COM Radio selection squence error ?

Recommended Posts

There is something "not quite right" with the PMDG 737NGX VHF Radios.There would seems to be a "State Sequence" error when selecting the COM1 & COM2 Radios. Hopefully, as few of you can test this, and confime these findings ======================================== Note: Showing this gets a little complicated, but one comes to the conclusion that the Radios are set up differently, accoring to the Sequence that things are set, despite having the same final Switch Configuration.I cannot believe this is CORRECT --HERE is a detailed way to reproduce this issue. ( HOTFIX #3 currently installed)Note: The easy way to HEAR what you are receiving on is to set your two Com frequencesi to different ATIS frequences that are within range, then you can hear what Freq(s) you are receiving on.Depending on what SEQUENCE you select, you will get different results.You this end up with different Radio selection for the same final switch selection.THIS CANNOT BE CORRECT, because it means that by looking at the switches, you cannot tell which of two very different configurations you are in. !SEQUENCE TO REPRODUCE THIS ISSUESet COM 1 to ATIS freq1 Set COM2 to ATIS Freq 2Confirm that BOTh ATIS freqs are withing Range !!Now you can tell which Freq you are listening ON, (or BOTH !!)Pilot side COM1 selected, Mic on COM1Co-Pilot side: COM2 selected Mic on COM1You are now only using COM1, receiving and transmitting on COM1 - listening to ATIS 1 [ok]Now select VHF2 audio (button IN) -- You ae now TX/RX on COM1 (118.10 ) and also RX on COM2 (118.20)Listening to BoTh ATIS 1 & ATIS 2- [ok]Select MIC 2. You are now TX/RX on COM2 (118.20 ) and also RX on COM1 (118.10) -- [ok]Listening to BOTH ATIS Freqs.Looking at selectors, Mic COM1, audio COM2 -- this is what you expect looking at the switches.(If you have Mic selected on COM1, rx audio on COM1 is automatically selected, when if you do not maunally select,You cannot TX on a Freq you are not also receiving on)------------ OK so far ---Now, deselect COM2 audio, and as expected, we are now ONLY TX/RX on COM1Now select MIC Com2, and we are correct TX/RX on COM2 ONLY [ok]Manually select Select AUDIO COM2 ONLY - we are still fine, TX/RX on COM2 only [ok]Now select MIC COM1We are now TX/RX on COM1 ONLY but notice we still have Audio COM2 selected. !!Above, under this swich combination we were TX/RX on COM and RX only on COM2 !!!Looking at the swiches we would EXPECT to be as above, RX/TX on COM1 and RX only on Com2, but in fact, we arenow NOT receiving on COM2.Note: You get the same results, when on Vatsim, listening to two different controllers (or THINKING that you are !! )--------------------------------------------Would be helpfull if some others could try this and report back their findings on this issue.If this is, in fact a BUG, its one that can really screw you up, especially when when on Vatsim, and ATC starts blaming you for not responding to them, because you do not hear them on Freq !!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can you make your actual complaint more concise? Is your concern that you're not hearing COM2? What is the actual state of the panel when you have your concern?

Share this post


Link to post
Share on other sites
Can you make your actual complaint more concise? Is your concern that you're not hearing COM2? What is the actual state of the panel when you have your concern?
2 Pages and the detailed steps to reproduce the issue is NOT "Concise" enough ?
Depending on what SEQUENCE you select, you will get different results.You this end up with different Radio selection for the same final switch selection.

Share this post


Link to post
Share on other sites

Well, I tried ... "You can lead a horse to water, but you can't make him drink" Of all the PMDG bugs, this is one that is 100% reproducable. When you get on Vatsim, or PilotEdge, and you THINK you are set to listen on COM2, and don't hear ATIS on COM2, or you don't hear the controller, and get kicked for not obeying ATC, then you might consider it relevant !!Doh.gif

Share this post


Link to post
Share on other sites

Ah. That I can get my brain around. So after all your switching and flipping, the volume knob is lit and turned up, but no sound. Is that correct?

Share this post


Link to post
Share on other sites
Ah. That I can get my brain around. So after all your switching and flipping, the volume knob is lit and turned up, but no sound. Is that correct?
Something like that .. lol. According to the order you switch the switches, you end up with all the switches in the same position, but with one sequence, the com2 radio can be heard, and with the other sequence, it cannot. So, switches are in the Correct position, but you will, or will NOT hear COM2, according to how you got there.

Share this post


Link to post
Share on other sites

I've noticed some planes don't model com2 on vatsim/pe/ivao... perhaps just the plane interacting with the pilot client (or not interacting for that matter?)

Share this post


Link to post
Share on other sites
I've noticed some planes don't model com2 on vatsim/pe/ivao... perhaps just the plane interacting with the pilot client (or not interacting for that matter?)
PMDG 737 can correctly tune COM2, if switched in the correct sequence, ( Tried it )

Share this post


Link to post
Share on other sites

i cannot receive anything on COM2! have tried various combinations but no luck. it must be a simple glitch as in all other aircraft, PMDG J41 it is a simple matter of entering the frequency and when the ATIS on destination becomes within range VIOLA! the sound comes across perfectly. i dont believe that in the real world pilots (NF of course) spend time futtzing around rather than simply entering the frequency and thats it! read the manual and followed the instructions,. simple: put in frequency:make active: turn up volume and that is it! possible issue that will be fixed in SP?

Share this post


Link to post
Share on other sites
PMDG 737 can correctly tune COM2, if switched in the correct sequence, ( Tried it )
The plane must work also if not used in correct scheme, if the real one works, the simulated pplane if correctly programmed must do the same.I've not tried yet, and a bit confused about reading the sequence.But if following a procedure that must have a result but it doesn't, it is a bug. Exactly the same as for speedbrakes. And in this case you are losing a Com radio...Must check it asap, and report back.

Share this post


Link to post
Share on other sites

I'm trying right now, there is something strange... From this step you wrote:

Now select VHF2 audio (button IN) -- You ae now TX/RX on COM1 (118.10 ) and also RX on COM2 (118.20)Listening to BoTh ATIS 1 & ATIS 2- [ok]
Selecting MIC 2 it deselect MIC1 and deselecting it also the RX disengages if it was not previously pushed in (lighted), so that's already not OK. SPKR buttons are not simulated, I can assume that pmdg simulated the sounds as you have your headphones plugged, but on the real one if I turn on the speakers on both ASP I can hear left audio output plus right ASP audio output. For example, by selecting VHF1 on the pilot side, plus SPKR and selecting VHF2 audio on the copilot side plus SPKR I must listen both in cockpit as they are played from the speakers. I'm continuing to try combinations

Share this post


Link to post
Share on other sites

I replicated the things, VHF1 mic is selected, VHF2 Audio is selected, atis only with vhf1. Resetting (off then on) VHF2 speaker button solved the issue.Not a problem with an ATIS that speaks continously, maybe a problem in flight when noone is trasmitting and the selector is lighted. No way to find if it is working. the only thing to make sure it works is to double push the vhf2 button.Same things will happens if you have VHF1 pushed in (mic on VHF1) then mic on vhf2 (the audio selector on vhf1 remains lighted) but then no audio from the VHF1

Share this post


Link to post
Share on other sites
I replicated the things, VHF1 mic is selected, VHF2 Audio is selected, atis only with vhf1. Resetting (off then on) VHF2 speaker button solved the issue.Not a problem with an ATIS that speaks continously, maybe a problem in flight when noone is trasmitting and the selector is lighted. No way to find if it is working. the only thing to make sure it works is to double push the vhf2 button.Same things will happens if you have VHF1 pushed in (mic on VHF1) then mic on vhf2 (the audio selector on vhf1 remains lighted) but then no audio from the VHF1
Thank you Daviersoft !! AT LAST -- someone has bothered to make the effort to reproduce the steps, and has confirmed there is an issue. BTW: It is NOT an "atis" related issue.============================== I used ATIS audio to demonstrate the issue, as you can HEAR when the Radios are receiving the individual Atis Audios. Initially, I discovered the Bug when using the radios for Communications with other Pilots & Controllers, when in Multiplayer. You could also see the effect, if you are in Free Flight, and have AI traffic, that is talking to ATC. The advantage of using TWO ATIS freqyuencies is that they are continuous transmissions. In hindsight, it is easy to imagine how the process of translating the 737 Switches, to "FSX Key_Events", to select Radios, could develop a sequencing issue, but now identified, it should be an easy fix. ( Having to "DOUBLE SELECT" the radio is a very unrealistic work around !!!)

Share this post


Link to post
Share on other sites

Thank's Geoff and Daviersoft. My original post about this problem has got lost. I will admit to sheer laziness for not trying your sequences geoff, but I'm pleased Daviersoft has found a workaround that sounds simple enough. Just double selecting the com2 radio. I will try that. Thank's gents. Martin.

Share this post


Link to post
Share on other sites
Thank's Geoff and Daviersoft. My original post about this problem has got lost. I will admit to sheer laziness for not trying your sequences geoff, but I'm pleased Daviersoft has found a workaround that sounds simple enough. Just double selecting the com2 radio. I will try that. Thank's gents. Martin.
I am hoping that PMDG's standards do not accept that to be an acceptable "work around". in lieu of correcting the issue.

Share this post


Link to post
Share on other sites
I am hoping that PMDG's standards do not accept that to be an acceptable "work around". in lieu of correcting the issue.
Have you submitted a ticket with them?

Share this post


Link to post
Share on other sites
Have you submitted a ticket with them?
In a word NO, While I am happy to discuss aviation topics with other PMDG pilots, , PMDG have made it very clear that they do not want to hear from me directly .. and I am happy to respect that "request". As they read the Forum, they are no doubt aware of the issue, and it's up to them what they do with that information.

Share this post


Link to post
Share on other sites