Archived

This topic is now archived and is closed to further replies.

Michael Moe

pause/stutter just >1-500feet before touchdown

Recommended Posts

Well FSX is bad programmed. We all know that but i found it irritating that when everything is going fine then the sim would give me these stretched images like stutter and small pauses on approach just before landing.

 

I believe i read somewhere that it has something to do with FSX memorybuffer so lowering grahics would help.

 

So what are your experience to this killer and solutions ?

 

Thanks

Michael

 

I7@950 4,2ghz

HD5870 1GB

SSD128 win 7 64bit

300gb RAPTOR FSX drive

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Michael, it sounds to me, simply that as the autogen is being drawn as you get closer to the airport, it is using more resources from the CPU, hence the stutters. I suggest you run the NGX at lower slider settings.

Share this post


Link to post
Share on other sites

Might be airport structures coming into higher LOD levels as well..

Share this post


Link to post
Share on other sites

well the Autogen is pretty much lowered to Dense from Max and i am not sure if this is the best solution. I have had results with maxed out Autogen with better smoothness but OOM instead.

 

Some guy suggest tha i should remove the Affinitymask=14 as it would give me all 4 cores for textureloading

 

hmm

 

Thanks

Michael

Share this post


Link to post
Share on other sites

?? this is the site that uses affinitymask=14

 

Michael

Michael PM me your FSX. cfg i have ATI and i had this issue but i did resolve it.. thanks Steve i'll help you out here m8 and get you running smooth again

Share this post


Link to post
Share on other sites

well the Autogen is pretty much lowered to Dense from Max and i am not sure if this is the best solution. I have had results with maxed out Autogen with better smoothness but OOM instead.

 

Some guy suggest tha i should remove the Affinitymask=14 as it would give me all 4 cores for textureloading

 

hmm

 

Thanks

Michael

 

Hi Michael, unsure what airports you are experiencing this issue. But to be honest, I run my NGX at normal autogen...always. If you see my signature, my rig is no slouch. However, even at normal autogen approaching Aerosoft's Madrid airport I will encounter poor perfrormance. Now throw in 8/8 cloud, all the assorted parafanalia and then up the AG to dense and I have similar issues. However, I'm sure Steve will help you out with a PM.

Share this post


Link to post
Share on other sites

Yeah i certainly will the tweek i have unfortunatley only works well with ATI cards.... but PM me m8 i will get you going ( In the FSX way ) :o

Share this post


Link to post
Share on other sites

Anyone with a high end SandyBridge system should religiously follow THIS guide.

Share this post


Link to post
Share on other sites

well i have sent you a PM including the text of my fsx.cfg. Its rather frustrating having these microstutters on approach

 

Normal autogen does not help at all

 

Thanks

Michael

Share this post


Link to post
Share on other sites

Yeah got your PM m8 and im working on it for you im away now till Monday so i will message you your new CFG monday... There are a few things i need to know m8 do you run AI traffic like UT2 etc.. and if so what sound do you use for them normal default or do you use Audio Airliner Enviroment ?? Your cpu is a quad i have that... and your card is a 5800 series right?

 

leave it with me will speak Monday

 

Steve

Share this post


Link to post
Share on other sites

Thank you :-)

 

I have:

 

UT 2 at 30%

 

No sound extras .only default

 

Intel core i7-950@4-4,2ghz

 

HD5870 1GB

 

Michael

Share this post


Link to post
Share on other sites

Hi Michael,

I had stutters during approach. I had the impression that they are relatetd to the altitude callouts, because I had before each callout a stutter.

 

I changed in my fsx.cfg in section

[sound]

sound_lod=0

to

sound_lod=1

 

and I had several approaches now with no stutters.

I hope that helps to solve your problem

regards

Stefan

Share this post


Link to post
Share on other sites

This part of the config is apllied to external sounds such as audio enviroment 3 party like airline audio enviroment.... =1 is default ai traffic sounds

Share this post


Link to post
Share on other sites

I know, but my stutters disappeared. I can only presume that the sounds of the NGX are somehow like AI sounds.

regards Stefan

Share this post


Link to post
Share on other sites

Oj i see im not sure to be honest since i use bufferpolls =0 i never get stutters at all now

Share this post


Link to post
Share on other sites

Hi Michael,

I had stutters during approach. I had the impression that they are relatetd to the altitude callouts, because I had before each callout a stutter.

 

I changed in my fsx.cfg in section

[sound]

sound_lod=0

to

sound_lod=1

 

and I had several approaches now with no stutters.

I hope that helps to solve your problem

regards

Stefan

 

 

 

LOL i didnt know but i had it that way by default so :-)

 

I think the compromise deleting usepools=0 is the best solution but still think that simconnect can also have a role in this. Is there any regular updates to simconnect and should i edit any ini files for this ?

 

Thanks Steve and the community

 

Michael

Share this post


Link to post
Share on other sites

No problem... The usepools=0 option is great if you have the water set to high x2 because other wise you will start to get graphic atifacts.... and ATI cards are much better for this option than Nvidia as they are harder to crash....

Share this post


Link to post
Share on other sites

Yes it is easy to get these blitz over ground, and artifacts when having usepools=0 but i believe the high x 2 water setting is eating my fps up to 7fps. not nice :-)

 

Thanks

Michael

Share this post


Link to post
Share on other sites

Hi everybody

 

after some more try and error I found 2 parameters influencing the stutter.

I have no stutters during approach when I have in fsx.cfg the following settings:

 

delete the lines in section [Graphics]

ForceFullScreenVSync=1

ForceWindowedVSync=1

it seems that they are the main source for the stutters during approach.

 

set in section [sound]

Sound_Lod=1

 

Some remarks to section [bufferpools]

in my system is no difference regarding stutters between

 

Usepools=1

PoolSize=490000000

 

and

UsePools=0

With Usepools=0 I have sometimes strange textures flashes.

I think this depends very much on the hardware and the OS.

 

Some people say that it is better to disable DX10 preview, but in my system DX10 preview gives much better colors and around 10 FPS more.

When I fly the 737NGX I have 2D panel on one screen and overhead panel and CDU on the second screen. I run my system with nvidiaInspector and limit the frames to 75. Due to this I get around 38 fps (due to my 2 displays the FPS of the limiter is divided by 2)

 

regards

Stefan

 

My system

Master for FSX:

Intel i7 CPU X980 3,3GHz ;12GB RAM; 2 x GeForce GTX295 driver 290.53 together in SLI mode nvidia inspector 1.9.6.5 with 2 screens 1920x1080

sound Creative Sound Blaster SB X_Fi driver 6.0.1.1376

Win7 Prof 64bit SP1; FSX +Acceleration

Slave for connection with IVAO or VATSIM:

Intel Quad Q 8400 2,66 GHz; 8GB RAM; graphic card INTEL Q45/Q43 Express Chipset

Win7 Prof 64bit SP1;IVAP 1.9.8.2133

Share this post


Link to post
Share on other sites