Archived

This topic is now archived and is closed to further replies.

Hlminx1

Control assignments not saving in Standard.xml when exiting FSX

Recommended Posts

Hi

I'm hoping someone can come up with a suggestion that i havent already tried...

 

I've been using FSX Acceleration on a Win7 64 bit PC for about a year with the following Saitek peripherals installed (using the drivers only rather than the SST software) and not had any issues, with everything running together:

- Yoke & Throttle

- Ruddar Pedals

- Switch Panel

- Multi Function Unit (autopilot etc)

- Radio stack

 

A couple of weeks ago i purchased a second Throttle unit and the Cessna Trim wheel from Saitek, and this is where things started to go badly wrong.

 

The Trim wouldn't work despite me downloading the driver from the Saitek site (there was supposed to be a disk in the box with the software and driver but wasnt). It registered in the FSX controls section that there was another controller added, but just wouldn't do anything with it apart from automatically assign all the same buttons and axis as the Yoke. Deleting ALL the settings on the Trim wheel and also those on the Yoke for Trim, didn't help, and every time i shut down FSX, everything just went back to those duplicated assignments.. it was as if i hadn't deleted anything.

 

I contacted Saitek and was told to unplug all the Saitek peripherals, delete all the saitek files including all registry entries and then install them in a particular order from scratch, one by one.

 

Amazingly everything worked perfectly. I even managed to get the throttles working with single, twin, 3 and 4 engine aircraft... success after about 6 hours of effort... or so i thought! :(

 

As soon as i shut down FSX, and re started the FS, all the assignments had changed. Now i had the same assignments for the yoke being mirrored on the throttle and trim wheel again.

 

I did several hours of trolling the net last night and this morning trying to find out what might have gone wrong and finally narrowed things down to the Standard.xml file in the controls sub menu on the Users settings. OK i thought... i'll go through and re-assign all the controls for the yoke, pedals, trim and throttles and then (so it seemed to hint in the posts i read) when i closed down, the Standard.xml file would be updated and date-stamped for when i saved it... Not!

 

I have gone through the permissions for the main FSX folder and the Controls folder and everything is set for all people (admin, System, me) as FULL access with the exception of 'Special permissions which is unticked wherever i open it but it doesn't come up with the changeable tick box for me to change it anyway. I have turned off my antivirus, my UAC is set to None, and i even tried making a copy of the Standard.xml and saving it as something else to see what happened, but the Standard.xml that is in the Controls sub folder just doesn't change! :angry:

 

I have now uninstalled all the saitek peripherals again, deleted all the temp files and registry items, and, because it was still in there, i have edited the standard.xml taking out all the control lines except those for the mouse yoke. I can fly FSX with the mouse ok, but even if i change anything on the mouse controler, its still picking up details from the Standard.xml which i saved when i edited out everything but the mouse commands.

 

I've tried closing FSX by typing CTRL+C... no joy

 

I'm pretty much at the end of my tether... Saitek suggested that if re-installing all the controlers didnt help then i had to reinstall FSX, but with so many add ons, Photo sceneries, FS Global that takes 5 hours to load, etc, I have to consider that a last resort.

 

I know that the reinstall of all the controllers DID work before i closed down FSX, so i'm veering towards it being an issue with FSX not updating something it should be when i shut down, but having made sure the permissions are fully open to me and every other admin,System user, i'm out of ideas.

 

I'm not good at editing anything more than the basics in the .cfg file so i know absolutely nothing about .xml files

Is it possible that there is supposed to be an automatic save function in FSX that has somehow been deleted or become corrupt ?

 

Apologies for 'War and Peace'... thought it best to give all the details now so that you know what i've already tried.

Any bright ideas of what i can try? I honestly don't think reinstalling FSX is going to make much difference if the Standard.xml file isn NEVER being updated when i make changes and close.

 

Fingers and toes crossed. :Praying:

Steph

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

How did/do you exit FSX? It has more than once occured to me that exiting the sim via "ALT+F4" makes FSX forget all controller/key assignments I changed in that session. (The same also happens when FSX crashes after key assignment changes.)

However, if I went back to the "Free Flight" screen, and then pressed the close symbol, all these changed settings are saved. Obviously, that's the only way FSX is supposed to be shut down.

 

Regards

Flo

Share this post


Link to post
Share on other sites

I have about the same setup except i use 3 quadrants.

Make sure you use SPAD for the panels and FSUIPC. Delete/uninstall all saitek crap first though.

Share this post


Link to post
Share on other sites

Hi Flo

Thanks for the response. I always end FSX by clicking the proper close icon. I only tried the CTRL+C because i found it in another thread. Neither makes any difference to the settings failing to save. The Standard.xml actually dates back to may when i did a system restore once. I dont tend to get FSX crashes very often but then again i havent added to my set up for several months.

 

Hi Toedv

I did wonder whether FSUIPC would solve the problem but i know it worked with the Saitek drivers when i reinstalled them plus, having just saved up to buy the extra throttle and trim wheel i cant just splash out 30 odd euro for extra software. The panels also work fine with the saitek software so no nedx for spad. The problem seems to be that FSX wont save the settings in an updated Standard.xml.

 

Any other suggestions?

:-)

Steph

Share this post


Link to post
Share on other sites

Any other suggestions?

Nope.

I messed with it for a long time (and it was a loosing battle) before finally getting FSUIPC and SPAD . If you spent the dough on the HW you pretty much have to add FSUIPC to make it worth while. SPAD of course is free.

This is particularly true if you switch between aircraft types like I do. The profiles function in FSUIPC and SPAD makes life very easy.

Share this post


Link to post
Share on other sites

From your description I could not tell if you have already deleted Standard.xml. This would force FSX to construct a new file. If some odd file problem is the cause, this would be the strongest means to correct it.

 

I have no reason to suppose this will fix this problem, but when I have had strange problems crop up after making no changes, deleting config files (as many as needed) then slowly restoring them has often fixed them.

Share this post


Link to post
Share on other sites

From your description I could not tell if you have already deleted Standard.xml. This would force FSX to construct a new file.

 

Hiya

I haven't deleted the Standard.xml as i thought i'd first try and make changes to see if the time/date stamp changed. Is there anything in particular that i need to do in FSX to get it to create a new one ? i know that FSX automatically creates the config file if it disappears but didn't know it worked for the standard.xml too.

I'll give it a try when i get home.

 

I guess

I would recommend that you use FSUIPC to assign everything.

 

HI Ben

Yeah, i'm going to keep that in 'reserve' in case i have no other options... mind you, looking at the forums for FSUIPC, it looks really complicated. I may end up having to post a plea on here for an idiots guide to help set it up ;-)

 

Will update this post when i have tried deleting the Standard.xml altogether.

Fingers still crossed

 

Thanks again to all who have replied :-)

Steph

Share this post


Link to post
Share on other sites

I haven't deleted the Standard.xml as i thought i'd first try and make changes to see if the time/date stamp changed. Is there anything in particular that i need to do in FSX to get it to create a new one ? i know that FSX automatically creates the config file if it disappears but didn't know it worked for the standard.xml too.

I'll give it a try when i get home.

 

FSX will auto recreate with the default entries for controls.

Share this post


Link to post
Share on other sites

WHICH standard.xml file are you editing? There are two. One is the default and the other is the one that is saved upon exit.

 

The saved one is found in C:\Users|<yourusername>\Appdata\Microsoft\FSX\Controls.

 

Make your changes there. Save the file. Make a copy of the file so you can restore it if something goes amiss. Also note that if you unplug the devices from the USB ports or if your power saving plan shuts down the ports - the assignments may change because Windows will assign a new device ID and set up default settings.

 

Vic

Share this post


Link to post
Share on other sites

From your description I could not tell if you have already deleted Standard.xml. This would force FSX to construct a new file. If some odd file problem is the cause, this would be the strongest means to correct it.

Hats off to you.. I think you might have solved it ! I never knew that FSX would automatically create a standard.xml on exit.

 

I had already deleted all the saitek drivers, files etc. so i made a copy of the standard.xml and then deleted the one that was there. I then set up all the Saitek peripherals one by one with the most up to date drivers, went through the adjustments and re-assignments for the yoke, pedals, throttles and trim wheel then without going flying, i just closed down and hey presto, a brand new standard.xml was created. Although i'm no .xml code reader, it looks like everything is in there! I've made a copy but it seems that i don't need to; for some reason any changes i make to the settings don't tend to 'stick' however, i have a perfect .xml with everything assigned, and if i need to change something i can copy the file, delete the original, make the changes and then copy and paste the important bits.

 

OK.... i'm stilll having a few issues with the trim wheel moving a lot more than it should do but i think thats just a case of tweaking.

 

For those of you that suggested FSUIPC, i have absolutely no doubt that its the best way to have all the controllers assigned and working properly, however, as a stop gap till i can afford to get it, this will do the trick.

 

Thanks to everyone who replied. I really appreciate all your comments and advice.

 

Well chuffed ! :yahoo:

Steph

Share this post


Link to post
Share on other sites