Archived

This topic is now archived and is closed to further replies.

Arismac

200 hours of v1.4 without a CTD

Recommended Posts

I am ecstatic. I have now flown for 200 hours in v1.4 without a single CTD that could be blamed on Prepar3D. All in Orbx scenery with sliders hard right, MyTraffic 3D full on. Active Sky 2012 and Plan-G. Mainly PAD aircraft plus the packaged default.

 

Only one CTD, in the very dense Orbx scenery area near Melbourne, which the staff over Orbx are looking into. Although my rig is high end it is not overclocked, the passing scenery is as smooth as satin and a joy to behold.

 

PS: I am old and disabled which is why I can clock up these sort of hours and am looking forward to hundreds more. Many thanks to LM and to the many people who have provided advice hints and tweaks to give me a future to look forward to. Truly something to aspire to for all who enjoy FS and it can only get better from here.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

200 hours in v1.4 without a single CTD.

 

Please tell us your install process and add to the compatibility database.

 

So pleased you are pleased!

 

Chas

 

 

 

Arismac, did you do a new install of 1.4 or did you "migrate" from 1.3?

 

Please tell us your install process and add to the compatibility database.

 

So pleased you are pleased!

 

Chas

Share this post


Link to post

I get several crashes with 1.4 in Orbx country, around ksea and upward past concrete. Sliders not maxed out, but high. Not sure why yet, but definitely annoying.

 

Sent from my HTC One X using Tapatalk 2

Share this post


Link to post

I have 1.4 nothing added on and still have the same menus.dll error I had in 1.3 - which had PMDG 737,ORBX, and other scenery.

 

Have just flown the Mooney in 1.4 and still have menus.dll error and happens randomly. Thought it was the addons in 1.3 but looks like P3D doesn't like my computer.

 

WIN7 64,i5 2500 3.3,8gig ram,Asus P8Z68-V-Pro,GTX 560TI 2gb.

 

So I think it will not be used as a flightsim but as an experiment.

 

Denis the Menace :rolleyes: :wacko:

Share this post


Link to post

With 1.3 I had the menus.dll. With V1.4 and many, many hours and 1/2 round the world in a Baron. 0 errors. Clean 1.4 install. Its been stated by LM , they use a different menus callback routine then FSX. So if addons arent using the P3D callback, there may be errors. Im no programmer so not sure if I worded or conveyed this correctly. Short is, its probably not P3D but the addon compatability

 

You can read it here.

 

http://www.prepar3d.com/forum-5/?mingleforumaction=viewtopic&t=810

Share this post


Link to post

I have no addons and 1.4 fresh install and using mooney - no scenery addons, no fsuipc and still get random menus.dll CTD - so like I say P3D does'nt like my computer.

My setup is WIN7 on one SSD,FSX on 2nd SSD and P3D on its own 250 IDE HDD.

I did format the P3D before re-install of 1.4 so must be my "funny" computer.

 

Thanks for reply

 

Denis

Share this post


Link to post

Well to be honest I'm totally cheesed off with 1.4, I have the same scenery installed (reinstalled completely fresh) and in Orbx PNW regions I am getting hammered with G3D.dll crashes despite having the latest version of FSUIPC installed (which only catches 1 version of this crash), also get loads of

d3d9.dll errors (which is linked to Enbseries) and d3dx9_26.dll crashes which also seem to be linked to Enbseries because when these start I cannot even start the sim unless I remove the d3d9.dll file from the root directory. Even without this and lowering settings I am still getting the G3D crashes, didnt get them in 1.3 and no longer have the install files for 1.3. Going to sent Pete Dowson a message though doubt he can help. If not will be binning FSX/Prepar3D yet again like I did a couple of yrs back before Pete sort of fixed the most common crash which related to a certain fault offset

 

Chris Ibbotson

Share this post


Link to post

G'day all. I approached v1.4 as a brand new program. I used the Windows Control panel to uninstall v1.3 and then manually deleted all the Lockheed Martin\Prepar3D folder. I also deleted all the .cfg files in AppData folder(s). I then defraged the VRaptor which is a dedicated P3D drive.

 

I then reinstalled P3D according to the LM instructions. Installed a new version of FSUIPC and Plan-G and ran the Orbx Migrator Tool. I then installed MyTraffic 3D. Active Sky 2012 remained in use from my primary drive which is a Vertex-3 SSD. Finally I ported several aircraft from FSX on the primary drive and reinstalled several more from such as a Just Flight BAe 160-200.

 

Added a few tweaks to the new prepar3d.cfg file to suit my computer specs and everything worked exactly as intended. Good stuff.

Share this post


Link to post

"Well to be honest I'm totally cheesed off with 1.4, I have the same scenery installed (reinstalled completely fresh) and in Orbx PNW regions I am getting hammered with G3D.dll crashes despite having the latest version of FSUIPC installed"

 

Chris - you seem to be worse off than me - at least I can run P3D and then wait for the menus.dll crash :wacko: :mad: - anyone know where we could look to find the "menu culprit or any culprit " that creates the errors.

 

Just a thought - Denis :blink: ^_^

Share this post


Link to post

If you are getting a repeated CTD in the same place using Orbx scenery it may be very useful if you reported over at the Orbx Forum. In my case I got two CTD caused by the G3D.dll as I hit the runway at YLVT. I then switched FSX Central to default scenery and the CTD vanished. So reported to Orbx who are investigating. LINK HERE

Share this post


Link to post

G'day all. I approached v1.4 as a brand new program. I used the Windows Control panel to uninstall v1.3 and then manually deleted all the Lockheed Martin\Prepar3D folder. I also deleted all the .cfg files in AppData folder(s). I then defraged the VRaptor which is a dedicated P3D drive.

 

I then reinstalled P3D according to the LM instructions. Installed a new version of FSUIPC and Plan-G and ran the Orbx Migrator Tool. I then installed MyTraffic 3D. Active Sky 2012 remained in use from my primary drive which is a Vertex-3 SSD. Finally I ported several aircraft from FSX on the primary drive and reinstalled several more from such as a Just Flight BAe 160-200.

 

Added a few tweaks to the new prepar3d.cfg file to suit my computer specs and everything worked exactly as intended. Good stuff.

 

I did this too, prior to installing 1.4 I uninstalled every addon via the control panel then removed P3D and FSX then deleted all remaining files then started afresh install. If I install Orbx using the Estonia FSX to Prepar3D migration tool I get lots of G2D.dll crashes, if I install ORBX into FSX then use their migration tool I dont get G2D errors but now get G3D errors.

Share this post


Link to post

if I install ORBX into FSX then use their migration tool I dont get G2D errors but now get G3D errors.

Sorry Chris, I should have said. It seems the Orbx related CTD does show up in the log as a G3D.dll crash. Like you I have not seen a G2D.dll crash with v1.4. Perhaps try flying the same route in default scenery?

Share this post


Link to post

No Javier, Lockheed Martin do not flag release dates for any upgrade. See the Prepar3D Forum for more info.

Share this post


Link to post

Hey Arismac, do you have P3D installed on your SSD or your Velop?

Share this post


Link to post

P3D is on the VRaptor. I still have FSX installed along with the OpSys on the SSD. Using identical settings for the two sims, P3D is out performing FSX by about 20% on my machine.

Share this post


Link to post

Be careful with those 20%... while I had quite a lot of boost in my initial tests, I found out that for some reason (in process of researching) my FSX was running way slower than it should.

Share this post


Link to post