Jump to content

Archived

This topic is now archived and is closed to further replies.

Chfeudpail

AI traffic strange problem

Recommended Posts

Hi guy's ,

 

Just a very few "ai planes" are landing at busy airports, the departure traffic seem normal. I have hundreds of packages installed.

 

What could cause that problem ?

 

I used to get loads of plane coming in as in real life....

 

Any idea what could cause this decrease in landing traffic ? AFCAD's and traffic settings are properly adjusted.

 

Thanks !!!!

Share this post


Link to post
Share on other sites

What have you changed since it worked properly?

 

What is your indication that planes aren't landing? Could they be landing and disappearing? That's an indication of insufficient parking spaces.

 

How many airports are affected?

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for your message !

 

I am an old Time FS9 ultimate geek, as soon as a new ai traffic package goes out in avsim I would install it , so I have lots of airlines and most of them are the latest packages available.

 

For example yesterday I was running Fs9 in Atlanta to do some spotting :) where I have an add on installed with lots of parkings and it just seems that just a very few aircrafts are appearing for landing , Over a 4X hour lapse I would only see like 20 planes landing. Departure traffic seems normal and what happens as I don't see planes landing is that they would suddenly appear on empty parking places.

 

I don' t have this arrival rush typical when you load fs9 at a busy airport. ( ai traffic from the last 15 mins prior loading arriving/departing ).

 

I am using windows 7. All traffic sliders to the right.

 

Very weird problem !!!!!

 

Any clues ?

 

Thanks!!!!

Share this post


Link to post
Share on other sites

Any clues ?

 

Which AI packages are you installing and if necessary what are you compiling the plans with? If you are using any flight plans and manually installing them with Traffic Tools then you need to open the aircraft text file and change all aircraft speeds to 200 unless of course the speed listed is already 200 or less. There is a issue involved that can cause no shows and AI appearing at the gate when compiled with TTools and speeds set to what one think should be normal. With the 'other' traffic compiler there is no such issue. Adequate parking doesn't sound like the problem so the above would be my first guess. W7 - UAC off and proper permissions so everything cooperates?

 

Regards,

Mel


Mel

Flight Sim Addict

:American Flag:

Share this post


Link to post
Share on other sites

...

I am an old Time FS9 ultimate geek, as soon as a new ai traffic package goes out in avsim I would install it , so I have lots of airlines and most of them are the latest packages available.

...

 

I am too, although lapsed (I have a backlog folder with about 200 repaints and flightplans awaiting my attention)! Apart from the obvious AFCAD and timing issues, have you got any AI 'optimisation' software running such as AISmooth or AISeparation? In some cases I have seen reduced traffic from the expected level if they are preventing too many of the AI planes from approaching...

Also, is this only at certain times? I have noticed that there are definate 'quiet' times with my AI but have no evidence of anything being really wrong.

 

Geoff

Share this post


Link to post
Share on other sites

If you are happy that ai is set to 100% and that your AFCAD is ok, and that your flightplans are in order then I suggest looking at the aircraft.cfg files of your most populous ai aircraft. If one of the fltsim.x entries has become corrupted, then all later numbered aircraft will never show.

 

Peter


Peter Schluter

Share this post


Link to post
Share on other sites

Hi guy's thanks for your good responses !

 

I am basically installing every "latest" package available on avsim , so I mostly nowadays get alpha india's group packages , some "authors" ones and I have a few WOAI's remaining as well + others ( utt, MAIW, RATS.... )

 

Indeed I am using TTools to compile the "text" files by renaming the acft titles to match; I was not aware of this 200 kts bug !!!! , I've done that since years now ! Before I was using the mrai compiler. What other program would you use then ?

 

It will take forever if I have to redo all the aircraft files !!!!! Or is there any way to convert bgl's back to the text files ? :)

 

I am not using Aismooth nor speration and I was spotting at peak hours at many busy airports with proper AFCAD's, settings etc.... It seems to be a "general" problem !!!

 

I used ACA2005 to see IFR's dep. and arr. at several airports on "wednesday/24h lapse" but the numbers seem correct : e.g. :- LEMD : 600 dep's ; 596 arr's - EGLL : 719 dep's ; 723 arr's ..... KATL 1291 dep's : 1282 arr's ; so it is not a " flightplans problem ". And for your info I have 909 airplanes installed, 917 flightplans files, 41197 flights and 997223 legs !!!! So good enough to create some landing jams !!!

 

I tried removing .bgl's but no change and when I use Traffic view board 128nm in ATL I get like 5 pages of mostly atl dep's and barely 1 page of atl' arr's...

 

Any more clue's ?

 

Cheers !

 

All the airlines are showing , but on the ground and for take off , but very few show for landing.... my aircraft.cfg files are in order...

 

And after a while I even get no mare arrivals at all !

 

Ah yes 3 planes on approach in ATL within 128nm and 35 boarding now !! ! my airport is getting empty quick !

 

The best sor far is 9 planes in approach within 128nm !!!

Share this post


Link to post
Share on other sites

Hi.

 

Traffic Tools will decompile traffic.bgl into airports.txt, aircraft.txt and flightplans.txt, you just need to put the bgl file into the designated 'traffic' folder and hit the decompile button. The decompiled text files end up in the 'source' folder.

 

Further, if you are considering a complete rebuild, I think you should be ok with making just one all-encompassing 'good' aircraft.txt containing everything, then using copies of that when recompiling each of the separate traffic.bgl files, though if your flight plans have come from disparate sources you'd need to be sure that the AC# designations are all correct. That could end up being more trouble than it's worth. I think you may also have to be careful with the naming of the files: *new.txt will compile into trafficnew.bgl but naming the text files as new*.txt won't work.

 

And, on top of that, if you're writing your own flightplans.txt, put a @ prefix on the arrival time for each leg (e. g. ... ,@22.15.30, ...) and Traffic Tools will adjust the cruise speed to accomodate the now obligatory arrival time.

 

I'm currently cleaning up my AI-- I have Ultimate Traffic (the original) and have been spending happy hours replacing the Flight1 AI with more realistic models, replacing bad flightplans with home-made plans to match U-Traffic's timetables, correcting inappropriate airports, filling in some large holes in the assigned aircraft et c... almost as engrossing as flying!

 

Mel, thanks for the 200 kt tip-- you've given us another gem.

 

Best regards,

D

Share this post


Link to post
Share on other sites

 

 

, but very few show for landing.... my aircraft.cfg files are in order...

 

And after a while I even get no mare arrivals at all !

 

 

Sounds like the 200 knots/@arrival time bug if that is the case. There is a program called AIFP (ai flightplanner) which you can download for free. If nothing else the manual explains the 200 knots/@ arrival time bug. If you have been compiling plans with TTools and not changing the speeds in the aircraft.txt file you will over time experience the problem you are describing. You can use AIFP to create plans without worrying about the "bug".

 

Btw if you also look for a free program called ACA2005 you can scan for errors in all your aircraft files. It is well worth doing especially if like me you manually add/remove AI a/c to the sim.

 

Peter


Peter Schluter

Share this post


Link to post
Share on other sites

CHfeudpai: What? ...Were you looking over my shoulder when you posted this? I posted the same exact problem months ago. The exact same. Like you I like to spot. Used to love watching the landings and take offs from LAX. Now nothing. Yes takeoffs and ground traffic are fine but nothing lining up to land or even in the skies. Weird. Like you I am an FS9 Geek and tried various sollutions with no luck and yes I tried the 200 sollution and again no luck. I am perplexed. I do use alot of different authors on AI but that should not be a problem. I will keep watching this thread to see if there are any newer easier sollutions then a total overhaul. BTW for anyone else reading this that finds entering all the new ai traffic files tedious we should form a club and somehow share the load by sending each other the plane and traffic files already compiled. Just a thought cause I am too backed up as well and now all the wi 12-13s coming out.

Share this post


Link to post
Share on other sites

I think the simple rule is that if you use TTools/Ultimate Traffic (original version) , then if your flightplans use the @ format for arrival times you need to have 200 knots for jets and a lower number for props specified in the aircraft.txt files.

 

The whole idea is that you dont want the aircraft to arrive "late", otherwise FS9 simply populates the a/c at the arrival gate.

 

I update flightplans often and always check. I dont have any problems with aircraft not landing.

 

My suggestion to the OP is simply to follow these rules on all his subsequent flight plans and over time he will get back to normal. Perhaps start by re-doing just those plans for major airlines at major hubs he visits.


Peter Schluter

Share this post


Link to post
Share on other sites

@Sonebone

 

Hi , glad to hear I am not the only desperate !!! Very weird bug indeed , will try the 200kts trick over time... Cheers !!!

Share this post


Link to post
Share on other sites

I just recompiled Delta, Delta connection and Spirit airlines with 200kts speed and it seems to slightly increase landing traffic... coincidence ?

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,710.00 of $25,000.00 Donate Now
×
×
  • Create New...