Jump to content

Archived

This topic is now archived and is closed to further replies.

FlyingTib

gtx260_dx10_FSAA with NI not working

Recommended Posts

First at all, Hi and many thanks for that very good dx10 tutorials!

 

Didnt think there would be a way to use dx10 after all this years of tweaking, but i tried all your tips and have to say very very nice and smooth goin in fsx.

Would be my favourit but...

 

seems fsaa enhancement with NI doesnt work at all with (my?) Nvidia gtx260 card in dx10.

 

In dx9 it does what it should.

 

Tested nearly all combinations of FSAA, SGSAA, enhance/override, Profiles, ingame fssaa on/off etc.

No reaction with dx10 in fsx at all!

 

Only the built in fsaa of fsx is working which isnt that bad, but the

shimmering of the trees and in the cockpit is terrible and makes it useless for me.

Too sad , the dx10 experience (smooth action, cockpit shadows, water effects..) are very nice.

 

Can you confirm this incompatibility with gtx260 or (better) is someone out there who knows the "trick"?

 

Thanks anyway.

Share this post


Link to post

The shimmering is fixable by ensuring all sceneries are mipped, and by using 2, 4 or 8xSGSS.

 

Plus you might find a 560Ti or better will help, but to give you some help which may be of value to you, we rally need to see what system, including any overclock is, also what your Inspector and fsx.cfg settings are.

Share this post


Link to post

Thks for reply.

 

Mips:

I tested all textures with the tool linked in the dx10 howto. No Problems found.

The flashing occures in all sceneries, original and addon. No difference.

 

SGSSAA:

That's what i tested in all variants an all combinations with/out different FSAA-settings...

No reaction at all in dx10-mode (dx9 works flawless with NI-settings).

 

560Ti:

Guess a new card could be the solution in this case. Especially because it's stated, that one needs a powerful one to avoid stutters and low fps using SGSSAA.

In some posting in the 3-d center forum there was the hint, that pre-Kepler cards wouldn't support the enhancement of ingame fsaa with NI.... (not official though).

 

System specs:

3570K@4,2 - 8GB - W7/64uptodate - GTX260 - FW310.90 - NI1.9.6.9

 

NI-settings:

I don't post any NI-settings, because i had more than 50 different combinations of FSAA,SGSAA,enhanced/forced,MSAA/SSAA,compatibility-bits.......

(Including all combinations posted by anybody else here before)

 

FSX-settings:

Didn't post them (i didn't want to waste your time by examining my settings), because i hope someone else is using an gtx260 and knows.....

 

Anyway, this is my fsx.cfg for the dx10 testing ("not permitted to upload this kind of file"....):

Made from a fresh install of fsx with changes from the dx10-howto

 

[bufferPools]

BufferPools=1

PoolSize=10485760

RejectThreshold=524288

 

[GRAPHICS]

MultiSamplesPerPixel=4

MultiSampleQuality=8

SHADER_CACHE_PRIMED_10=1693500672

SHADER_CACHE_PRIMED=1693500672

D3D10=1

Highmemfix=1

TEXTURE_MAX_LOAD=1024

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=0

AIRCRAFT_REFLECTIONS=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=0

AC_SELF_SHADOW=0

EFFECTS_QUALITY=2

GROUND_SHADOWS=0

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

 

[sOUND]

AmbientUIMusicVolume=-6.000000

SOUND_FADER1=0.500000

SOUND_FADER2=0.500000

SOUND_FADER3=0.500000

SOUND_FADER4=0.500000

AmbientUIMusic=FSX01

PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}

VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}

SOUND=1

SOUND_QUALITY=2

SOUND_LOD=0

UISound=1

AmbientUI=1

 

[Display]

ChangeTime=4.000000

TransitionTime=4.000000

ActiveWindowTitleTextColor=255,255,255

ActiveWindowTitleBackGroundColor=0,28,140,64

NonActiveWindowTitleTextColor=255,255,255

NonActiveWindowTitleBackGroundColor=24,33,87,64

InfoUpperRightTextColor=255,0,0

InfoUpperRightBackGroundColor=0,0,0,0

InfoLowerLeftTextColor=255,255,255

InfoLowerLeftBackGroundColor=255,0,0,128

InfoLowerRightTextColor=255,255,255

InfoLowerRightBackGroundColor=255,0,0,128

InfoBrakesEnable=True

InfoParkingBrakesEnable=True

InfoPauseEnable=True

InfoSlewEnable=True

InfoStallEnable=True

InfoOverspeedEnable=True

BLOOM_EFFECTS=0

SKINNED_ANIMATIONS=1

TEXTURE_BANDWIDTH_MULT=40

UPPER_FRAMERATE_LIMIT=0

WideViewAspect=True

 

[Main]

Fiber_Frame_Time_Fraction=0.1

User Objects=Airplane, Helicopter

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

ProcSpeed=17599

PerfBucket=7

Maximized=1

Location=320,115,1360,893,\\.\DISPLAY1

HideMenuNormal=0

HideMenuFullscreen=1

 

[PANELS]

IMAGE_QUALITY=1

DEFAULT_VIEW=0

QUICKTIPS=1

PANEL_OPACITY=100

PANEL_MASKING=1

PANEL_STRETCHING=1

UNITS_OF_MEASURE=0

 

[Weather]

WindshieldPrecipitationEffects=1

MinGustTime=10

MaxGustTime=500

MinGustRampSpeed=1

MaxGustRampSpeed=200

MinVarTime=5

MaxVarTime=50

MinVarRampSpeed=10

MaxVarRampSpeed=75

TurbulenceScale=1.000000

WeatherServerAddress=fs2k.zone.com

WeatherServerPort=80

WeatherGraphDataInDialog=0

AdjustForMagVarInDialog=1

DynamicWeather=2

DownloadWindsAloft=0

DisableTurbulence=0

CLOUD_DRAW_DISTANCE=3

DETAILED_CLOUDS=1

CLOUD_COVERAGE_DENSITY=8

THERMAL_VISUALS=0

 

[DISPLAY.Device.NVIDIA GeForce GTX 260.0]

Mode=1680x1050x32

Anisotropic=1

AntiAlias=1

 

[AccelerationPack]

ControlsFirstRun=0

HomePageFirstRun=0

 

[CONTROLS]

Controls_Default=Standard

Controls_Current=Standard

KBDAIL=64

KBDELEV=64

KBDRUD=64

JOYSTICKS=1

 

[TextInfo.1]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

WindDirectionAndSpeed=1,6

 

[TextInfo.2]

FrameRate=1,1

LockedFrameRate=1,2

GForce=1,3

FuelPercentage=1,4

 

[TextInfo.3]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

WindDirectionAndSpeed=1,6

FrameRate=2,1

LockedFrameRate=2,2

GForce=2,3

FuelPercentage=2,4

 

[slewTextInfo.1]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

 

[slewTextInfo.2]

FrameRate=1,1

LockedFrameRate=1,2

 

[slewTextInfo.3]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

FrameRate=2,1

LockedFrameRate=2,2

 

[DynamicHeadMovement]

LonAccelOnHeadLon=-0.020000

LonAccelOnHeadPitch=-0.010000

RollAccelOnHeadLat=0.010000

YawAccelOnHeadLat=-0.100000

RollAccelOnHeadRoll=0.100000

MaxHeadAngle=5.000000

MaxHeadOffset=0.300000

HeadMoveTimeConstant=1.000000

 

[VirtualCopilot]

VirtualCopilotActive=0

 

[uSERINTERFACE]

PageID=1

OpenATCOnCreate=0

SHOW_MISSION_CAPTIONS=0

PAUSE_ON_LOST_FOCUS=1

PROMPT_ON_EXIT=1

SITUATION=FLIGHTS\OTHER\FLTSIM

Map_Orientation=2

ShowAllACPaintSchemes=0

SelectAircraftManufacturer=Alle

SelectAircraftPublisher=Alle

SelectAircraftType=Alle

 

[ATC]

ShowATCText=1

COMM_MSG_NONE_COLOR=FFFFFFFF

COMM_MSG_ATC_USER_COLOR=FFB6FFB6

COMM_MSG_USER_ATC_COLOR=FFFFD21B

COMM_MSG_ATC_AI_COLOR=FF00FF00

COMM_MSG_AI_ATC_COLOR=FFFF7840

AutoOpenAirTrafficWindow=1

UsePilotVoice=1

PilotVoice=0

 

[PointOfInterestSystem]

CycleSetting=0

 

[sCENERY]

LENSFLARE=0

DAWN_DUSK_SMOOTHING=1

IMAGE_COMPLEXITY=5

 

[TrafficManager]

AirlineDensity=20

GADensity=20

FreewayDensity=10

ShipsAndFerriesDensity=0

LeisureBoatsDensity=0

IFROnly=0

AIRPORT_SCENERY_DENSITY=3

 

[TERRAIN]

LOD_RADIUS=4.500000

MESH_COMPLEXITY=100

MESH_RESOLUTION=24

TEXTURE_RESOLUTION=29

AUTOGEN_DENSITY=5

DETAIL_TEXTURE=1

WATER_EFFECTS=4

 

[AContain]

ShowLabels=0

ShowUserLabel=0

ShowLabelManufacturer=1

ShowLabelModel=1

ShowLabelTailNumber=0

ShowLabelDistance=1

ShowLabelAltitude=1

ShowLabelAirline=0

ShowLabelAirlineAndFlightNumber=0

ShowLabelFlightPlan=0

ShowLabelContainerId=0

ShowLabelAirspeed=0

ShowLabelHeading=0

LabelDelay=1000

LabelColor=FFFF0000

 

[iNTERNATIONAL]

ASLAT=2

ASLON=1

MEASURE=0

 

[REALISM]

PFactor=1.000000

Torque=1.000000

GyroEffect=1.000000

CrashTolerance=1.000000

General=1.000000

UnlimitedFuel=False

AllowEngineDamage=True

TrueAirspeed=False

AutoCoord=False

RealMixture=True

StressDamage=False

GEffect=True

ManualLights=True

GyroDrift=False

CrashWithDyn=False

CrashDetection=False

AutoTrim=False

 

[sIM]

SYSCLOCK=1

 

[sTARTUP]

DEMO=0

SHOW_OPENING_SCREEN=1

STARTUP_DEMO=

LoadWindow=1

 

[FACILITIES]

COUNTRY=

STATE=

CITY=

GTL_BUTTON=4096

 

[Misc]

Com_Rate=7

 

[Trusted]

F:\FSX\GAUGES\Cessna.DLL.hnibwuonnkiucczeaulkbazeizqlehciuibaknlw=2

F:\FSX\GAUGES\Cessna172.DLL.heawhbnuqwbrlehewelokqnchenoqrzoknwnwrzr=2

F:\FSX\GAUGES\Cessna182s.DLL.baqewzrbzkzootqthtcntwkkqabwiwutkwnoatnz=2

F:\FSX\GAUGES\CessnaWAlpha.DLL.lzauquiqahqqiawkkknqhelwkzhkkkhwnrtikotr=2

F:\FSX\GAUGES\Bendix_King_Radio.DLL.whalabcbinuokwihtkqlwrcoetwqackzqznoahzq=2

F:\FSX\GAUGES\Bell_206B.DLL.hcanwnhkweaiauhqzatqeqtbulrqzbtrekcnltlh=2

F:\FSX\GAUGES\fa-18.DLL.noqhbbnenaaiqkolkbciewlouhnqziqtcinozelr=2

 

[MULTIPLAYER]

condAccoutPassword=0

 

Tib

Share this post


Link to post

You need to match your fast processor with an equally fast GPU, Tib.

Image Complexity and CloudDensity are the only parameters which seem high for the proc speed, and I would think your BufferPools have to be wrong because of that cpu/gpu mis-match.

Shimmering is generally fixed by those two methods - SGSS and /or mipmaps (also lowering water settings, but yours are ok).

 

In general, post-processing AA tools have little effect on AA, and usually "blur" the entire image, rather than merely fix the AA. The only one which I've personally tried - and now use - is SweetFX, which provides adjustable bloom, vibrance, hue, saturation, sharpness, gamma gain and dither.

 

Anyway - while I don't know your budget - my suggestion would be for you to purchase something in the order of a GTX 580, a 660Ti, a 670 or even a 680- OK? :smile:

Share this post


Link to post

BufferPools:

Tested those too. ON/OFF, different (lower and higher) values and in combination with different RejectThreshold values.

Also tested the recommendation from "Bojote".

Didn't help with this special problem.

 

Postprocess:

Interestingly this had a an effect. Minor and blurry, as you stated, and not related to my flashing problem, but noticeable.

 

I know its a little bit like riding e dead horse with this card, and i surely will buy a better one not so fare in the future.

And i still would have done before, if dx9 wouldn't work nicely as it does....

(Using MS-Flightsimulator from the beginning on C64 and PC not only was simulating, it was "tweaking" too because PC-power was not strong enough ever.... guess i have spend more time "tweaking" than flying....).

 

But thks for your reply, i'll take your suggestion for a new card to my "list of arguments" .... the day will come ;))

 

Tib

Share this post


Link to post

Watching this thread for answers as well....

 

I"m a recent DX10 convert as well and also have terrible AA within FSX plus shimmering with a GTX 580 (306.97) and nothing I do in NI seems to affect anything in FSX !

 

Can't say i done as much experimenting as the OP but for sure something ain't right.

 

cheers

Share this post


Link to post

@ Trim:

 

With a 2700K you ought to be up at 4.8+ GHz, Trim, allowing/giving everything more time to work much better - like 8x SGSS... :Thinking: hmmmm....

 

Try this: use this NI setting: do the mip-testing, using AlphaSearcher2 and ConvimX, and also - this "fix" from a post that's been around for a long time - here.

 

If you've done all three of these as a fix - and you still have shimmering - then there's something else going on with your machine.

 

 

@ SkipH with the 680 - Can't make much of a suggestion as I have no idea what machine you have, mate - you need to post your pc parts in your Profile, so we can see it. Thanks.

Try what I've suggested for Trim above, as it should also work for you, but if your proc is a bit slow, you'll be hard-pressed to run 8xSGSS.

Share this post


Link to post

Hi Paul, I have plenty of horse power I believe. I'm running a 3930 @4.6 with Gigabyte memory at 2400 x 16gig stable, and Win 7 x64. The 680 I will upgrade when the new Nvidia chip is available. I went with the Sandy because of the 6 cores. Anyway, I will read the 2 options you left for Trim and report back. The shimmering is only in the DX 10 mode. I have P3d, which only runs Orbx scenery, is flawless. And FSX just runs UTX and GEX scenery is flawless in DX-9. Mip the scenery? Did not see that in the How to Doc. Tnx, Skip

Share this post


Link to post

Hey Skip; Yeah - it's not included in the How-To doc, but it is on page 15 of the more general Avsim Guide here:

 

Let us know how you make out.

 

All the Best,

Share this post


Link to post

Interesting to hear, that even with a gtx580 and gtx680 the problem exists.

 

Just to clarify,

 

the problem here is, that Nvidia Inspector settings doesn't have an effect at all in DX10 while in DX9 it does....

 

(And because it doesn't, there is no way to eliminate the flickering/shimmering trees/virtual cockpit/.... and others as we can in DX9 where NI is doing what it should. Its not a question of GPU-/CPU-Power.)

 

Tib

Share this post


Link to post

Nvidia Inspector settings have the same effect in Dx10 as they do in Dx9.

The only difference is that the anti aliasing box must be ticked in Dx10.

 

Someone who posts that they have a GTX 580 or 680 (I have a GTX570) and Inspector settings make no difference is not using

it correctly.

A probable reason is that they are editing the global settings and not the built in Microsoft FSX profile which

overrides the global settings.

 

I did find that there are some fixed settings (at the bottom) in the default MS FSX profile that caused some shimmering of straight lines in the VC.

I got round this by applying all the recommended settings to the default (global) settings and then saved them as a new profile

which I named "FSX".

When I linked the new profile to fsx.exe, Inspector removed its own MS FSX profile and replaced it with mine.

You may wish to try this, the default FSX profile can be restored only by re-installing the Nvidia drivers, however.

 

With antialiasing set at 8xSQ and SGSS set at 8x AND the two lines below in Dx10 fsx.cfg

 

[GRAPHICS]

MultiSamplesPerPixel=4

MultiSampleQuality=8

 

I have so little shimmering that I need to stare hard to even see it, in fact less than I

occasionally see in Dx9.

 

Combine that with the far better performance, even with all the sliders (except water and traffic) to the right and a LOD radius of 9.5,

highly complex aircraft such as those by Captain Sim and Milviz and extreme density of scenery objects such as found in OrbX

and some quality addon airports, there is no contest.

In Dx9, I simply can't use such high settings without seeing artifacts.

Share this post


Link to post

Lol i which it was so easy.....

I tested all settings and combinations posted here and i guess everywhere else.

And i systematicly tested much more other combinations..

I can tell you NI definitely does not the same in dx10 with my gtx260.....it does nothing at all...

Thats why im searching for somebody using a gtx260 too who got NI working with sgfsaa/ssaa... in dx10. Didnt find anybody up to date.

Somebody using another graphiccard is useless for me because you cant say what works with yours has to work with all others too.

Tib

Share this post


Link to post

If your testing has been so thorough as to convince you that your GTX260

will not work correctly for FSX Dx10, so be it.

It seems likely that you have exhausted the possibilities and that the card does not

supports some of the features of the 300 series of drivers.

 

My reply may be useless to you but there are other people watching this topic whose

graphics cards are certainly capable.

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,525.00 of $25,000.00 Donate Now
×
×
  • Create New...