Sign in to follow this  
Ricardo41

"No Takeoff" Cessna Citation X?

Recommended Posts

I follow all the checklists, still the blue "no takeoff" sign wont go out on the eicas panel. Advancing the throttle generates a warning sound. What am I missing?ricardo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am assuming you are using the Eaglesoft Citation X. If so, make sure you have the flaps lowered. Don't know what else could be causing it that doesn't show up on the eicas panel.Jim

Share this post


Link to post
Share on other sites

Flaps have to be down and the elevator trim has be set in the green area on EICAS. Austin

Share this post


Link to post
Share on other sites

Take your trim up to at least 2.8 as well as flaps. Put on the Pitot heat while you're at it.

Share this post


Link to post
Share on other sites

Duh! Figured it out myself after a while - adjusted elevator trim to be in the green.ricardo

Share this post


Link to post
Share on other sites

>Duh! Figured it out myself after a while - adjusted elevator>trim to be in the green.>ricardoMight I suggest TWO things?1) Please read the manual. All those words and pictures are there for a reason.2) Please register and use the forums at http://eaglesoftdg.com for issues related to the Citation X or any other Eaglesoft product.All of your questions have been asked and answered a number of times, and all of those FAQs publicly posted at the website.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this