Archived

This topic is now archived and is closed to further replies.

captain420

My F12 = Top View is not working

Recommended Posts

Under my FSX settings, my F12 key is currently assigned to View 4 or whatever, not sure if this is the default or what, but I'm trying to assign Top View to F12. I have even went into the settings and found the Top View and assigned F12 to it, and when I press it. Nothing happens.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are you using OpusFSX? If so, there is a thread about this in the OpusFSX forum. The latest beta of OpusFSX has the fix.

Share this post


Link to post
Share on other sites

Yes I am and I already did everything mentioned in that thread but it still doesn't work for me.

Share this post


Link to post
Share on other sites

I use OPUS and used to have this problem too, here is the way I have always fixed my F12 view and it works every time for me:

 

TOP DOWN VIEW IN FSX Reset
 
1) Go to cameras.cfg (c:\users\<yourname>\appdata\roaming\microsoft\fsx)
 
2) Find:
 
[CameraDefinition.006]
Title = Top-Down
Guid = {A2849229-938A-448f-8AC6-01EF2291C171}
Description = This is the description of the map or top down view.
Origin = Center
SnapPbhAdjust = Orthogonal
PanPbhAdjust = Orthogonal
Track = None
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 256
SmoothZoomTime = 2.0
ShowWeather = No
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Outside
HotKeySelect=4
 
3) Change the HotKeySelect=4 to 6
 
4) Go into FSX and change View camera 4=F12 to View Camera 6=F12
 
Can't remember exactly where I got this but I think it might have been back when I was using EZDok before moving to OPUS.
 
Hope it works out for you!
 
Aaron

Share this post


Link to post
Share on other sites

Tried that but when I hit F12 it shows me my virtual cockpit view? This is what I have in my cameras.cfg

 

[CameraDefinition.006]
Title = Top-Down
Guid = {A2849229-938A-448f-8AC6-01EF2291C171}
Description = This is the description of the map or top down view.
Origin = Center
SnapPbhAdjust = Orthogonal
PanPbhAdjust = Orthogonal
Track = None
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 256
SmoothZoomTime = 2.0
ShowWeather = No
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Outside
HotKeySelect=6

Share this post


Link to post
Share on other sites

Certain planes do this... For instance the recently released F1 King Air does this to me. Thankfully the G1000 has safe taxi so I don't need top down.

Share this post


Link to post
Share on other sites

I see, it takes me to cockpit view when I hit f12 even thought I have it assigned to top view. Oh well, I guess I can manually get to it using the mouse and menu.

Share this post


Link to post
Share on other sites

I haven't tried any other planes yet, just the realair lancair legacy.

Share this post


Link to post
Share on other sites

Ahhh. I disabled opus camera stuff on my end thus why im not seeing this.

Share this post


Link to post
Share on other sites

Sigh, this is really bothering me. I tried other planes and it does nothing when i Hit F12. I have this in my cameras.cfg file:

 

[CameraDefinition.006]
Title = Top-Down
Guid = {A2849229-938A-448f-8AC6-01EF2291C171}
Description = This is the description of the map or top down view.
Origin = Center
SnapPbhAdjust = Orthogonal
PanPbhAdjust = Orthogonal
Track = None
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 256
SmoothZoomTime = 2.0
ShowWeather = No
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Outside
HotKeySelect=4
 
I have tried assigning the HotKeySelect=6 as well and tried assigning F12 to it, and still nothing. The only way I can access Top View is via mouse and menu. I'm not sure why it's not triggering. Something must be causing some sort of conflict.

Share this post


Link to post
Share on other sites

 

Sigh, this is really bothering me. I tried other planes and it does nothing when i Hit F12. I have this in my cameras.cfg file:

 

[CameraDefinition.006]
Title = Top-Down
Guid = {A2849229-938A-448f-8AC6-01EF2291C171}
Description = This is the description of the map or top down view.
Origin = Center
SnapPbhAdjust = Orthogonal
PanPbhAdjust = Orthogonal
Track = None
ShowAxis = Yes
AllowZoom = Yes
InitialZoom = 256
SmoothZoomTime = 2.0
ShowWeather = No
XyzAdjust = FALSE
Transition = No
ShowLensFlare=FALSE
Category = Outside
HotKeySelect=4
 
I have tried assigning the HotKeySelect=6 as well and tried assigning F12 to it, and still nothing. The only way I can access Top View is via mouse and menu. I'm not sure why it's not triggering. Something must be causing some sort of conflict.

 

 

Did you actually try to reassign 'View camera 4 (Select)' to F12 again, using the ingame Control options...?

 

Pressing 'S' and then 'Shift-A' should also give you the topdown view. Press 'Shift-S' to get back to the VC again. From then on S and Shift-S will toggle topdown and V (during the current FSX session).

 

Do you use something like EZDOK or another utility that also uses the F12 key?

Share this post


Link to post
Share on other sites

Yes I am also using EZDok, but I have went into the cfg to make sure that there's nothing conflicting. After I have hit A and Shift-A to change views, it has messedup my external aircraft views in EZCA now. Sigh. 

 

This is really frustrating. Does anyone know what that little C button with the yellow square around it next to the 1st and 2nd column mean? 

Share this post


Link to post
Share on other sites

Okay I finally got it working. Turned out that there was a conflict inside the cameras.cfg file. There were 2 cameras using the same hotkey. Thanks everyone.

Share this post


Link to post
Share on other sites