Archived

This topic is now archived and is closed to further replies.

kamaz74

Surprising FPS hog

Recommended Posts

Here is a quote from Lefteris Kalamaras' blog:

 

 

 

If you run FSX in Windowed Mode and have the FSX window maximized, sometimes the Windows Start button will overlap your FSX window. If your machine is powerful enough, you'll tend to be annoyed by the seemingly low FPS, but performance will be enough for you to simply be puzzled.

Resize the FSX window to allow the Start button NOT to overlap [or you can switch from Aero theme to Classic theme in your personalize menu] (or simply hide the taskbar) and you'll find that performance will increase - sometimes even double.

Same holds true for ANY external window that overlaps the FSX display - don't let any of those small popups come in view, as your FPS will drop to almost half (the technical reasons are outside the scope of my note here).

 

This shocked me when I tried it. Never knew it was hurting me so much. 

 

Hope this helps one of you.  ^_^ 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


don't let any of those small popups come in view

 

What "pop-ups"...?  Examples?  Thanx.

Share this post


Link to post
Share on other sites

I've noticed things like this:

 

screen_windows7taskbar.png

 

Or this:

 

win7_01.gif

 

Can temporarily slow you down. The problem with the start button is that its always there. So you might never know that it has been hurting you this whole time. 

Share this post


Link to post
Share on other sites

yes I notices this years ago....with FSX it is wise to shut everything else down and just fly.

Share this post


Link to post
Share on other sites

If you have two monitors, just move the windows taskbar to the other monitor and keep only FSX window on the main one.

Share this post


Link to post
Share on other sites

I have a AutoHotKey script that hides the taskbar with a simple key press, if anyone is interested in getting it you can get it from the link below. Pressing Win + A on your keyboard toggles the taskbar. Simply place the ahtoggle.exe somewhere and then create a shortcut to the file and place the shortcut in your Startup folder to get it to load at windows boot time.

 

https://dl.dropboxusercontent.com/u/21030205/ahtoggle.exe

 

Only works on Vista and Windows 7 as far as I know.

Share this post


Link to post
Share on other sites

Presumably auto hiding the task bar would eliminate this possibility?

 

No.

You will need to shut it down entirely and check it time to time.

Things may pop-up which sucks resources.

 

Little tweaks also help. Example.

Window effects in your display settings.

Share this post


Link to post
Share on other sites

Presumably auto hiding the task bar would eliminate this possibility?

Pardon, possibility of what.

 

Hiding the taskbar stops the frame rate drop caused by the bit of the start button that overlaps onto the FS window, it is that which is causing the frame rate drop, hiding it stops it. Pop over dialogues do not reduce my frame rate, but the taskbar start button overlap does.

 

This picture below shows you what I mean, its actually a picture I made in Vista years ago but the same is true with windows 7 as well, its the top bit of the button which overlays the FS window just a tiny bit that causes the frame rate drop.

 

this.jpg

Share this post


Link to post
Share on other sites

A blind Sheperd leading sheeps :rolleyes:

 

Hiding does the trick yes but only minimum to nothing.

Tell me, Whats better.  Hiding or stopping.

 

If your not using your Printer while simming, Why have the SPOOL.exe running.

 

If your Hiding it. Its still running sir.

Share this post


Link to post
Share on other sites

Hope you aren't calling me blind sir. It's you who has no clue what you are doing, hiding the task bar is all that is needed, and this has been the general consensus on the FS Developer forums for years.

Share this post


Link to post
Share on other sites

A blind Sheperd leading sheeps :rolleyes:

 

Hiding does the trick yes but only minimum to nothing.

Tell me, Whats better.  Hiding or stopping.

 

If your not using your Printer while simming, Why have the SPOOL.exe running.

 

If your Hiding it. Its still running sir.

 

wut?  :wacko:

Share this post


Link to post
Share on other sites

Listen. There are proccesses that are running and not needed while simming.

If you shut them down thats saves memory bc it is not running.

 

Example. Your printer is related to the SPOOL.exe in which it automatically running.

 

If your not using your printer while flying. Why have it running in your task manager.There are many things that are running and not needed. Its the same example what AlacrityPC would do

.

Windows effects. Check to see if you have effects enable. Mouse move effects also. If enable it might be effecting to FPS drop.

Share this post


Link to post
Share on other sites

Pardon, possibility of what.

 

Hiding the taskbar stops the frame rate drop caused by the bit of the start button that overlaps onto the FS window, it is that which is causing the frame rate drop, hiding it stops it. Pop over dialogues do not reduce my frame rate, but the taskbar start button overlap does.

 

This picture below shows you what I mean, its actually a picture I made in Vista years ago but the same is true with windows 7 as well, its the top bit of the button which overlays the FS window just a tiny bit that causes the frame rate drop.

 

this.jpg

 

Sorry, wasn't very clear! What  I meant was presumably auto hiding the taskbar eliminates the "FPS hogging" that this causes, as the windows do not overlap.

 

I run FSX in windowed mode with the taskbar auto-hidden, so presumably there is no gain to be had for me by doing anything else!

Share this post


Link to post
Share on other sites