Archived

This topic is now archived and is closed to further replies.

jay907uk

Rudder problems Logitech 3d extreme pro

Recommended Posts

Hi,

 

I'm hoping someone may beable to help me resolve this issue? 

 

I'm using the above joystick and notice the rudder will go either hard left or right also the joystick will swing also from left to right.

 

I've tried numerous calibrations which again hasn't worked using the calibrate thorugh FSX , I've deleted my FSUIPC.ini file and the problem still persists.

 

When going into the axis control the rudder shows up as (Z Rotation) yet the elevators and Ailerons are X & Y Axis.

I've had the Autorudder Ticked and unticked again still no joy.

 

Having goggled this problem it seems it's a known problem and from trying calibration tips still same rudder problem.

 

This tends to happen with all aircraft I use with FSX.

 

I'm sure there is others who use this joystick but have no problems.

 

I've got a registered version of FSUIPC but haven't set any keys through that due to me not being to sure of what to do ? If that may rectify the problem I'm not sure. 

 

I don't have the throttle problem only the rudder problem. I'm using W7 64bit

 

I hope I've enclosed enough information for somebody to help. There is two pics below so help they will help to show my problem

 

Thanks

 

Jason

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Man is the joystick..I had the same issue..I dismantled the joystick to check inside and is the rudder location. What you can do is to make the deadzone a bit bigger than normal to avoid this spikes...

Share this post


Link to post
Share on other sites

I still experience this problem from time to time (I also have the same joystick - I've used it for about 2-3 years now).

 

The only thing I found which helps alleviate the problem most of the time, is to:

 

1.  shut FSX down

2.  unplug the joystick from the USB connector

3.  restart the PC

4.  connect the joystick, give the joystick about 60 seconds to talk to the PC and re-calibrate

5.  then start up FSX again and see how you go.

 

I have also tried what Roberto mentioned above, but found this didn't solve the issue. That said, still try what Roberto suggests and see how it goes.

 

It's some kind of glitch with the Extreme 3D Pro for sure.

 

Rgds,

Share this post


Link to post
Share on other sites

Hi Roberto & Steve,

 

Thanks for your replies.

 

I've messed around with couple of settings and from setting the Null Zone setting to full which seems to have solved the Rudder problem from going left to right and sticking to one particular side and seems to make taxing somewhat easier. I'm not sure if it's just temporary but will keep me eye on it.

 

It may not be the best but I've done two flights with T7 & Aerosoft Airbus which both went ok.

 

Thanks

 

Jason

Share this post


Link to post
Share on other sites

I've used the Extreme 3D Pro for a number of years now but it does seem to have this annoying habit of misbehaving every so often. Just about the only other game I play is Grand Prix Legends (even older than FSX!) and it does exactly the same in that as well.

 

Someone suggested to me that I get a registered, rather than a free, version of FSUIPC and set it up from there but as I have no other use for a registered version I'm not sure why I should be paying £20 or so for something that should work anyhow. What I do find will work 90% of the time, however, is something akin to what Steve suggests; therefore I now leave the joystick permanently unplugged and only stick it into the PC when I'm actually going to use it.

Share this post


Link to post
Share on other sites

 

I had the same problem. Its not just the dead zone that will fix it but also settig the delta vakue higher.

 

The delta value is what tells fsx what os thr minimim value accepted as an input.

 

The problem sometimes is that of you move the joystick on one axis the fsx will pick up small movement on another axis. Because the delta is set to one on all axis.

 

Changing the delta value to 200 will make the required movement to actually show on the SIM higher so eliminates control spikes.

 

Last part is setting the range of movement in the calibration window.

 

 

Sent from my SPH-L710 using Tapatalk 2

 

 

Share this post


Link to post
Share on other sites

I had the same problem. Its not just the dead zone that will fix it but also settig the delta vakue higher.

 

The delta value is what tells fsx what os thr minimim value accepted as an input.

 

The problem sometimes is that of you move the joystick on one axis the fsx will pick up small movement on another axis. Because the delta is set to one on all axis.

 

Changing the delta value to 200 will make the required movement to actually show on the SIM higher so eliminates control spikes.

 

Last part is setting the range of movement in the calibration window.

 

 

Sent from my SPH-L710 using Tapatalk 2

 

Hi MisterA,

 

is there any chance you could provide a quick insight into this? I am unfamiliar with "Delta" values for joysticks. I would really like to give it a try to see if it does alleviate this problem.

 

Much appreciated.

 

 

Steve

Share this post


Link to post
Share on other sites

I can help you. Let me see if csn upload a video to YouTube

 

Sent from my SPH-L710 using Tapatalk 2

 

Much appreciated!

 

Rgds,

Share this post


Link to post
Share on other sites