Archived

This topic is now archived and is closed to further replies.

dental12

Lee's (dental12) questions regarding LINDA

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Can controls from different modules be used on different aircraft?

I.e , for example can a control from the ngx plane be used on

The twin otter?. Are they interchangeable?

Share this post


Link to post
Share on other sites

Yes that is what the FSX default profile is for in Linda. Make any assignments you want to work with all aircraft in the FSX default profile, then add specific assignments for special aircraft too their own individual profile.

Share this post


Link to post
Share on other sites

So am I correct in assuming that since there are no specific

Module for my flight1 king air 200 , I can use controls from other

Modules like the twin otter or others.?

Thx for patience

Lee

Share this post


Link to post
Share on other sites

I've no idea about the F1 King Air as I do not own it, so I cannot really advise what should work and what wont. A module being included in Linda just means that someone has gone to the trouble of adding support for an aircraft that wouldn't work with the default FSX controls in Linda. It doesn't automatically mean that if your aircraft has no module that it should just work with LINDA, it's not that easy, sometimes its a case try it and see. Other times you need to read the manuals and do more research of your own at the forums for the aircraft in question, there is also tonne of information in this forum area too.

Share this post


Link to post
Share on other sites

 

 


Can controls from different modules be used on different aircraft?

 

As I understand the question: no!

As Andy said you could/should assign standard FSX assignments to FSX standard planes as a basic setup.

Addons do then require a special module as standard FSX assignements do not work.

 

And a NGX battery could not be used with a aerosoft twin otter ...

 

if that was the question?

Share this post


Link to post
Share on other sites

Thx

That helps.

I just bought the vr insight button and switch panel as well as several additional

Switch panels from desktop aviator and will be giving it

A go.

Thank you guys for your quick response as those of us

Who are in the learning curve really appreciate your help!

Lee

Share this post


Link to post
Share on other sites

Hi

I downloaded and extracted linda and the patch to

The modules folder. Linda found my devices but says

It cant find fsuipc. I do have the latest version of fsuipc.

Where did I go wrong. Also the patch does show up in

The module folder but when I start linda , I dont see evidence

Of patch.

Thx lee

Share this post


Link to post
Share on other sites

Hi

I just posted an issue of linda not see fsuipc files.

I dont mean to be impatient but I cant move on until

I get this resolved. Lindas folder is in the module folder like

Manual says and no luck. Pkwase help

Lee

Share this post


Link to post
Share on other sites

Hi

I too am getting the message of not finding fsuipc files. I installed linda into the module folder. I do not use the mcp combo. Any advice would be appreciated

Thx lee

Share this post


Link to post
Share on other sites

Hello out there

My earlier post has not been answered. I am trying to set up linda to use

The vr insight button and swittch panel and my equipment

Is recognised but it says linda can find fsuipc files. What does this mean

And what to I do. Does it matter? Please advise

Tgx Lee

Share this post


Link to post
Share on other sites

Lee,

 

please DO NOT open several threads regarding your problems or highjack other threads!

This is a freeware forum which means you can't demand a 24/7 instant support. There are several people here which try to help as good and as fast as we can. But a little bit of patience is needed from your side.

 

For your problem:

please make a screenshot of your modules folder, then I could probably see if everything is installed correctly.

And please list your FSUIPC4.ini here( ... at least the first half, from beginning till where Com ports etc are opened.)

Share this post


Link to post
Share on other sites

Hi Guenseli

First Of all, I want to apologize for being so pushy and inappropriate in the forum.I just got carried away with things.It won't happen again.

I attached a screen shot of my modules folder and ini files and appreciate your time and guidance.

                                    Lee

Share this post


Link to post
Share on other sites

Ah ok,

 

installation error it seems.

you should not zip the complete folder into modules folder. you should zip the content of the downloaded folder "LINDA-v1.11" into modules folder.

 

In the end it should look like:

 

7N2Pd.jpg

 

and linda.exe should be directly in the modules folder.

Share this post


Link to post
Share on other sites

Thank you!

Now it says everything is ok with fsuipc. I will now jump in and try linda out

Lee

Share this post


Link to post
Share on other sites

hi

I have tried to program a button and a switch and saved them and they turned green,but when I go into a default plane like the c172, the button and switch does nothing. Ive read through both manuals and don't see what I am missing. thx lee

Share this post


Link to post
Share on other sites

1. Show the assignments you did (screenshot please)

2. Do you leave LINDA GUI running while switching to FSX? 

Share this post


Link to post
Share on other sites

I set linda to start when fsx starts. Imade assignments both fsx was running

And without fsx.

I will get you a screen shot when I get back later or by morning.

Its as if fsx isnt seeing the assignments I made. Linda does acknowledge saving of assignments but no luck in cockpit

Thx for you quick response Lee

Share this post


Link to post
Share on other sites

3. Also copy&paste here your FSUIPC log after flight with default C172 is loaded in FSX.

Share this post


Link to post
Share on other sites

Hi Ihope this helps. I feel that Im so close but missing something.Also I know you guys volunteer so is there a way that I can pay or donate for your time helping. and do you ever dial in to someones computer to see for yourself what the problems are. I am never looking for something for nothing.I am willing to pay in advance for your expertise

                                     thx Lee

Share this post


Link to post
Share on other sites

If this is your full fsuipc4.log file contents at the moment of flight already loaded, then LINDA just didn't start inside FSX.

 

Check the file named ipcready.lua in your */FSX/modules/* folder.

This file is included with LINDA distribution zip, 

 

If it is there, check it's content, It should look like this:

ipc.runlua('linda')

If file is not there or is empty, you can create it by hands or unzip it from LINDA archive. 

 

When LINDA starts in FSX, the log should look like this:

...
...


--- NEW LOGGING SESSION -----------


VRI MCP2B ("MCP2 Boeing") detected on port com3
System time = 06/10/2013 17:56:23, Simulator time = 17:49:11 (01:49Z)
Aircraft="C172R F-GOAP"
Starting everything now ...
LUA.0: beginning "F:\P3D\Modules\ipcReady.lua"
LUA.0: ended "F:\P3D\Modules\ipcReady.lua"
LUA.0: trim start
LUA.1:
LUA.1: [INIT] Loading...
LUA.1:  Aircraft: C172R F-GOAP
LUA.1:  Aircraft module detected: A2A Cessna 172R
LUA.2:  AivlaSoft library loaded...
LUA.2:  FSX standard library loaded...
LUA.2:  IVAO library loaded...
LUA.2:  RealityXP library loaded...
LUA.2:  Weather library loaded...
LUA.2:  A2A MAP library loaded...
Advanced Weather Interface Enabled
LUA.2:  RADIOS : Empty command for :: COM1 Select
LUA.2:  Loading a fallback joysticks config...
LUA.2:  Loading A2A Cessna 172R joysticks config...
LUA.2:  Module: A2A Cessna 172R Started...
LUA.2:  Ready to go, Captain!
LUA.2:

Share this post


Link to post
Share on other sites

You should look for inside-FSX-LINDA-logs in fsuipc4.log, not the linda2.log.

Share this post


Link to post
Share on other sites

Oh... in your directory listing there is no linda.lua file which is the core of LINDA.

Share this post


Link to post
Share on other sites

So the ipcreadylua is in the wrong place? By directory listing, do you mean my modules folder?.

Do I need to start all over by erasing all of linda and redownloading it?. Also if so I need to know where I went wrong with first install.

Thx for your patience!!

Share this post


Link to post
Share on other sites