Archived

This topic is now archived and is closed to further replies.

PapaRomeo

New nVidia driver Vsync broken

Recommended Posts

After installing the newest nVidia driver, i can't get vsync working again.

 

Using DX10 Fixer

 

Using vsync and 30 fps limiter in nvidia control panel.

 

Anyone else got this?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

.....Anyone else got this?

 

If you're talking about nVidia 331.58 I can only tell that it works fine but I set FPS in nVidia profile to zero and set FPS=31 in fsx.cfg. My FSX run in DX10 mode but not with the DX10 Fixer. I have Steve's DX10 patch 3.2.2

 

I use nVidia Inspector to maintain the profiles, never the nVidia Control Panel.

 

Spirit

Share this post


Link to post

Perhaps there will be an update for the DX10 fixer.
Also using inspector.

I like FPS unlimited in FSX and use external limiter.

Share this post


Link to post

Installed latest beta, everything is fine again, how could they miss this?

Share this post


Link to post

 

 

I use nVidia Inspector to maintain the profiles, never the nVidia Control Panel.

 

Spirit

I have both but the tools icon in "Inspector" is greyed out. I presume because of the nvidia control panel.

Share this post


Link to post

I have both but the tools icon in "Inspector" is greyed out. I presume because of the nvidia control panel.

I don't know what you mean with a "tools icon". You've to start nVidia Inspector (Version 1.9.7.2), click "Driver Profile settings" and then chose the profile from the profiles drop down menu. The profile for FSX is called "MS Flight Simulator X". Here you can see and change all the settings for FSX.

Spirit

Share this post


Link to post

I don't know what you mean with a "tools icon". You've to start nVidia Inspector (Version 1.9.7.2), click "Driver Profile settings" and then chose the profile from the profiles drop down menu. The profile for FSX is called "MS Flight Simulator X". Here you can see and change all the settings for FSX.

Spirit

I have ver 1.9.7.2

 

To the right of "Driver Version" there is an icon with crossed tools. This is greyed out so is unusable. My thinking is that this is because it has detected the existence of Nvidia Control Panel. I can't find an "nvidia control panel" anywhere on my system in order to turn it off. Is it generated by the divers?

Share this post


Link to post

 

 


I can't find an "nvidia control panel" anywhere on my system in order to turn it off. Is it generated by the divers?

Go to Windows Control Panel, you will find it there.

Share this post


Link to post

I have ver 1.9.7.2

 

To the right of "Driver Version" there is an icon with crossed tools. This is greyed out so is unusable. My thinking is that this is because it has detected the existence of Nvidia Control Panel. I can't find an "nvidia control panel" anywhere on my system in order to turn it off. Is it generated by the divers?

I guess every nVidia user has the "Nvidia Control Panel" which can be found in "Windows Control Panel" as "Badfinger" already said. I doubt that the "nVidia Control Panel" is the reason for your problem. Do you run the "nVidia Inspector" as an administrator? Maybe a new installation of this tool would help to solve your problem.

Have a look here http://wiki.step-project.com/Guide:NVIDIA_Inspector you may find some hints.

Spirit

Share this post


Link to post

In the nvidia forum someone mentioned that vsync is broken if you use limited fps.

And that is exactly what I do!

But why do beta drivers work?

What else can be used for limiting fps external?

Share this post


Link to post

I have ver 1.9.7.2

 

To the right of "Driver Version" there is an icon with crossed tools. This is greyed out so is unusable. My thinking is that this is because it has detected the existence of Nvidia Control Panel. I can't find an "nvidia control panel" anywhere on my system in order to turn it off. Is it generated by the divers?

Usually when a field is greyed out, it just means the current setting in the profile matches the global setting. You can still set it in the profile, and apply the change.

Share this post


Link to post

Usually when a field is greyed out, it just means the current setting in the profile matches the global setting. You can still set it in the profile, and apply the change.

I can only change "global" settings within nvidia control panel and that has no effect on inspector.

Share this post


Link to post

In the nvidia forum someone mentioned that vsync is broken if you use limited fps.

And that is exactly what I do!

But why do beta drivers work?

What else can be used for limiting fps external?

 

So use the driver 331.48 and be happy. Maybe nVidia will fix this with the next update.

 

There are many external FPS limiter available. Google will be your friend.

FRAPS, EVGA Precision X and Dxtory are among them.

Spirit

Share this post


Link to post

Well, I already have Fraps.

Maybe I should try it.

Fraps just records what you have on your screen + what you hear at a specific fps that you set. Using Fraps should not change the fps within the sim.

Share this post


Link to post

OK, here we go.

Got latest driver installed and Dxtory.

Sometimes i can launch with vsync on, and sometimes it doesn't work!

Same scenario, same settings, same everything, sometimes it work, sometimes it doesn't.

After extensive Vsync tests, i just can't get a clear view of what is going on.

I unplugged all saitek, just launching FSX, and it goes on/off.

 

I had enough for now, why can't FSX not just work with stable vsync???


Can't stand the screen tearing!
If at least i launched different scenarios, so i could pin it down.

But there is simply NO logic!!! :angry:


1 out of 7 flight have vsync working...

Share this post


Link to post

I've no problem but I set FPS in FSX and NOT in the nVidia profile.

Spirit

Share this post


Link to post

But unlimited FPS in FSX, generates more power!

 

Wrong, believe me. Did you try both to compare in a serious way?

Spirit

Share this post


Link to post

Unlimited FPS FSX, 30 fps lock external in busy airport, 25-28 fps.

Loaded same scenario with FSX 30 fps limit, 18-25 fps.

I don't know why it does that, but believe me, you want FSX set to unlimited fps.

Share this post


Link to post

Depends on the machine. Some react better with FSX set to unlimited, some set to 30fps.

Share this post


Link to post

Depends on the machine. Some react better with FSX set to unlimited, some set to 30fps.

i've found the best setting is in between 30fps and the max that the video card does. My card maxes at 62fps with all sliders full. Unlimited I get micro stutters. With 30 fps I get fewer but more apparent stutters. In between at 46 fps I get the best of both worlds. I can get 60+fps with no stutters but the scenery is blurred and the horizon too sharp. As always it a compromise.

Share this post


Link to post

Unlimited FPS FSX, 30 fps lock external in busy airport, 25-28 fps.

Loaded same scenario with FSX 30 fps limit, 18-25 fps.

I don't know why it does that, but believe me, you want FSX set to unlimited fps.

 

You've a powerful GPU with a less powerful CPU so you should try to put as much load as possible to the GPU.

You should have a look at your fsx.cfg what tweak you missed or set not very well.

What's about UsePools=0 did you try this?

Spirit

Share this post


Link to post