Jump to content

Archived

This topic is now archived and is closed to further replies.

joergalv

I wanted vsync, so i dealt with the evil...

Recommended Posts

Aero is off! And it won't be enabled again .. 

 

Like most of us Nvidia users, i enabled Aero just after one or two attempts to get vsync working in this new sim.

It was one of my first 'corrective' actions ..and well ..Aero On, and vsync worked.. .. good to go..

So, i had Aero enabled and tried to find the sweetspot between EQ / smoothness / fps , et all... for one week.

I had good times, i had bad times (sounds familiar?), More trial & error then logical approaches..

 

Yetsterday i decided to stop tweaking, but wait for LM to deliver an update instead.

I just wasn't able to get it right. Stutters, sometimes, more, sometimes less, Really bad! Not to talk about the inability to make smooth turns with my head using Track IR.. Again: stuttering mess! And all that with 'only' moderate settings...

 

So I started FSX again .. and I was really blown away how smooth everything was. What a difference!

Exactly in that moment i started wondering, and asking myself a couple of questions.

I just couldn't get it. What should keep p3dv2 from delivering smoothness at least on FSX level.

And why should Aero be good for p3d when it's bad for FSX? Has LM or MS improved Aero recently? Certainly not.

 

Bang! I've never tweaked p3dv2 with Aero disabled.. i should give it a try.. And i did..

and i think you should give it at try too...

 

My result for 3840x1024 (!)

 

Vsync: Nope, sorry, still not working, so tearing, yes, but...

Tearing; down to an absolutely acceptable limit 

(Depends highly on your HW & settings You might have to play with P3dv2 INTERNAL EQ settings to bring it down to an acceptable limit)

fps: rock solid 30fps, even in complex scenery & heavy weather (tested in FSDT CYVR),

Stutters: Gone..

Smoothness: Outstanding, throughout whole flights!

AA: Acceptable (room for improvement off course)

 

Aero: Off

 

Clean prepar3d.cfg (TBM tweak is NOT required)

 

External FPS Limiter required! (NI works, DXtory gives slightly better results, i.e. less tearing)

 

P3Dv2 Settings

 

Graphics

  • FXAA: Off
  • MSAA: 8x
  • SSAA: 8x  (in Prepar3d.cfg, don't know whether it makes avisual difference)
  • AF: 16x
  • Vsync & TB: Off     (Yes!! Turn it OFF!! It won't wotrk, but spoil performance if you turn it on))
  • Target Frame rate: unlimited
  • Texture Res: High - 2048x2048
  • Tesselation Enabled

Other

  • Scenery sliders are all somewhere in the 'middle'
  • Shadows:
  • Q: Medium,
  • I+E Vehicle: C+R
  • Terrain: C+R
  • Buildings: Cast

 

Nvidia Inspector:

  • All reset to defaults, NO AA Enhancement etc..  (i don't see an enhancement with SGSSAA, but only very high fps impact)
  • Optional: Frame Rate Limiter: 30fps

For any limiter: Make sure you lock for any of the Adaptive Vsync Frequencies 60,30,20,... to get max smoothness)

 

Vsync will be available without Aero some day.. until then i'll run with the above config..

 

If you test it, please report back..

 


Joerg Alvermann
Win7 Pro 64Bit - GTX980Ti 6GB - 5760x1200

Share this post


Link to post

Sorry, but I see zero difference in fsx or p3d with aero on or off


Glenn

Ryzen 3700X, X570 Pro Wifi, 32GB 3600mhz RAM, Nvidia Titan Xp "Galactic Empire", RM750x PSU, H700 case, 2x NVMe M2 SSD, 1x SATA SSD

Share this post


Link to post

Aero works fine with DX11 - so so with DX9. It mainly is for VSync and transparency. I don't know why but I never had any tearing when I started P3D2 and I use TrackIR. I did enable aero but I also can't see any difference. However, until I see a problem, I am leaving it on.

 

Vic


 

P3D#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 2080ti 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
P3D#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors
 

Share this post


Link to post

I thought the Vsync and Aero thing had something to do with the "No True" fullscreen anymore in V2.


Rendi

 

KAB200_sig4.jpg

 

Rendi

Share this post


Link to post

Yes, you need aero for vsync in v2 but other than that I see no performance difference


Glenn

Ryzen 3700X, X570 Pro Wifi, 32GB 3600mhz RAM, Nvidia Titan Xp "Galactic Empire", RM750x PSU, H700 case, 2x NVMe M2 SSD, 1x SATA SSD

Share this post


Link to post

Yes, you need aero for vsync in v2 but other than that I see no performance difference

No tearing?


Rendi

 

KAB200_sig4.jpg

 

Rendi

Share this post


Link to post

Aero is off! And it won't be enabled again .. 

 

Like most of us Nvidia users, i enabled Aero just after one or two attempts to get vsync working in this new sim.

It was one of my first 'corrective' actions ..and well ..Aero On, and vsync worked.. .. good to go..

So, i had Aero enabled and tried to find the sweetspot between EQ / smoothness / fps , et all... for one week.

I had good times, i had bad times (sounds familiar?), More trial & error then logical approaches..

 

Yetsterday i decided to stop tweaking, but wait for LM to deliver an update instead.

I just wasn't able to get it right. Stutters, sometimes, more, sometimes less, Really bad! Not to talk about the inability to make smooth turns with my head using Track IR.. Again: stuttering mess! And all that with 'only' moderate settings...

 

So I started FSX again .. and I was really blown away how smooth everything was. What a difference!

Exactly in that moment i started wondering, and asking myself a couple of questions.

I just couldn't get it. What should keep p3dv2 from delivering smoothness at least on FSX level.

And why should Aero be good for p3d when it's bad for FSX? Has LM or MS improved Aero recently? Certainly not.

 

Bang! I've never tweaked p3dv2 with Aero disabled.. i should give it a try.. And i did..

and i think you should give it at try too...

 

My result for 3840x1024 (!)

 

Vsync: Nope, sorry, still not working, so tearing, yes, but...

Tearing; down to an absolutely acceptable limit 

(Depends highly on your HW & settings You might have to play with P3dv2 INTERNAL EQ settings to bring it down to an acceptable limit)

fps: rock solid 30fps, even in complex scenery & heavy weather (tested in FSDT CYVR),

Stutters: Gone..

Smoothness: Outstanding, throughout whole flights!

AA: Acceptable (room for improvement off course)

 

Aero: Off

 

Clean prepar3d.cfg (TBM tweak is NOT required)

 

External FPS Limiter required! (NI works, DXtory gives slightly better results, i.e. less tearing)

 

P3Dv2 Settings

 

Graphics

  • FXAA: Off
  • MSAA: 8x
  • SSAA: 8x  (in Prepar3d.cfg, don't know whether it makes avisual difference)
  • AF: 16x
  • Vsync & TB: Off     (Yes!! Turn it OFF!! It won't wotrk, but spoil performance if you turn it on))
  • Target Frame rate: unlimited
  • Texture Res: High - 2048x2048
  • Tesselation Enabled

Other

  • Scenery sliders are all somewhere in the 'middle'
  • Shadows:
  • Q: Medium,
  • I+E Vehicle: C+R
  • Terrain: C+R
  • Buildings: Cast

 

Nvidia Inspector:

  • All reset to defaults, NO AA Enhancement etc..  (i don't see an enhancement with SGSSAA, but only very high fps impact)
  • Optional: Frame Rate Limiter: 30fps

For any limiter: Make sure you lock for any of the Adaptive Vsync Frequencies 60,30,20,... to get max smoothness)

 

Vsync will be available without Aero some day.. until then i'll run with the above config..

 

If you test it, please report back..

 

Those settings take all the fun outta P3D...mine as well stick with FSX for those mediocre settings.


Asus Maximus X Hero Z370/ Windows 10
MSI Gaming X 1080Ti (2100 mhz OC Watercooled)
8700k (4.7ghz OC Watercooled)
16gb DDR4 3000 Ram
500GB SAMSUNG 860 EVO SERIES SSD M.2

Share this post


Link to post

enabling Aero and using Vsync in V2 has FINALLY shed me of the nagging tearing I had with FSX

Share this post


Link to post

To the OP

 

I have experienced bad stuttering from the start wit V2 (Aero Enabled). It is so bad it virtually makes P3DV2 unusable. I have a 3930k @ 4.7GHz with a GTX680 on Win 7. I run sliders around mid but have experimented with them to the left. Nothing alleviates the bad stuttering.

 

My system has been optimised for FSX DX10 and runs this extremely well. So I have been dissappointed with the P3DV2 performance. What is frustrating is that so many people are reporting smooth, even buttery smooth performance and I can not even come close to this.

 

So with interest I read the OP comments. Why not give it a go. Turning of Aero has removed my stutters. If fact the sim runs very smooth. Add a complex aircraft and even at 20fps the sim has a reasonably smooth feel. However the tearing due to lack of vsync is also not possible to live with.

 

I have thrown countless hours at this sim to try and find a solution to my stutters and the one thing that stops them introduces another no go.

 

This sim has so much going for it for the people who are fortunate enough to achieve their performance goals. Just wish I could. Hopefully down the track a solution arises to allow me stutter free operation with vsync working.

 

I wonder if going to Win 8.1 would make any difference?

 

Michael M

Share this post


Link to post

Thanks to All. Great Feedback..

 

So it might be a GTX 680 specific vsync issue :(

 

Just googled 'vsync stutters' .. and the GTX 680 is named in almost every result on the list.

A thread about vsync stutters in the nvidia forum is 139 pages (!) long..

 

so... waiting for a driver fix...

  

and 'sorry' to Aero. :rolleyes:


Joerg Alvermann
Win7 Pro 64Bit - GTX980Ti 6GB - 5760x1200

Share this post


Link to post

Did u use the 1/2 refresh rate in FSX with inspector?


Matt Wilson

Share this post


Link to post

Did u use the 1/2 refresh rate in FSX with inspector?

 

Yes. Vsync control to Standard + 1/2 refresh rate in Nvidia Inspector.


Joerg Alvermann
Win7 Pro 64Bit - GTX980Ti 6GB - 5760x1200

Share this post


Link to post

Did u use the 1/2 refresh rate in FSX with inspector?

I did use NI 1/2 refresh rate with FSX. It was the only way I could achieve a smooth experience with it.

 

Wish it was an option for P3DV2.

 

 

Sent from my iPad using Tapatalk HD

Share this post


Link to post
×
×
  • Create New...