Sign in to follow this  
soundrats

FTX GLOBAL MS NET FRAMEWORK 4.0 or 4.5

Recommended Posts

Hi out there,

The readme of the FTX GLOBAL installation says it needs MS NET FRAMEWORK 4.0 to work. After a new WIN7 64bit installation NET FRAMEWORK is updated to version 4.5. Now I want to know if I can install FTX GLOBAL with MS NET FRAMEWORK 4.5 instead of 4.0?

Kind Regards Tom

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi out there,

The readme of the FTX GLOBAL installation says it needs MS NET FRAMEWORK 4.0 to work. After a new WIN7 64bit installation NET FRAMEWORK is updated to version 4.5. Now I want to know if I can install FTX GLOBAL with MS NET FRAMEWORK 4.5 instead of 4.0?

Kind Regards Tom

 

To run FSX/Acceleration, let alone FTX Global, you need versions 1.1 through the latest.  Here's a clip from the AVSIM CTD Guide:

 

Make sure required Microsoft.net Framework Packages are installed and up-to-date - The appropriate Microsoft.net Framework packages are normally installed when you first install FSX/Acceleration/P3D and commercial add-on programs if the appropriate package is not found.  You will need versions 1.1 through the latest. You can see what versions are installed by going to your Windows Explorer and look for Windows/Microsoft.net/Framework/(then the versions installed). Once the packages are installed, Windows Update will periodically update the packages.  You can verify whether your versions are properly installed and up-to-date by using the .Net Framework Setup Verification Tool User's Guide.  Microsoft.net packages are used by developers to make sure the program runs in the way they intended, including memory management. The packages are, for the most part, not backward compatible.

 

Best regards,

Share this post


Link to post

Thank you,

all what I read is that the NF 4.5 or meanwhile 4.5.1 contains each NF from NF 2.0 on. Anyway if I install an earlier version the win updater is prompting updates till I reach NF 4.5.1. This really should be ok then.

Kind Regards Tom

Share this post


Link to post

Jim,

 

The Windows 8 .net 4.5 contains .net 4.0 and is entirely backwards compatible. The major revision numbers (1.x, 2.x, 3.x, 4.x) are not and you need each of them installed, if you have apps that access them. Hence the MS directive. Here's an example:

 

http://superuser.com/questions/491000/what-versions-of-the-net-framework-are-included-in-windows-8

It is definitely not backward compatible.  For instance, remove version 2.0 or 3.5.  You'll be lucky to get FSX or certain addons to run.  Please run a Google search asking "Is Microsoft.net packages backward compatible".  For the most part they 'might' be but, for the most part, you need all versions for this very, very old computer program called FSX/Acceleration.

 

Best regards,

Share this post


Link to post

It is definitely not backward compatible.  For instance, remove version 2.0 or 3.5.  You'll be lucky to get FSX or certain addons to run.  Please run a Google search asking "Is Microsoft.net packages backward compatible".  For the most part they 'might' be but, for the most part, you need all versions for this very, very old computer program called FSX/Acceleration.

 

Best regards,

Jim,

 

Thank you for passing this along. I think I just figured out a major mystery with my FSX troubles with my Win 8 install.

 

Keith

Share this post


Link to post

It is definitely not backward compatible. For instance, remove version 2.0 or 3.5. You'll be lucky to get FSX or certain addons to run.

We are saying the same thing. Only the minor revisions are backwards compatible (4.0 & 4.5 for example). If your version of Windows has all the previous versions of .net, then you are very lucky.

Share this post


Link to post

 

 


If your version of Windows has all the previous versions of .net, then you are very lucky.

 

The appropriate version of dotnet is installed on your computer when you install FSX, starting with Version 1.1, Acceleration 2.0, Orbx/FTX 3.5, etc., etc.  The following is taken from the AVSIM CTD Guide:

 

Make sure required Microsoft.net Framework Packages are installed and up-to-date - The appropriate Microsoft.net Framework packages are normally installed when you first install FSX/Acceleration/P3D and commercial add-on programs if the appropriate package is not found.  You will need versions 1.1 through the latest. You can see what versions are installed by going to your Windows Explorer and look for Windows/Microsoft.net/Framework/(then the versions installed). Once the packages are installed, Windows Update will periodically update the packages.  You can verify whether your versions are properly installed and up-to-date by using the .Net Framework Setup Verification Tool User's Guide.  Microsoft.net packages are used by developers to make sure the program runs in the way they intended, including memory management. The packages are, for the most part, not backward compatible.

 

The dotnet setup verification tool is an important utility to make sure you have all versions and they are properly installed.

 

Best regards,

Share this post


Link to post

Jim, What procedure did you use to get Net Framework 1.1 to install into Windows 7-64? I have all versions installed except 1.1. I remember when I tried to install 1.1 I got error messages but I don't remember the details of the messages now. Browsing the net it appears that you need to jump through some hoops to get this installed in windows 7. My sim seems to run fine without it so I just left that one out. Do you know what programs need 1.1?

 

Thanks,

 

Ted. 

Share this post


Link to post

Jim, What procedure did you use to get Net Framework 1.1 to install into Windows 7-64? I have all versions installed except 1.1. I remember when I tried to install 1.1 I got error messages but I don't remember the details of the messages now. Browsing the net it appears that you need to jump through some hoops to get this installed in windows 7. My sim seems to run fine without it so I just left that one out. Do you know what programs need 1.1?

 

Thanks,

 

Ted. 

Hi Ted,

 

Sorry for not responding sooner.  When you install FSX, Acceleration, or any addon, the proper dotnet will be installed.  It is my understanding that FSX Deluxe used dotnet 1.1 and SP2/Acceleration used 2.0.  If it is not installed on your system and everything is working properly, then I would not worry about it.  I have it installed on my system.  Have you tried downloading and installing it on your system? http://www.microsoft.com/en-us/download/details.aspx?id=33

 

Happy New Year!

 

Best regards,

Share this post


Link to post

Jim,

When I tried to run the link above it said that the program it was trying to update was not installed. The link is to a service pack so that made sense. Then I did a search on the Microsoft website and found the distributable for both Net Framework 1.0 and 1.1. Both gave me the incompatibility message below when I tried to install  them. I did not want to try a forced install.

 

post-135255-0-20226600-1388713672.png

 

What are the symptoms if Net Framework 1.0 or 1.1 are not installed? My FSX seems to run fine without it. 

 

Thanks,

 

Ted

Share this post


Link to post

IIS is not needed by most users as it allows you to host a web server under Windows. Check your services to see if it is even running.

Share this post


Link to post

I checked this morning and I do not have IIS running or listed in windows services. According to the Net Framework 1.0 and 1.1 download pages Windows 7 is not supported. I did a google search and found the following procedure to get it installed.

 

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/how-to-install-net-framework-11-in-windows-7-64/eb1e6232-e874-432e-ab43-17660e25e43d

 

Did you folks that have .net 1.1 running in windows 7 go through this procedure? I'm a little hesitant being that FSX and acceleration installed and seem to run fine. With so much conflicting and buggy software in this hobby now, I'm very conservative about installing anything. 

 

Thanks,

Ted

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this