Sign in to follow this  
shawlee

Using Google Maps

Recommended Posts

Hi all

 

 I modified the libnettile.dll. so now it was compactable with the google maps.

 

 I'm not sure if it is against any laws? if so let me know or just delete the post.

 

 

 You can download the two fix files:   http:/pan.baidu.com/s/1mguPENe

 

 Useage:

 

 Replace the libnettile.dll in your TP directory(Bakeup if needed).

 

 Config the ProxyUser.ini .  See the download file "ProxyUser.ini"  ,  I add a new server named "Google Service" and make it the Active one.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I don't think it's against any law, but Google might move to shut you down pretty quick. In any case, the link didn't work for me. :)

Share this post


Link to post
Share on other sites

I'm not sure if it is against any laws? if so let me know or just delete the post.

 

May not be "against the law", but Christian Buchner's statement in the TileProxy 8.1 User Manual states:

"Note that compatibility with Google Inc.'s map servers had to be removed at the explicit

request of Mike Hearn who is with Google Earth and Maps engineering department.

This is unfortunate, but complying to this request was probably the wisest choice to make."

 

So, I'm staying away from Google Earth.  Service1 (VE) seems to work well in Europe and US/Canada.  Occasionaly I will go back to using Service3 (Yahoo)...  It's too bad they (VE & Yahoo) don't have bertter coverage in many other places on earth...  You can get good coverage of Norway here:

http://aviation.allanville.com/tileproxy/

Share this post


Link to post
Share on other sites

Thank you shawlee for your patch, much appreciated! Was that very difficult to recompile that dll module?

Share this post


Link to post
Share on other sites

The tileproxy service with modifying g ** gle stopped working today 16/05/2014 at me, does anyone know what happened? is there any update now?

 

My current line.

 

[service Google]
cache_folder=E:\\TileProxy Photoreal World\CACHE.GOOGLE
network_module=libnettile
module_config="conn=20|rate=2.0|verbose=0|server=http://khms*.google.com/|path=/kh/v=%v&src=app&x=%X&y=%Y&z=%Z&s=Galileo|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"
min_level=5
max_level=19
map_version=146
color_hack=No
color_level=0
bulk_extend=50

Share this post


Link to post
Share on other sites

Hey Everyone.

 

Can anyone confirm if this still works and with success? Can someone please throw up the modified Libnettile.dll if possible as the link is now inactive.

 

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this