Sign in to follow this  
AnkH

Problem getting the middle MFD to work

Recommended Posts

Hi all,

 

I really like the phenom (besides this FPS issue), but as I normally use cold and dark setups, I am really not capable of getting the middle MFD of the phenom to work properly. Only by clicking on the Carenado pre-defined setups "ready for taxi" helps. The problem is: it always shows the start screen, no matter what I do and how I power up the plane. Clicking on "ent" or the rightmost softkey as indicated on the screen only brings the map up for a quarter of a second, then it switches back instantly to the loading screen. Strange enough, as soon as the engines are running, it works as it should. How do you do it? Because of this problem, I am also not able to use the comms on ground until the engines are running...

 

Thank you for any help!

 

regards

Chris

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just bought the Phenom yesterday and was seeing the same thing, but it's a simple oversight - the "Avionics Master" switch setting in FSX needs to be "On" - I have this switch on my Saitek panel, so it was a quick push of the rocker for me - sorry, but I don't remember what the FSX key equivalent is (I didn't see a switch in cockpit of the Phenom explicitly for it).  Other than that, despite the grumbling about this little jet, I find I am actually enjoying it quite a bit - plus turning off the co-pilot's PFD, and moving the MFD to my second screen while keeping my mouse off the VC when not needed to click something has me getting really decent frame rates even on my fairly modest equipment... 

Share this post


Link to post
Share on other sites

So in the end it is that what I was thinking about. But where the heck is the avionics master switch in the Phenom? Sometimes a manual would not be a bad thing...

Share this post


Link to post
Share on other sites

Use the standard FSX key to Turn Avionics Master On -- I believe it's Shift-M, unless you have that keystroke combo mapped to something else.

 

I have a number of add-ons I have to do this for (mainly Nemeth helicopters), oddly enough, not the Phenom, though.

Share this post


Link to post
Share on other sites

I tried it with the key combo and yes, it works. But come on, this little plane must have an avionics master switch, no? But where is it?

Share this post


Link to post
Share on other sites

Where are the Manuals for it? It says the folder includes manuals for the phenom 300

Share this post


Link to post
Share on other sites

Manuals are in your:

 

...\Lockheed Martin\Prepar3D v2\Carenado\EMB500 folder

 

The real Phenom 100 does not have an avionics master switch (nor a beacon light switch) - both of these things turn on automatically with the battery and engine respectively - this is one of the things that Embraer has done to make the pilot workload easier.

Share this post


Link to post
Share on other sites

On the Feel There Phenom 100 for FSX, is it possible to align the MFD map to display NORTH UP, instead of HEADING UP…?   Hope someone can help!  Thanks.  

Share this post


Link to post
Share on other sites

On the Feel There Phenom 100 for FSX, is it possible to align the MFD map to display NORTH UP, instead of HEADING UP…?   Hope someone can help!  Thanks.  

You can do it also on Carenado Phenom 100. You press the MENU button and the on MAP category you will define your preffered selection. 

Share this post


Link to post
Share on other sites

There is a bug on the middle MDF I can't turn on (no buttons) On the left and right ther is a invisible button on corner but not on the middle. Also when start with engine ready, only left and right MDF are on (display) the center is OFF (dark)

 

I tried ON/OFF master switch and same.

I re-installed and same too.

 

Any solution?

 

I think this is the last time I m buying Carenado!

Share this post


Link to post
Share on other sites

Ok here is the solution I've found uninstall FSX SP2 then re-install it again, all worked like a charm. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this