Jump to content

Archived

This topic is now archived and is closed to further replies.

SolRayz

Better mdl exterior shadows, possible?

Recommended Posts

Maybe this is a question for Steve, but I'm experimenting with dx10 again, and having much better luck after a full FSX reinstall. Everything is great and performance is on par with what I should expect. My only concern is the airplane exterior shadows seem erradic and innacurate. As a trackIR user I find the shadows jump around a lot when panning in spot view.

 

Are there any settings in the fixer to eliminate, or reduce these jerky shadows. It seemed less of an issue in dx9.

Share this post


Link to post
Share on other sites

Are these the shadows on the ground or the shadows the aircraft casts on itself? I sometimes see the latter flash off for a fraction of a second but that aside I haven't notice any faults. Is it one plane or all planes? If it occurs can you save the flight and does it reproduce? - if so if you uninstall the DX10SF libraries is it the same?

Share this post


Link to post
Share on other sites

The latter, shadows the aircraft casts on itself. I notice it on all planes including default planes. The issue is present in dx9 as well. But I think since the shadows are darker with the fixer, it is much more obnoxious. If you pan around the plane, you really see the shadows jump around. If you remain in a stationary position the shadows behave as one would expect.  

 

Is this simply a limitation of the shadow mapping process in FSX? I've been spoiled by the exterior shadowing in P3D which is accurate, smooth, and very realistic, but because of performance reasons I am back to FSX. There has to be a way of improving exterior shadows!

Share this post


Link to post
Share on other sites

Are these the shadows on the ground or the shadows the aircraft casts on itself? I sometimes see the latter flash off for a fraction of a second but that aside I haven't notice any faults. Is it one plane or all planes? If it occurs can you save the flight and does it reproduce? - if so if you uninstall the DX10SF libraries is it the same?

 

Maybe this will give you a better idea. You can see rampant shadowing issues. I find the further I move away the better and more stable the shadows become, and may even stop the issue entirely. Is everyone seeing this issue?

 

Here is my shader options in the fixer.

NclUL.jpg

Share this post


Link to post
Share on other sites

No I don't see that, try disabling toned shadows. Thee was a bug (fixed in latest versions) where you could get false shadowing from toned shadows on reflective surfaces.

Share this post


Link to post
Share on other sites

I will install the latest version and report back, Thanks for the help!

Share this post


Link to post
Share on other sites

No I don't see that, try disabling toned shadows. Thee was a bug (fixed in latest versions) where you could get false shadowing from toned shadows on reflective surfaces.

 

I installed v2.2 but the issue remains. Are you sure your not seeing the same artifacting? I suspect this problem is much more apparent when using ezdok to move around the aircraft. The closer to the aircraft I get, the issue seems to get much worse. The further out, the issue subside almost completely, execept for occasional jumpy shadow, which I could live with.  

Share this post


Link to post
Share on other sites

Well the video above demonstrates exactly the fault that was reported in 2.1 with toned shadows - are you sure that the update worked - did you uninstall the libraries before the update?

 

I suggest load the controller, check at the top it says 2.2 uninstall the libraries, install the libraries and retest.

Share this post


Link to post
Share on other sites

I use the free fixes as well as some of my own. I fixed the shadows with nVidia inspector. I'll post my settings later if you want.

Share this post


Link to post
Share on other sites

I use the free fixes as well as some of my own. I fixed the shadows with nVidia inspector. I'll post my settings later if you want.

 

Ok, so your saying that the shadow issue can be fixed with NI. If this is true please post asap. Thanks.

 

Steve, I uninstalled libraries, and uninstalled the app. And then reinstalled the latest build 2.2 and flushed the shader cache. I will check again tonight.

Share this post


Link to post
Share on other sites

ok thanks - its possible that I am mistaken and confusing two issues. I certainly don't see any artifacting like that.

Share this post


Link to post
Share on other sites

Ok, so I found a painstaking but working solution. It turns out that tweaking the .mdl file was all I needed for perfect exterior shadows. I used developer app called RADItor which allows you to adjust the shadow parameters within .mdl file. It turns out that adjusting the radius parameter to 15 (max) eliminates the issue completely for me. Unfortunately I had adjust each .mdl for each airplane...bleh. But on the bright side it works! Shadows look great now.

 

The two following links helped solve my problem

http://www.sim-outhouse.com/sohforums/showthread.php?70828-FSX-self-shadow-problem

http://www.fsdeveloper.com/wiki/index.php?title=RADItor

Share this post


Link to post
Share on other sites

Although I can't guarantee that it'll work with everyone, this gives me absolutely perfect AA with +- 25FPS average in the Q400 and the T7 in DX10 mode.  Latest drivers on GTX570 and 4.2GHz OC'd i7 2600k.

 

I use these fsx.cfg settings

 

D3D10=1
MultiSamplesPerPixel=8
MultiSampleQuality=8
 
Combined with these nVi settings
 
settings.PNG

Share this post


Link to post
Share on other sites

I have the exact same NI settings already. AA and performance is not really the issue at hand, but the artifacting of exterior shadows around the aircraft as demonstrated in the video. Parameters must be altered in the aircraft exterior mdl. Don't quote me, but, my understanding is that the parameters are determined automatically via some algorithm during the creation of the .mdl. Unfortionately it is inaccurate, and explains why some airplane shadows are worse than others. Generally I have found that the radius needs to be increased for all aircraft.     

 

Not surprisingly, this method cleans up the exterior shadowing in DX9 as well. Although I don't fully understand the inner workings of exterior shadow mapping, I do know that increasing the radius seems to increase the distance where this artifacting begins to occur. This is a tolerable solution. The further out you are the less obvious and less distracting.

Share this post


Link to post
Share on other sites

When I tried altering the radius, I found it disabled ALL aircraft shadows up to that range. Sure - it gets rid of the artefacts, but it seems to me to be "throwing the baby out with the bath water" <?>.

 

Adam.

Share this post


Link to post
Share on other sites

×
×
  • Create New...