Sign in to follow this  
PatsTeam

Artifact (?)

Recommended Posts

Hi,

 

Does anyone know how to fix this kind of artifact? It is only one millisecond so it looks a flash. It seems the problem occurs only when moving my view btw.

 

870879bb1c.jpg

 

Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Does this happen on every airport? Are you using bufferpool tweaks?

Share this post


Link to post
Share on other sites

Yes it occurs on every airport.

My bufferpools:

 

[bufferPools]
PoolSize=5000000
RejectThreshold=131072
UsePools=0

Share this post


Link to post
Share on other sites

Welcome to Avsim!

 

Since this happens as a flash, I'd guess that your video card is not able to keep up with the demands being placed upon it.

Share this post


Link to post
Share on other sites

I have a GTX 660Ti and I am nearly sure I didn't had the problem in my previous FSX install.

Share this post


Link to post
Share on other sites

Try to disable your bufferpool tweaks to see if it changes anything

Share this post


Link to post
Share on other sites

With usepools=0 it is disabled, isn't it? I tried usepools=1 and I can confirm the problem is resolved, but my average fps is decreased with 15(!).

Share this post


Link to post
Share on other sites

Yes it occurs on every airport.

My bufferpools:

 

[bufferPools]

PoolSize=5000000

RejectThreshold=131072

UsePools=0

If you are using PoolSize and RejectThreshold value, you should not have UsePools=0 in your config.

 

Otherwise you should use only:

 

[bufferPools]

UsePools=0

 

And set your water setting in FSX to 2x high, or you will get artifacts.

 

Regards,

Share this post


Link to post
Share on other sites

So:

 

[bufferPools]
UsePools=0

 

And water setting 2x high should fix it. I will test it.

 

Edit : It worked, but water 2x high eats a lot of fps compared to none what I had before. There is no other way around to fix the artifact?

Share this post


Link to post
Share on other sites

So:

 

[bufferPools]UsePools=0

 

And water setting 2x high should fix it. I will test it.

 

Edit : It worked, but water 2x high eats a lot of fps compared to none what I had before. There is no other way around to fix the artifact?

I am not aware of, but Regardless of what your rig specs are, I would suggest maybe compromising on some other slider settings to compensate.

 

Edit: I am no expert, but I should add that to use the BP=0 tweak, I believe you have to have a reasonable GPU.

Share this post


Link to post
Share on other sites

 

Yes it occurs on every airport.

My bufferpools:

 

[bufferPools]
PoolSize=5000000
RejectThreshold=131072
UsePools=0

 

 

 

Just want to confirm what wanabflyer said.

You cannot ever use usepools=0 with values in rejecthreshold and poolsize

If you want to use the rejectthreshold and poolsize it will look like below.

 

[bUFFERPOOLS]

UsePools=1

Poolsize=8388608

RejectThreshold=126976

 

Also there is specific values that should be used. e.g.

=524288  highest

=262144

=126976  <---- this is what I start with for a safe value and RARELY ever have to use any different

=98304 
=65536    lowest
 
Same thing for poolsize: You cannot just add any random number.
 
 

do you have the HIGHMEMFIX added in your FSX.cfg

[GRAPHICS]

HIGHMEMFIX=1  

 

this should be in ALL FSX.cfg files.. it was left out by Aces by mistake in SP2/Acceleration

 

 

Have you read the FSX tweaking guide where this is properly explained

http://forum.avsim.net/files/file/41-basic-fsx-p3d-configuration-guide/

 

Bufferpools is NOT the holy grain of fsx. It either work for you or NOT.

 

Bufferpools – Not recommended except for tweaking Autogen. Autogen has a default

texture buffer of 4 million (PoolSize=4000000) but this default function is not displayed in the FSX.cfg. If you want to change this value you will have to add the heading [bufferPools] and then, on the next line enter the new parameter. This will override the default setting set by Microsoft when they developed FSX. Setting the value to UsePools=0 means it will completely use the video card memory as the texture buffer. This could provide improvements to FSX with a very modern video card but may produce artifacts, memory spikes, and many times crashes. If you want to play with this parameter, you can simply search the Internet for Bufferpools FSX. We have seen too many issues by many who have tried this so-called ‘tweak’ so users should use caution when employing this parameter.

 

So if you you really wanna try bufferpools

starts with just

 

[bufferPools]

UsePools=0

Share this post


Link to post
Share on other sites

Thanks, I used some tweak tools so I haven't done the wrong bufferpools by my self. I will use usepools=0 because of the fps improvement.

I also have highmemfix and I downloaded the tweaking guide already a few hours ago.

Share this post


Link to post
Share on other sites

you can also read more here

http://www.simforums.com/forums/drivers-nv-inspector-fsxcfg-complete-guide_topic36586.html

 

Another good read is this document where point 6 explain the bufferpools. Download and read point 6. Although this is about DX10, it is a very detailed explanation on bufferpools

 

http://www.nzfsim.org/index.php?dsp=dload&fname=DX10_HowTo.pdf


Thanks, I used some tweak tools so I haven't done the wrong bufferpools by my self. I will use usepools=0 because of the fps improvement.

I also have highmemfix and I downloaded the tweaking guide already a few hours ago.

 

Great, hope you get it sorted.

Share this post


Link to post
Share on other sites

I also found this particularly true on my system

Whenever I use BP=0, I always make sure my target frame rate is locked and I use highwater2.

 

"quote from the FSX customsining doc"

 

Notes:
Normally a locked framerate is required (30 set in fsx). BP=0 will cause artifacting and flashing if the ‘match’ is wrong. In this case, either set water to High 2.x, or set BP to “1” and add a RejectThreshold. Testing for size is a few hundred identical low-level flights with on-screen frame rates visible around a known frame-rate killer area, such as the city of Seattle. As the settings become “more correct” the frame-rate will increase, and the dips will lessen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this