Sign in to follow this  
Nemo

ASN fights FSUIPC

Recommended Posts

I could really need some help on a very very strange behavior. I hope  I can explain it good enough as English is not my first language.

 

The issue started with installation of AS A318/319. After some time, P3Dv2.3 suddenly did not start anymore. I could figure out it has sth. to do with ASN and FSUIPC.  I removed both entries from dll.xml. P3D did still not start (Start window/P3D closes before reaching the scenario setup window). Re-installed FSUPIC. Everything is fine again. Re-installed ASN. Started P3D: Everything is fine. BUT ONLY FOR ONE TIME. After I had done a short flight (ASN weather works) I closed P3D. Now when I want to start P3D again I am in the same %§$ situation. P3D CTD w/o any comments.

 

Meanwhile I uninstalled AS 318/319, but I still have that issue.

 

I can use FSUIPC and ASN just one time together. After a P3D CTD, I do a reinstall of FSUIPC, then I open ASN, which says "sim module configured". Then I can start P3D. Can do a flight. But as soon I have quitted P3D, I can't start it anymore ... do a reinstall of FSUIPC, then ...

 

and so on ... and so on ...

 

Isn't this odd? Meanwhile I am at the end of my knowledge. I tried nearly everything, deleted dll.xml and p3d.cfg. Did completely uninstall ASN and reinstalled the new beta 5 ...

 

I could really need some new ideas.

 

Cheers,

Harry

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Unless you are using some of the functions in the FSUIPC utility, you do not need to have it installed. I do not use any of the utilities except to record VAS and I do not really need that. So, you can uninstall it or disable it in the dll.xml. In fsx the freeware/payware versions trapped the infamous g3d.dll crash and that's the only reason I use it in fsx. Not required for ASN either.

 

Best regards,

Share this post


Link to post

Unfortunately no ideas as I've never seen anything like this before and you have done some diagnostics that didn't resolve that I would think should have resolved. 

 

There is a know compatibility issue with ASN and Aerosoft's A318/319 weather radar processing.  Joshue Che posted a hot fix DLL that disabled the weather radar but I can't find that thread any more on Aerosoft's forum.  see link here: http://forum.aerosoft.com/index.php?/topic/85412-hotfix-101c-hf-1-01c-quick-post-release-fixes/  

 

Also, when installing A318/A319 did you elect to install RAAS?  RAAS apparently has some compatibility problems with P3D v2.x ... I believe RAAS will create an entry in your DLL.XML ... make sure this is disabled if you did install RAAS.

 

You'll need to provide some details on what you mean by P3D won't start?  Error messages, OS Event Logs?

 

Cheers, Rob.

Share this post


Link to post

What does event viewer tell you what is happening? It should be able to tell you which module is crashing which app.

Share this post


Link to post

Are you using EMT? (Estonian Migration Tool) It will disable ASN causing unpredictable results. They are working on a fix.

 

Also be sure you are using the LATEST ASN and FSUIPC.

 

 

Vic

Share this post


Link to post

Unfortunately no ideas as I've never seen anything like this before and you have done some diagnostics that didn't resolve that I would think should have resolved. 

...

You'll need to provide some details on what you mean by P3D won't start?  Error messages, OS Event Logs?

 

Cheers, Rob.

 

Thank you guys. Problem unexpectedly solved.

 

 

Issue description:

 

P3D crashed during loading without any error comments. I could solve this by a new install of FSUIPC or by disabling/removing the FSUIPC entry from dll.xml. The latter was no option for me as I need FSUIPC. Reinstallation of FSUIPC did cure the problem, but unfortunately, only for one run. Then the issue returned. First I anticipated a FSUIPC/ASN problem because after every reinstall of FSUIPC, ASN always did change the dll.xml. But that was it not, even after complete removal of ASN, the issue returned. Then I tracked the P3D loading process using simconnect.ini. This showed that P3D did load all dlls as indicated in dll.xml but hangs on loading the fsuipc4.dll.

 

Solution/Conclusion:

To maker a long story short: The problem was the aircraft position/scenario when I did exit P3D. Usually I do my tests (like the new AS A318/19) on demanding areas like KSEA/ORBX PNW heading RW 34R and make this the default flight. If I exit P3D from that area, it seems that P3D does not shut down proplery which than corrupts something FSUIPC related. Reinstallation of FSUIPC fixes that, but the issue returns as long as I open and close P3D at that ac position.

 

The issue and its solution was reproducible. It does not happen when I exit P3D from a less demanding scenery in ORBX/PNW. But as soon as I return to KSEA or to CYYV (FSDT) and exit P3D, the issue is back. Overall it seems to be a P3D/FSUIPC bug. P3D does not shutdown properly under certain circumstances which might also be related to ORBX/PNW Scenery.

 

 

Cheers,

Harry

 

 

Share this post


Link to post

Hope you post this in both the LM and FSUIPC forums Harry!

 

Vic

Share this post


Link to post

Yes Vic, will do it, but will wait how it behaves with 2.4 which I just have downloaded.

 

Harry

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this