Sign in to follow this  
WGP

PC12 P3D 2.4 - Accelerates on Startup

Recommended Posts

I'm wondering if anyone else is having issue with the PC12 accelerating on start up. I have the brakes on but it pushes the aircraft forward anyway. I have checked all my axis settings yet this still happens every time I start up the aircraft. This only happens for about 5-10 secs where the engines pulls the aircraft forward even with the parking brake applied.

 

I've tested the condition lever various positions, disabled prop pitch but still having this issue. I don't have any add ons except for the free version of fsuipc, and some obrx scenery.

 

I have yet to see anyone experiencing the same issue. I don't have problems with any other aircraft just this one.

 

Looking for ideas to further troubleshoot this problem.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This is common with turboprop engines...try this...prior to start the condition lever should be all the way back, then when you press the start button (wait for the start), when you get 10-11% NG, move the condition lever a bit (20%), the fuel goes in, then move it all the way to IDLE, it shouldn't accelerate doing it that way...at least I did it like that and it doesn't happen anymore with any turboprop

Share this post


Link to post
Share on other sites

I too have this problem, and even CTRL+F2 (feather) does not stop it.

 

The suggestion above is a good one, probably better than my "fix" of dialing enough reverse thrust (14-percent, IIRC) that the opposing forces balance each other.

 

The only turbo-prop that I have in the hanger that does not have an explicit prop control lever - weird.

Share this post


Link to post
Share on other sites

I was going to, tongue in cheek, suggest chocks but, looking at what 'chocks' does, it's a horribly bad idea.  It looks like the method Carenado uses on their 'autostart' is to just put the Condition Lever to idle.  Is that not correct?

Share this post


Link to post
Share on other sites

 


The suggestion above is a good one, probably better than my "fix" of dialing enough reverse thrust (14-percent, IIRC) that the opposing forces balance each other.

 

It works perfectly...not even has anyone complained about this, I didn't have this problem, I start it according to the procedures (common turboprop startup) and there is!

 

Try what I said above and you guys will be fine...again, there's no problem with the startup

Share this post


Link to post
Share on other sites

JJMP: worked just fine, thank you! 

 

I will have to try that on the other turbo-props I fly - I think I have flown pistons so long that the mantra is "gas first".

Share this post


Link to post
Share on other sites

This is common with turboprop engines...try this...prior to start the condition lever should be all the way back, then when you press the start button (wait for the start), when you get 10-11% NG, move the condition lever a bit (20%), the fuel goes in, then move it all the way to IDLE, it shouldn't accelerate doing it that way...at least I did it like that and it doesn't happen anymore with any turboprop

 

 

Thanks jjmp that absolutely helped. I'll have to RTFM next time. :)

Share this post


Link to post
Share on other sites

Create a saved default flight, load up flight sim with a default airplane anywhere in the world, cut the engines, turn off the lights, set the parking brake, then save the flight as default. From now on your pc-12 when loaded with also not have engines running when loaded.

Share this post


Link to post
Share on other sites

 

 


JJMP: worked just fine, thank you! 
 
I will have to try that on the other turbo-props I fly - I think I have flown pistons so long that the mantra is "gas first".

 

hahaha yeah!, I know that, I've flown pistons so long too!, great!, I'm glad it works!


Create a saved default flight, load up flight sim with a default airplane anywhere in the world, cut the engines, turn off the lights, set the parking brake, then save the flight as default. From now on your pc-12 when loaded with also not have engines running when loaded.

 

You can do that without doing all that, if your new or saved flight, loads with the engine running, just open the toggle control shift + 7, 8, 9 (I don't remember exactly which number is) and simply click on the COLD & DARK option, it will cut off the engine and shut down all systems...that's what I always do when the flight has been loaded with the engine running...it shuts down everything, pretty useful for cold & dark
 
Also, if I'm not mistaken, Bert knows how to start all your flights with the engine(s) not running of a desired aircraft...by modifying the aircraft gauges I guess...

Share this post


Link to post
Share on other sites

You can do that setting cold and dark after it loads but with my way the airplane wont roll forwards right when flightsim loads

Share this post


Link to post
Share on other sites

 

 


Create a saved default flight, load up flight sim with a default airplane anywhere in the world, cut the engines, turn off the lights, set the parking brake, then save the flight as default. From now on your pc-12 when loaded with also not have engines running when loaded.

 

Interesting.  So, if your default doesn't have engines running and you just select an airplane and airport and click Fly, it sets up up without the engines running?  You'd think I'd have noticed this.

Share this post


Link to post
Share on other sites

Interesting.  So, if your default doesn't have engines running and you just select an airplane and airport and click Fly, it sets up up without the engines running?  You'd think I'd have noticed this.

 

Some custom airplanes have their own panel state, like the pmdg. But everything else will load exactly as you set the default flight. Make sure to use a default airplane, and dont turn off any system switches just cut the engines, set everything else up the way you want it like nav light on beacon light off, parking brake set, then go up to the menu and save, check save as default.

Share this post


Link to post
Share on other sites

Just an FYI: I use SimLauncher, and it has multiple options for how you want to load a flight. I have the "cold and dark" option selected and every aircraft is loaded thusly. It also allows me to start in a specific parking spot, sets the flight time, preload flight plans, etc., all before the sim (I am currently using P3D v1.4, aiming for V2 for Christmas) launches.

 

Great product, and it is free!

Share this post


Link to post
Share on other sites

Some custom airplanes have their own panel state, like the pmdg. But everything else will load exactly as you set the default flight. Make sure to use a default airplane, and dont turn off any system switches just cut the engines, set everything else up the way you want it like nav light on beacon light off, parking brake set, then go up to the menu and save, check save as default.

 

I don't find this to be needed, not at least, with Carenado recent aircrafts that has the toggle control where you can click "cold & dark" to your saved flight (if it loads with the engine and system running) and that's ALL you have to do, to have it COLD AND DARK, at least for Carenado

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this