Jump to content

Sign in to follow this  
roland_lfor

Another radar gauge for VC & Window usage

Recommended Posts

Hello and happy new year to all simmers!

 

Thanks to Bryn work, he gave me the idea to develop my own gauge. I wanted to have a gauge which can be integrated in Virtual Cockpits as well.

 

I have now a working Beta version which currently do:

- Windows standalone use or VC integration in existing [VcockpitXX] location

- Tilt/Range/Gain driven from Gps buttons

- Tlt/Range from mouse wheel (if Gps buttons unavailable)

- Sweep radar beam simulation (optionnal)

 

 

 

See below an example in the A2A PA-28, replacing the GPS:

 

843473ASNWRadarv05.jpg

  • Like 1

Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

I woulkd be great if somehow it could be integrated with the VC GTN 750, since the GTN 750 presently doesn't implement the weather radar option when one selects it and just shows a message. Maybe you should email Flight 1 and see if they would be interested in incorporating your gauge into the GTN 750. Here's what the GTN Trainer Lite weather display looks like:

 

  https://www.dropbox.com/s/lirkoj29oc5gwq7/GTN%20750.jpg?dl=0


Jay Bloomfield

Share this post


Link to post
Share on other sites

Unfortunately, it's not possible to merge 2 gauges at the same location.

The only "clean" solution is to merge my code with the GTN750 code and build a new bitmap.

It won't happen I'm afraid.

 

I'm looking for a solution to overlay my gauge bitmap over an existing glass cockpit gauge.

At this time, I did not find any solution.

 

Roland


Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

I placed this in 2d view as a panel in the default Extre 300 as per pdf, but I just get a blank screen and then it disappears. Anyone have any ideas? Below is my cfg entry.

 

 

[Window05]
size_mm=100,150
position=2
visible=0
Window_pos=0.05,0.65
zorder=4
background_color=0,0,0
alpha_blend=0.55
 
gauge00=RolasnRadar!oRadGauge, 0,0,100,150, sweep|icing

Share this post


Link to post
Share on other sites

Sorry for this 1st silly question:

- Are you using ASN ?

- if you start without ASN, you are supposed to see "No radar link!" on the gauge. Do you see it ?

- try to modifiy the declaration with "visible=1"

- Perhaps try also to "undock" the window and see what happens.

 

I spend most of testing time with the VC mode(which was the main goal for me), and I'm running P3D. But if there is an issue with the 2D window under FSX, I'll do my best to fix it.

 

Thanks

 

Roland


Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

I have retested the window mode. It's working.

I have currently this settings:

 

 

 

[Window19]
size_mm=200,250
position=2
visible=0
ident=3012
Window_pos=0.05,0.65
zorder=4
background_color=0,0,0
alpha_blend=0.65
gauge00=RolasnRadar!oRadGauge, 0,0,200,250, sweep|icing

 

I have tried with visible =1 or visible=0: it makes no difference.

 

One problem I saw however, you should avoid to increase the size of the gauge with mouse.

 

 

393949ASNWRadarv05win.jpg


Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

Thanks Roland

 

I tried your new settings and for some strange reason when i hit the shift number key, a black panel flashes on the screen for about a second and then goes away. When I hit the shift number key again, nothing. I downloaded again but that did not fix it.

 

John

Share this post


Link to post
Share on other sites

John,

Can you detail your FSX version and OS, so perhaps another user with similar configuration could help or confirm it works or not?

 

I would like to know if it's a common issue.

 

Please try also to disable the "alpha_blend" line with a comment '//'.

 

What is exactly the "shift number key"?


Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

I have exactly the same problem trying to get it to work in a 2D window.  Black square flashes and disappears.  I have tried tinkering with the settings (changed visible, changed zorder, removed alpha_blend, added an ident) and nothing makes any difference.  Another airplane with the Bryn gauge works fine so I know all the connections to ASN are working.

 

'Shift-number-key' just refers to the key combination to show a window.  I have:

 

[Window03]
size_mm=200,250
position=7
visible=1
background_color=0,0,0
zorder=5
ident=9440
gauge00=RolasnRadar!oRadGauge,0,0,200,250,sweep|icing
 

So when I press SHIFT+4 the window should appear.  Instead it appears to be crashing.

 

UPDATE:  Sadly I can't get it to appear on any VC either.  I have tried several airplanes.  It does load the DLL because it asks me to authorize it.  But nothing appears, the space (where the previous GPS or Wx radar or whatever was) is simply blank or has the texture on it the same as if I'd never installed the gauge on the panel.  It is installed correctly without syntax errors, I am very experienced at doing this.  I have tried placing the DLL in [FSX]\gauges, and also in the FSX root.  (I am running Acceleration with the DX10 Scenery Fixer.)

 

Too bad, this gauge looks much more realistic than Bryn's and it should work in the VC, which I can't get the Bryn one to do.

 

Dutch

Share this post


Link to post
Share on other sites

I'm running P3D but someone did a test under Fsx for me with success.

I'll ask if it's an Acceleration pack.

 

The gauge use SimConnect. could it be an issue for your system?

I can avoid using it if it's an issue, easily.

 

Did you powered the avionic bus for testing?

 

Roland

I would like to know also if you have both Dx10 activated.


Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

Roland

 

I have FSX Acceleration running on Windows 8. I use the shift 6 key. Bryn's radar also works OK for me, but for some reason this one doesn't. I have tried it on both DX9 and DX10 and it is the same for both. All other avionics are on.

 

A pity as it really looks like a cool gauge.

 

John

Share this post


Link to post
Share on other sites

I got curious and tried the 2D version with Win 8.1 and P3D 2.4. I got a similar result as above. A vague gray blob showed for a split second and disappeared. Bryn's gauge works okay.


Jay Bloomfield

Share this post


Link to post
Share on other sites

Well, I have reloaded the gauge from Avsim library to be sure I have the same version: it still working on my system P3D v2.4.

 

 

I really don't know what is the cause.

 

 

It would be great if someone who use it with success write a post in this thread so I know it's working on some systems.

 

 

There is around 300 downloads but I still don't know if it's working for someone :(

 

 

Thanks

Roland

 

******************************************************************************************************

EDIT: I developed the gauge with VC++ 2013, so perhaps you need to install the related Redistributable Packages. Can you install them and tell me if it works?

 

<Link>http://www.microsoft.com/en-US/download/details.aspx?id=40784

 

******************************************************************************************************


Roland

My ASN, AS16, ASP4 weather radar gauge:

The gauge discussion thread 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...