Sign in to follow this  
camadidu

AA and full-screen problems with DX10

Recommended Posts

Hello. Let me start with my system settings.

HP Pavilion g4-2064la
Intel Core i3 @ 2,3GHz
4Gb RAM
Intel HD Graphics 3000 (integrated)
ATI Radeon HD 7670M (dedicated) - Switchable graphics
FSX with SP1 and SP2

I've forever used FSX in DX9 mode, but recently wanted to try DX10 and see how it works. Even though the FPS have never been so good in my computer and I have applied the fixes, antialiasing is terribly bad. I have already applied the MultiSamplesPerPixel=4 in the fsx.CFG [GRAPHICS] section and the "Use application settings" in RadeonPro's AA options (I also selected Multisampling (Box)). Anyway, the AA should work, but it does not function very well. 

I also get a black full-screen view, but I can see everything if FSX is running in windowed mode.

Thanks for your help. I suppose I should start by letting FSX build a new fsx.CFG file, shouldn't I? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I think that there may be some issues with lap tops with intel/GPU combos running FSX in DX10 mode. Try searching for Optimus on Avsim to see if you can find anything

Share this post


Link to post
Share on other sites

Do you use Steve's DX10 fixer?

 

 

It doesn't matter if you are using his fixer or not. If you can't run AA properly without the fix, AA will be no better with Steve's fix (or so I think). Of course, you need to add the MultiSamplesPerPixel=# tweak to make AA work in DX10, but you can add it anyway without Steve's fix, which is mostly for the shaders, effects and some textures.

 

I think that there may be some issues with lap tops with intel/GPU combos running FSX in DX10 mode. Try searching for Optimus on Avsim to see if you can find anything

But isn't Optimus for nVidia graphics? I have an ATI Radeon.

Share this post


Link to post
Share on other sites

You are completely correct that my tool wouldn't change this - the AA is defined by MultiSamplesPerPixel and in CCC by theslider which allows you to select SuperSampling.

 

The AMD equivalent is AMD Dyanamic Switching. All I recall is that with the Nvidia version (Optimus) people were reporting issues and I wondered if that was related to the black screen view.

 

Have you tried Ron's instructions for black screen here?

 

http://forum.avsim.net/topic/458300-full-screen-problem-in-dx10/

Share this post


Link to post
Share on other sites

I want to share some advances with you guys.

 

1. I still cannot understand why full-screen FSX is black.   I (tried to) click where Ron says but it made FSX no better. Windowed mode works perfectly.  :blink:

One thing I did notice was that after I click "Fly Now!", but before the loading dialogue appears, the screen flashes and goes black and on again like if it was doing a driver installation or update. The same happens when changing from full-screen to windowed mode and vice versa. 

 

(I have an Intel Graphics HD 3000 and an ATI Radeon HD 7670M  with switchable graphics. FSX is set to run at high performance in the CCC settings.)

 

2. I let FSX build a new fsx.CFG file and then I applied the following tweaks:

 

[GRAPHICS]

HIGHMEMFIX=1

MultiSamplesPerPixel=4

 

[Display]

WideViewAspect=True

RUNWAY_LIGHTS_APPROACH_SCALAR=0.65
RUNWAY_LIGHTS_STROBE_SCALAR=0.7
RUNWAY_LIGHTS_SURFACE_SCALAR=0.75
RUNWAY_LIGHTS_VASI_SCALAR=0.5
 
[bufferPools]
UsePools=0
 
[JOBSCHEDULER]
AffinityMask=14
 
[Main]
DisablePreload=1
FIBER_FRAME_TIME_FRACTION=0.18
Location=-4,-4,1370,744,\\.\DISPLAY1
Maximized=0
// The last two entries appeared by themselves after the first FSX run with DX10. I have no idea what they are.
 
[TERRAIN]
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=2000//1000
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=800//700
 
[DISPLAY.Device.Intel® HD Graphics 3000.0]
Mode=1366x768x32
Anisotropic=1
AntiAlias=1
 
[DISPLAY.Device.Intel® HD Graphics 3000.0.0]
Mode=1366x768x32
Anisotropic=1
AntiAlias=1
 
// [DISPLAY.Device.etc] was set by FSX itself.
 
3. Here are some comparison shots, with FSX-AA disabled and FSX-AA enabled. I still did not get the best AA ever (I have very good AA in DX9), but better something than nothing.  ^_^ (Real images resolution is 1366x768. Please click to enlarge them or open them in a new tab.)
 
AA disabled
2015-1-30_11-10-14-551.png
 
AA enabled
2015-1-30_11-10-26-113.png
___
AA disabled
2015-1-30_11-13-44-898.png
 
AA enabled
2015-1-30_11-13-55-71.png
 
I think that, perhaps, increasing the MultiSamplesPerPixel from =4 to =8 should help to improve AA in FSX DX10.

 

P.S.: The aircraft is Project Airbus A320 FD-FMC version and the scenery is VirtualCol Colombia Virtual Xtreme Edition 2011 (SKCL airport).


Here I add a picture of GPU-Z 0.7.7 showing the Radeon 7670M's performance during the FSX DX10 test.

Shot1-copia.gif

Share this post


Link to post
Share on other sites

Somebody please shed some light to me.

 

Seeing the two pictures above of the A320's VC (and doing another FSX DX10 test), I have noticed something very weird. Everything but the PFD, the ND and the ECAMs 1 and 2 are affected by the antialiasing options. Their "readability" does not improve with AA activated. Nevertheless, everything else gets better (or is good already).

 

Any ideas on why does that happen?

Share this post


Link to post
Share on other sites

Somebody please shed some light to me.

 

Seeing the two pictures above of the A320's VC (and doing another FSX DX10 test), I have noticed something very weird. Everything but the PFD, the ND and the ECAMs 1 and 2 are affected by the antialiasing options. Their "readability" does not improve with AA activated. Nevertheless, everything else gets better (or is good already).

 

Any ideas on why does that happen?

 

This happens with NVidia cards also. The trick with "readability" problems on some aircraft or instruments, and the NVidia cards, is to use transparency sparse grid supersampling, rather than transparency supersampling or multisampling. This only comes up in DX10 FSX and DX11 P3D, DX9 unaffected.

Share this post


Link to post
Share on other sites

This happens with NVidia cards also. The trick with "readability" problems on some aircraft or instruments, and the NVidia cards, is to use transparency sparse grid supersampling, rather than transparency supersampling or multisampling. This only comes up in DX10 FSX and DX11 P3D, DX9 unaffected.

 

And how on Earth can I do that in my ATI/AMD card? I can't believe FSX DX10 looks at least decent in my laptop but planes are unflyable because there is no way to read their gauges.

Share this post


Link to post
Share on other sites

Well, the NVidia card has a supporting program called NVidia Inspector, this is used to set special modes of operation on the NVidia cards. Perhaps there's something similar for your card?

Share this post


Link to post
Share on other sites

Well, the NVidia card has a supporting program called NVidia Inspector, this is used to set special modes of operation on the NVidia cards. Perhaps there's something similar for your card?

RadeonPro.

Buy a Nvidia card and it will be fixed

I have a laptop. There is no way I can remove the ATI Radeon 7670M and install a Nvidia GPU without possibly breaking something.

Share this post


Link to post
Share on other sites

 

 


2. I let FSX build a new fsx.CFG file and then I applied the following tweaks:

 

That cfg shows FSX using the HD3000.

Can you show us a cfg where FSX recognizes the ATI card?

 

gb.

Share this post


Link to post
Share on other sites

A common theme with these laptops with combination GPUs is that they appear within fsx as the name of the Intel gpu. I think from previous threads that that isn't an issue. I would try enabling super sampling with catalyst rather than radeon pro as the latter is a third party tool that needs to detect the GPU at runtime and it may be similarly confused by the Gpu identity.

Share this post


Link to post
Share on other sites

That cfg shows FSX using the HD3000.

Can you show us a cfg where FSX recognizes the ATI card?

 

Even though FSX only recognises the Intel Card, that doesn't seem to be an issue because

1) the activity of the Radeon card increases when I'm using FSX, while the Intel GPU's activity remains rather constant.

2) when FSX is set at CCC to run in the power-saving mode, it is extremely laggy and such, but when it is set to run at high-performance (like I always do), it works way better.

3) RadeonPro settings affect FSX's graphics.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this