Jump to content

Sign in to follow this  
bouma1874

help with getting my simconnect working

Recommended Posts

Hi,

 

I've recently acquired a laptop, and was really looking forward to getting my rig networked nicely for fsx...turned out I'm having a real bad time of it lol. I've been looking at all kinds of guides, youtube tutorials for 2 days now but still cant get anything working :(

 

From what I can tell, I've got the network running (all drives mapped and visible on both PC and Laptop)..Downloaded and installed the SDK and all Service packs on both devices. Configured the SImConnect.cfg and Simconnect.ini on both devices

 

Disabled Firewalls and AV's but when I try the test with AI located in the samples file, a command box pops up then disappears.

 

Is there anything I could have missed??

 

Thanks in advance

Share this post


Link to post
Share on other sites

When you install a program that requires simconnect, say ASN or P3DV2.5, the program will install the proper version. Nothing is required on your part. You just sit back and let the appropriate installer install simconnect for you. If you want to have a networked configuration, then the best guide was put together by the developers of ActiveSky Next or HiFi. Here's a link to that guide - http://support.hifitechinc.com/Knowledgebase/Article/View/6/3/networked-configuration-with-simconnect. The SDK is only for developers who want to use simconnect with their software program. People like us who are not developers should just stay away from the SDK. It is only very confusing to individuals not familiar with the software development community.

 

So, if you are just installing ASN, the program will automatically install a version of simconnect that works for that program and no other program on your computer. P3DV2 installs a version of simconnect for use with P3DV2 and no other software.

 

The complication is when one wants to network their software between computers they own and they need to use simconnect to do that. So, if you want to do that you want to read the ASN guide.

 

EDIT: I want to add that the purpose of this forum is for developers of software to get together to figure out how to use the Microsoft SDK so they can use simconnect in their addons. This forum really isn't for anyone who is not developing an addon using simconnect.

 

Best regards,

Share this post


Link to post
Share on other sites

The link posted above is a good one.   You most likely need to create or modify the SimConnect.xml file on the computer acting as the server (the one where FSX itself will run, presumably the desktop unit.)

 

And I'm going to respectfully disagree with Jim.  You've got to post the question where you think you're most likely to get a useful answer.

 

Doug

Share this post


Link to post
Share on other sites

Apologies if this was intended for developers.

 

Thanks for the very replies, it is a great guide but unfortunately I'm unable to get it working for myself lol.  Perhaps ddawson you could cast an eye over my xml. to see if anything is amiss ?? (I have added asterisks just for security but I am sure its the correct IPv4 Address)

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>192.168.*.**</Address>
    <MaxClients>64</MaxClients>
    <Port>500</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>

Share this post


Link to post
Share on other sites

And I'm going to respectfully disagree with Jim. You've got to post the question where you think you're most likely to get a useful answer.

Not too many people visit here. If you read the description provided by the AVSIM CEO under the forum name, it indicates to me it is a place for developers to talk about the functionality of simconnect with their programs. Either the FSX/P3D or this forum would be fine. I'm just looking at getting a members question answered as soon as possible. We have had many posts in this forum started with no responses or responses made several days later.

 

I apologize for making an edit to my original post and providing my assumptions.

 

Best regards,

Share this post


Link to post
Share on other sites

Apologies if this was intended for developers.

 

Thanks for the very replies, it is a great guide but unfortunately I'm unable to get it working for myself lol.  Perhaps ddawson you could cast an eye over my xml. to see if anything is amiss ?? (I have added asterisks just for security but I am sure its the correct IPv4 Address)

 

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">

  <Descr>SimConnect</Descr>

  <Filename>SimConnect.xml</Filename>

  <Disabled>False</Disabled>

  <SimConnect.Comm>

    <Disabled>False</Disabled>

    <Protocol>IPv4</Protocol>

    <Scope>global</Scope>

    <Address>192.168.*.**</Address>

    <MaxClients>64</MaxClients>

    <Port>500</Port>

    <MaxRecvSize>4096</MaxRecvSize>

    <DisableNagle>False</DisableNagle>

  </SimConnect.Comm>

</SimBase.Document>

 

The entries certainly look reasonable.  If you have configured the SimConnect.ini file on the server to produce a log file, you will see at the beginning the protocols that the current instance is supporting.  I imagine you will see the global protocol that you are specifying, but do check to be sure.

The other thing to consider is that the settings in the SimConnect.cfg file on the client machine have to exactly match the settings in the SimConnect.xml file on the server.  The SimConnect.cfg file can be located either in the application folder or in "My Documents"  To be honest, I'm not sure which of those will take precedence if there is a SimConnect.cfg file in both locations - you might need to experiment a little.

The program you're trying to use on the notebook should have created a SimConnect.cfg file.  I would make sure the Simconnect.xml file settings on the server match those specified in the SimConnect.cfg file of the application, with the caveat that the IP address specified in both files must be that of the server, not the client.

 

Doug

Share this post


Link to post
Share on other sites

 

 


Thanks for the very replies, it is a great guide but unfortunately I'm unable to get it working for myself lol.

 

Did you install the actual SimConnect dlls on the client (non-FSX) computer as described in the ASN description?

 

Mike

Share this post


Link to post
Share on other sites

The entries certainly look reasonable.  If you have configured the SimConnect.ini file on the server to produce a log file, you will see at the beginning the protocols that the current instance is supporting.  I imagine you will see the global protocol that you are specifying, but do check to be sure.

The other thing to consider is that the settings in the SimConnect.cfg file on the client machine have to exactly match the settings in the SimConnect.xml file on the server.  The SimConnect.cfg file can be located either in the application folder or in "My Documents"  To be honest, I'm not sure which of those will take precedence if there is a SimConnect.cfg file in both locations - you might need to experiment a little.

The program you're trying to use on the notebook should have created a SimConnect.cfg file.  I would make sure the Simconnect.xml file settings on the server match those specified in the SimConnect.cfg file of the application, with the caveat that the IP address specified in both files must be that of the server, not the client.

 

Doug

 

Cheers Doug, When i started FSX the DOS Box was was going too quick for me to log anything other than it seemed to be connecting the addons i use from the Server PC :wacko:

 

I believe i matched them up, i was trying to connect PRO ATC-X up, however this failed so i tried to see if the issue ran a little deeper.  I think it was as i couldn't connect the samples based in the SimConnect folder

Did you install the actual SimConnect dlls on the client (non-FSX) computer as described in the ASN description?

 

Mike

 

I think so, would these be the 3 SimConnect Client v10.0.60 etc??

Share this post


Link to post
Share on other sites

Here is the contents of my SimConnect.ini file:

[simConnect]
level=verbose
console=0
;RedirectStdOutToConsole=1
;OutputDebugString=1
file=f:\fsx_SimConnect\simconnect%03u.log
file_next_index=7
file_max_index=100
 

You will of course need to change the path to something that works on your system.

The simconnect.ini file itself needs to be in My Documents\Flight Simulator X Files

Share this post


Link to post
Share on other sites

 

 


I think so, would these be the 3 SimConnect Client v10.0.60 etc??

 

The best way to tell is to look in the following folder (either Windows 7 or Windows 8):

 

C:\Windows\WinSxS

 

You should see a couple of subfolders, one for each version of simconnect you have installed.  Here is a typical example.  It's fine if there is more than one entry (as long as the version you want is one of them).  You can see the version number in the middle of all the other stuff starting w/ 10.0...:

 

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297

 

Inside each of these folders will be a file SimConnnect.dll .  (You can also check its version by right clicking, then properties>details).

 

If the version you need is missing, follow the ASN instructions about updating your SDK and copying and running the simconnect.msi file on your client computer.

 

Hope this helps!

 

Mike

Share this post


Link to post
Share on other sites

Thank for your help guys, but even with re installing windows, doing a vanilla install of FSX and following the ASN guide to the letter...I still have no joy :(

 

I honestly have no idea what it could be

 

Would it be worth trying an ethernet cable to see if its a router problem??

Share this post


Link to post
Share on other sites

I'VE DONE IT!!!! (not quite sure how lol)

 

Thanks for all your help!!

Excellent.  Good to hear!

Share this post


Link to post
Share on other sites

 

 


I'VE DONE IT!!!! (not quite sure how lol)

Thanks for all your help!!

 

Glad it's fixed!  If you can figure out how you solved the problem, it would be helpful to others.

 

Mike

Share this post


Link to post
Share on other sites

sorry to jump on this but i'm having the same problem exactly

And I'm now at the end of my knowledge on this

Everything is shared I've checked my firewall and allowed the port 500 through

does ASconnect also need to be allowed through the firewall despite being on the server pc totally stumped now and have no idea what to try next

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...