Sign in to follow this  
Dragonmount

Still getting PMDG options error with only 777 SE installed.

Recommended Posts

Currently on FSX SE the only PMDG aircraft that is installed is the 777, and I still get the PMDG options error, if I click, run anyway, FSX will close immediately. Anyone know what to do about this situation?

 

Patrick Boynton

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Patrick, the most common problem causing this is the dll.xml file not being correct.  When that file has a problem modules don't load (dll's) and the sim doesn't run.  If you are not familiar with the file I recommend you submit a trouble ticket to PMDG Product Support.  They'll be able to  help you resolve this.

Share this post


Link to post
Share on other sites

Patrick-

 

There are no PMDG products currently FSX-SE compatible that use that dll...

 

Did you perhaps try to force-feed SE an airplane we haven't made compatible and there are some residuals left over?

 

(No EULA issue here- our products are EULAd for FSX and FSX/SE is still FSX.... so i'm wondering from an academic "trying to get a site picture of what you have/have done/might have left" in your installation...

 

Check the PMDG/Dlls directory, for example...   You should have a PMDG_interface.dll file there and that is all at this stage...

Share this post


Link to post
Share on other sites

My dll.xml file does have an entry for exactly the PMDG_Interface.dll file -- pretty sure this was put in by the installer:

 

 

<Launch.Addon>
    <Name>PMDG Interface</Name>
    <Disabled>False</Disabled>
    <Path>PMDG\DLLs\PMDG_Interface.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>

 

Patrick, dll.xml can be edited with notepad.  Be sure to back it up first. 

 

On a dual install, it will be found in:

 

C:\Users\[YOUR NAME]\AppData\Roaming\Microsoft\FSX-SE

 

On a single install of FSX Steam, I believe the folder will be the same except without "-SE".

 

Mike

Share this post


Link to post
Share on other sites

Well I did try to install a couple, just to see if they ran, then uninstalled them later, should I perhaps hunt for this .dll and just delete it?

 

Patrick Boynton

Share this post


Link to post
Share on other sites

Well I did try to install a couple, just to see if they ran, then uninstalled them later, should I perhaps hunt for this .dll and just delete it?

 

Patrick Boynton

Hi, Patrick,

 

Not sure which dll you mean, but don't delete it!  Don't delete dll.xml either -- it is modified by addons and will NOT rebuild itself when deleted.

 

Check to see if you have the entry in dll.xml as I described above.  You can try posting your entire dll.xml file in a post here.

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this