Sign in to follow this  
Pete Dowson

AI Traffic landing lights appear well ABOVE the aircraft ... Help me fix this please.

Recommended Posts

I'm hoping there's an aircraft design expert here, or at least somone who knows a bit about these things, who can help me fix a problem I've had for some time now and have searched high and low for a fix with no results.

 

I am using MyTrafficX. This is installed on my cockpit system, in FSX, FSX-SE, and Prepar3D. In all three, when observing AI traffic landing (or doing anything really), the landing lights are positioned well above the actual aircraft, in mid-air. As the aircraft approaches the lights get closing and closer, until when you are right in front of them, eg a few metres, the lights are almost where they should be.

 

This wasn't always the case, and I've been using MyTrafficX for many years. Other MyTrafficX users don't suffer from this, and no one on their Support Forum has been able to help.

 

It does it with default traffic BGLs too, and it applies not only to the aircraft installed by MyTrafficX, but those default aircraft being used for AI purposes too.

 

I thought it might be something to do with some rogue Effects file I'd installed, so I renamed the FS Effects file and copied over the folder from a default FSX installation (I have a default installation on my development machine so I can test FSUIPC in such a 'normal' environment). This made no difference to the problem.

 

Is there anyone here who knows what is going on, and therefore how to fix it -- or at least can suggest places to look?

 

Thank you.

Pete Dowson

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

same thing with me using UT2, couldn't fix it.

let us hope with your (mighty) name on this post might bring some one for rescue. ;-)

 

Regards

Ali A.

Share this post


Link to post
Share on other sites

There was a thread about 2 weeks ago with the same situation.  It was caused by a modified Halo.bmp

Share this post


Link to post
Share on other sites

There was a thread about 2 weeks ago with the same situation.  It was caused by a modified Halo.bmp

 

Aha, so not an effect! I'll check. thanks for the pointer ...

 

Pete

Share this post


Link to post
Share on other sites

There was a thread about 2 weeks ago with the same situation.  It was caused by a modified Halo.bmp

 

Okay ... replacing the changed halo.bmp with the default worked!  Thank you!

 

Trouble is now I realise why I changed to a different halo.bmp. Lights are now too big and bright, AI and runway lights included.

 

I now need to find a halo.bmp that gives decent properly sized lights without separating them on AI traffic! Any suggestions, anyone?

 

Pete

Share this post


Link to post
Share on other sites

Add these to the FSX.cfg under [Display]  Adjust the numbers till everything looks the way you want

 

it to.  As far as aircraft lights size, there are Halo.bmp files that have been modified to

 

accommodate for smaller lights.  I think N4GIX had done one that worked well.

 

I just found this in a quick search  http://flyawaysimulation.com/downloads/files/17974/fsx-landing-lights/

 

This download includes a set of modified halo.bmp file.  Don't know if it will cause the AI problem

 

again, or not.

 

RUNWAY_LIGHTS_APPROACH_SCALAR=1.2
RUNWAY_LIGHTS_STROBE_SCALAR=1.0
RUNWAY_LIGHTS_SURFACE_SCALAR=1.2
RUNWAY_LIGHTS_VASI_SCALAR=1.2
 

Share this post


Link to post
Share on other sites

Add these to the FSX.cfg under [Display]  Adjust the numbers till everything looks the way you want

 

it to.  As far as aircraft lights size, there are Halo.bmp files that have been modified to

 

accommodate for smaller lights.  I think N4GIX had done one that worked well.

 

I just found this in a quick search  http://flyawaysimulation.com/downloads/files/17974/fsx-landing-lights/

 

This download includes a set of modified halo.bmp file.  Don't know if it will cause the AI problem

 

again, or not.

 

RUNWAY_LIGHTS_APPROACH_SCALAR=1.2

RUNWAY_LIGHTS_STROBE_SCALAR=1.0

RUNWAY_LIGHTS_SURFACE_SCALAR=1.2

RUNWAY_LIGHTS_VASI_SCALAR=1.2

 

 

Thanks! I'll experiment and see what I can do.

 

Pete

Share this post


Link to post
Share on other sites

Okay ... replacing the changed halo.bmp with the default worked!  Thank you!

 

Trouble is now I realise why I changed to a different halo.bmp. Lights are now too big and bright, AI and runway lights included.

 

I now need to find a halo.bmp that gives decent properly sized lights without separating them on AI traffic! Any suggestions, anyone?

 

Pete

I got tired of playing the halo game that not only affected the AI lights but others as well. I have switched all my AI Aircraft lights over to Shockwave. What a difference that made, much more believable and immersive.

Share this post


Link to post
Share on other sites

I spent a lot of time on this. I have a selection of halo.bmp files, including the one that I use. Shockwave lights didn't work for me. If you PM me an email address I'll send them over to you, along with my scalar settings.

Share this post


Link to post
Share on other sites

I spent a lot of time on this. I have a selection of halo.bmp files, including the one that I use. Shockwave lights didn't work for me. If you PM me an email address I'll send them over to you, along with my scalar settings.

 

Thanks. I don't use PMs, but please send to petedowson@btconnect.com.

 

Much appreciated!

 

Pete

Share this post


Link to post
Share on other sites

Thanks. I don't use PMs, but please send to petedowson@btconnect.com.

 

Much appreciated!

 

Pete

 

Look for them before lunchtime !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this