Jump to content

Archived

This topic is now archived and is closed to further replies.

jpc55

Some Error SS I have seen flying missions

Recommended Posts

These are some SS of errors I have seen while flying clandestine missions.

 

The first one is a SS of the ANTIOCH BRIDGE on highway 160. The closest airport to it is "Funny Farm (4CA2), and the bridge is north west of it.

 

cCJjRCc.jpg

 

This SS, I had just taken off at Truckee- Tahoe (TKRK) and turning toward Fallon (KFLX). Below my left wing tip highway I-80.

 

749cHad.jpg

 

In this SS I am taxing to takeoff at Lake Tahoe (KTVL) and I see this on my right. After takeoff I made a 180° turn and take these next two SS.

 

hliOcLF.jpg

 

0n6ZHTP.jpg

 

KBVRTZL.jpg

 

As I was takeoff at Lake Tahoe (KTVL) I saw this pink in front of me.

 

4VO58H3.jpg

 

I am on a mission from Yerington Mun. (O43) to Sierraville (O79). I am just north of Truckee, that is highway 89 below me and I am 15.8 NM from Sierraville. Two SS.

 

Yty6PoQ.jpg

 

tS0FZRu.jpg

 

These next 4 SS I took on a mission from Lake Tahoe (KTVL) to Sierraville (O79). The first two are on the left side side of sierraville and the second two were to the right side.

 

i1li8BD.jpg

 

mihKfAm.jpg

 

FGHMmbF.jpg

 

TwFdeSr.jpg

 

There seem to be a lot of errors in the vicinity around Lake Tahoe.


J. R. :ph34r:

Share this post


Link to post
Share on other sites

I ran a quick test flight and the errors are only associated with winter scenery, I am over Lake Tahoe.

 

 

 

QKFHZaF.jpg

 

DaaQbVG.jpg

 

6hJnCqS.jpg

 

That is Lake Tahoe airport below me.

 

k24JajE.jpg


J. R. :ph34r:

Share this post


Link to post
Share on other sites

Try checking the ContentErrors.log file in %appdata%\Microsoft\Flight. If it has any information it may be useful to include here.

Share this post


Link to post
Share on other sites

Checked and the problem only arises in Winter - nothing wrong in Summer. This problem has been reported before by rhumba on FSDeveloper...
 
Content Error log (Lake Tahoe):

(38.921724, -120.038171): Mask "902B2M21.DDS" is not 8 tiles high.
(38.921724, -120.038171): Mask "902B2M11.DDS" is not 8 tiles high.
(38.921724, -120.038171): Mask "902B2M31.DDS" is not 8 tiles high.
(38.921724, -120.038171): Terrain texture not found: 080B2HW5DL.DDS (dir=88)
(38.921724, -120.038171): Terrain texture not found: 051B2HW1DL.DDS (dir=88)
(38.921724, -120.038171): Terrain texture not found: 051B2HW3DL.DDS (dir=88)
(38.921724, -120.038171): Requested asset does not exist: ({ED62AF5A-EC27-4BD0-8AB2-0454C94C7540})
(38.921724, -120.038171): MaterialVariation '{ED62AF5A-EC27-4BD0-8AB2-0454C94C7540}' for autogen failed because it is ether missing or is of the incorrect\invalid type.
(38.927612, -120.037453): Terrain texture not found: 051B2HW5DL.DDS (dir=88)
(38.929319, -120.036378): Terrain texture not found: 051B2HW6DL.DDS (dir=88)
(38.929319, -120.036378): Terrain texture not found: 080B2HW6DL.DDS (dir=88)
(38.933005, -120.035241): Terrain texture not found: 080B2HW3DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 051B2SU1DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 051B2SU3DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 051B2SU5DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 051B2SU6DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 080B2SU3DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 080B2SU5DL.DDS (dir=88)
(38.933676, -120.035073): Terrain texture not found: 080B2SU6DL.DDS (dir=88)
(38.938470, -120.034560): Terrain texture not found: 051B2SU4DL.DDS (dir=88)
(38.941409, -120.034061): Terrain texture not found: 051B2SU7DL.DDS (dir=88)

 
Content Error Log from previous error report:

(40.729899, -110.591587): Mask "902B2M31.DDS" is not 8 tiles high.
(40.729899, -110.591587): Mask "902B2M21.DDS" is not 8 tiles high.
(40.729899, -110.591587): Mask "902B2M11.DDS" is not 8 tiles high.
(40.729899, -110.591587): Terrain texture not found: 028B2HW2DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 051B2HW7DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 081B2HW5DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 051B2HW4DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 081B2HW6DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 080B2HW4DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 080B2HW5DL.DDS (dir=88)
(40.729899, -110.591587): Terrain texture not found: 080B2HW2DL.DDS (dir=88)
(40.729899, -110.591587): Requested asset does not exist: ({EB4AE517-4CB6-06A4-239D-62876D28BF28})
(40.729899, -110.591587): MaterialVariation '{EB4AE517-4CB6-06A4-239D-62876D28BF28}' for autogen failed because it is ether missing or is of the incorrect\invalid type.

Just some textures/ Land classes causing the problem.


Kavinda J.D  ^_^

Share this post


Link to post
Share on other sites

The *DL textures are detail lookup textures that are new in Flight.  I'm not sure what it does if they are missing.  Seems weird it would only complain about those in the winter though, so it could be something else is causing the problem that isn't being reported.

 

Edit: As far as I can tell all the textures referenced from that pink area exist.  My only guess at this point is a bad dependency chain, or possibly bad autogen annotation reference.  It looks like it is trying to access the 'd' variant of the autogen, but it only goes from 0-7.  It could be during conversion of the lclookup for existing land classes that I need to make sure to use the same mappings that exist in the existing lclookups.  I'll look into that.

Share this post


Link to post
Share on other sites

It looks like this could be the problem with possibly several of the land classes (and would explain why a lot of places don't have cliff textures:

 

In the lclookup in cold climate DLC:

    <TextureSet id="55">
      <DrawPriority>30</DrawPriority>
      <Texture Region="1" Variation="7" Vulcn="24"/>
      <Mask Region="1" Variation="7" Vulcn="900"/>
      <LightMap Region="1" Variation="1" Vulcn="137"/>
      <Autogen Region="1" Variation="7" Vulcn="24"/>
      <CliffTexture>
        <MinSlopeIndex>12</MinSlopeIndex>
        <TextureScaleLevel>6</TextureScaleLevel>
        <MildWinterAtlasSlot>3</MildWinterAtlasSlot>
        <HardWinterAtlasSlot>3</HardWinterAtlasSlot>
        <SpringAtlasSlot>3</SpringAtlasSlot>
        <SummerAtlasSlot>2</SummerAtlasSlot>
        <AutumnAtlasSlot>2</AutumnAtlasSlot>
      </CliffTexture>
      <Season>1</Season>
      <Season>1</Season>
      <Season>2</Season>
      <Season>3</Season>
      <Season>4</Season>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
    </TextureSet>

In the lclookup generated as part of FSX conversion:

    <TextureSet id="55">
      <DrawPriority>30</DrawPriority>
      <Texture Region="1" Variation="9" Vulcn="24"/>
      <Mask Region="1" Variation="7" Vulcn="900"/>
      <LightMap Region="1" Variation="1" Vulcn="0"/>
      <Autogen Region="1" Variation="9" Vulcn="24"/>
      <Season>0</Season>
      <Season>1</Season>
      <Season>2</Season>
      <Season>3</Season>
      <Season>4</Season>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
      <MaskTextureVariation>1</MaskTextureVariation>
    </TextureSet>

So it looks like in Flight they changed this land class to only use the 8 texture variation, but in FSX it was using the 16 texture variation.  For whatever reason even though they only used the 8 texture variation, all 16 textures were shipped with Flight, except for the extra 8 autogen annotations.  I think I will change the conversion process to load all the existing Flight land class mappings, and only add ones in the conversion that don't already exist in Flight.

Share this post


Link to post
Share on other sites

Ok, I think I have the pink textures fixed.  I also figured out why some heavy vegetation land classes don't have any autogen, so I will hopefully fix that one soon.  I also looked into why several tropical places have winter trees when there shouldn't be.  If any of you get time and can help me investigate what is going on in FSX, you can look at this thread on fsdev: http://www.fsdeveloper.com/forum/threads/fsx-conversion-scenery-errors.432604/#post-707781  It would be a huge help to me as I have a very limited time to work on stuff anymore.

Share this post


Link to post
Share on other sites

Just wondered what you make of this stonelance? I was flying a mission from Delta Mun. (KDTA) to Provo Mun. (KPVU) Dis. 62.3nm. When on approach to land, this popped up.

 

unUau0V.jpg

 

 

 

I took a number of SS of this anomaly, trying different scenery setting, and then my computer crashed. This crash happens from time to time, so I don't think that this caused the crash. After it rebooted I went back to the location and it now came up like this.

 

LhxvPTa.jpg

 

 

 

I played around with different scenery setting again, and the only common thing with all of them was this one runway sign.

 

V68inKm.jpg

 

 

 

Here is a verity of SS.

 

O3hgapw.jpg

 

oFF292U.jpg

 

j8mig9S.jpg

 

8njwxRy.jpg

 

6Aq3iDj.jpg

 

dEPzMAo.jpg

 

r23SG7d.jpg

 

gTrtWeM.jpg

 

Just curious. :wink:  :smile:


J. R. :ph34r:

Share this post


Link to post
Share on other sites

Yeah I think we saw that in Alaska too before we shipped.  I'm guessing it is a bug in the code that generates the geometry for the taxiway signs.  We were never able to track down the cause in time.

Share this post


Link to post
Share on other sites

Hi jpc55.

 

I know Provo is bugging you, so here's a gift:

 

https://onedrive.live.com/download?resid=f3950c5bbd2bcfa1%21847

 

This is a taxiway sign fix for KPVU. It was made by decompiling the KPVU FSX stock airport with ADE v165. I altered the code to add an exclude for the signs, and then took out all code not related to the signs:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- Created by Scenery Design Engine (SDE) on 5/31/2015 -->
<FSData
   version="9.0"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:noNamespaceSchemaLocation="bglcomp.xsd">
   <ExclusionRectangle
      latitudeMinimum="40.2050309250438"
      latitudeMaximum="40.233106012"
      longitudeMinimum="-111.739011062"
      longitudeMaximum="-111.70009565007"
      excludeAllObjects="FALSE"
      excludeTaxiwaySignObjects="TRUE"
      />
   <Airport
      country="United States"
      state="Utah"
      city="Provo"
      name="Provo Mun"
      lat="40.2191944420338"
      lon="-111.72336101532"
      alt="1370.685M"
      magvar="-15"
      trafficScalar="0.7"
      airportTestRadius="5000.0M"
      ident="KPVU"
      >
      <TaxiwaySign
         lat="40.2186818048358"
         lon="-111.72285720706"
         heading="281"
         label="m13-31"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.218050814841"
         lon="-111.722297629671"
         heading="101"
         label="m13-31"
         size="SIZE3"
         justification="LEFT"/>
      <TaxiwaySign
         lat="40.219360904812"
         lon="-111.721941732476"
         heading="101"
         label="m31-13"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2197850348281"
         lon="-111.722557634614"
         heading="281"
         label="m31-13"
         size="SIZE3"
         justification="LEFT"/>
      <TaxiwaySign
         lat="40.2180784748106"
         lon="-111.722115410363"
         heading="235"
         label="m36-18"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2186271548379"
         lon="-111.721737557545"
         heading="55"
         label="m36-18"
         size="SIZE3"
         justification="LEFT"/>
      <TaxiwaySign
         lat="40.2197573748584"
         lon="-111.722739856132"
         heading="55"
         label="m18-36"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2190112148442"
         lon="-111.722942707269"
         heading="235"
         label="m18-36"
         size="SIZE3"
         justification="LEFT"/>
      <TaxiwaySign
         lat="40.2263953347288"
         lon="-111.728396782511"
         heading="183"
         label="m31-13"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2263732049956"
         lon="-111.721135799271"
         heading="3"
         label="m18"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2255477549059"
         lon="-111.720059525334"
         heading="229"
         label="m18"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2188393848395"
         lon="-111.721655405701"
         heading="170"
         label="m/31-13/|<36-18<"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2301712143551"
         lon="-111.731553334385"
         heading="142"
         label="m13"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2114165447011"
         lon="-111.714774130213"
         heading="108"
         label="m31"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.2082297450302"
         lon="-111.725540050204"
         heading="282"
         label="m36"
         size="SIZE3"
         justification="RIGHT"/>
      <TaxiwaySign
         lat="40.210785884925"
         lon="-111.715922420761"
         heading="337"
         label="m31"
         size="SIZE3"
         justification="RIGHT"/>
   </Airport>
</FSData>

I recompiled with the FSX BGLComp, then converted the BGL with Steve's ContentConverter.

 

The KPVU_TaxiwaySigns_Fix.flightAddon file can be added using the Flight Toolkit Addon Manager.

 

Dick

Share this post


Link to post
Share on other sites

Cool, thanks Dick. I wonder if it was only one taxiway sign in particular that was causing the problem. If we can isolate which one I could probably change the conversion to skip the bad ones.

Share this post


Link to post
Share on other sites

Thanks Dick, I really do appreciate your time and effort with this. I added your taxiway sign fix for KPVU and this was the results.

 

dt9I0YX.jpg

 

Thank you again, and to all who are helping to keep Flight alive! :excl:  :BigGrin:


J. R. :ph34r:

Share this post


Link to post
Share on other sites

Hi jpc55.

 

Glad this worked for you.

 

Hi Steve.

 

As far as taxiway signs, we had problems with them in FSX as far as excluding them. We usually had to find a 'root' sign and exclude that, plus the misplaced sign. Usually excluding/replacing just one sign didn't do the trick. The errant code may be in the FSX bgl itself, yet still rendered OK in the sim. Or it may be in the conversion process as you suspect.

 

I took the easy way out. Excluded and replaced all the signs, due to my experience with FSX.

 

Dick

Share this post


Link to post
Share on other sites

Hey Steve & Dick,

 

For a side note I just went to KPVU without the taxiway sign "fix" and the anomaly doesn't exist on my installation. All looks normal except I noticed runway 18-36 doesn't have markings. Is it supposed to be that way?


Blue skies & tailwinds,

-Alan

 

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    17%
    $4,475.00 of $25,000.00 Donate Now
×
×
  • Create New...