Sign in to follow this  
tanker

MU-2B RMI

Recommended Posts

I'm back again with another question. The RMI gage always has a red flag and points to the bottom of the case, even when VOR is selected for both needles, and a VOR is in range, and the correct frequency is entered in NAV 1 and 2. I do get a proper indication on the EHSI and the DME readout is correct. When I select ADF, the needles point to the top of the case and the red flag is still present, even when a NDB is in range and the correct frequency is entered in the ADF radio.

 

Inverter and avionic switches are on and the above takes place at altitude. Am I missing something?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hey Tanker. The RMI has been fixed. The RCS switches  had an issue with shutdown. fixed as well. Should help a lot with can't start issues.

 

Mark as been working diligently on customer reports to better this beautiful plane.  Given time, I know Mark will make this the best GA add-on.  Little prejudice I know. :-)

Luv my MU-2!

Best,

David

Share this post


Link to post

Glad we got this sorted out!

 

Let us know if there is anything else that needs attention!

Share this post


Link to post

I hate to bring this thread back from the dead but I have just purchased the MU-2 for P3D v4, and the RMI needles are inop.  In VOR mode they point straight down.  Everything else seems to work just fine.

 

-Tim

Share this post


Link to post
Posted (edited)
19 hours ago, tmetzinger said:

I hate to bring this thread back from the dead but I have just purchased the MU-2 for P3D v4, and the RMI needles are inop.  In VOR mode they point straight down.  Everything else seems to work just fine.

 

-Tim

Hello Tim,

I don't have P3D so can't help too much, but a couple of things to check are:

-The MU-2 Avionics master switches are on

- If you are using the GTN 750 or GNS GPS unit, it is on, active, in VLOC (not really required for the RMI but for the HSI) and a local VOR frequency has been loaded into the active frequency position (not standby position).

- Does the the CDI in the HSI move as you move the HSI course arrow? In other words, does the HSI respond to VOR course info?

- Does the RMI in another aircraft, such as the default Beach Baron 58,  loaded into the same location respond as expected?

- Try loading the MU-2 after first loading a default a/c like the C172 or Beach Baron.

Al

Edited by ark

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this