Sign in to follow this  
jason99vmi

Ground textures loading really slowly

Recommended Posts

I've noticed while at my departure airport ground textures load fine and quickly.  But after an hour flight to LAX the ground textures took forever to load on the approach 30 sec or more. This has happened at other locations after descending to approach.  Didn't really have this issue in FSX but seems to be a reoccurring problem in P3D.  I do have Tessellation on and graphics settings are either high or ultra. 

 

Running Orbx Global, Vector, FreeMeshX.  These are installed on a SSD. 

 

Fiber Time Fraction is 0.02

 

LOD Radius is at the default 4.5

 

I did hit pause to see if the textures would load in, and they do slowly but obviously can't be doing this on VATSIM. 

 

Possibly reduce Autogen? 

 

System:

i7-4790k 4.0ghz

Nvidia 760 4GB

256 GB dedicated for P3D SSD

 

 

 

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I've noticed while at my departure airport ground textures load fine and quickly.  But after an hour flight to LAX the ground textures took forever to load on the approach 30 sec or more. This has happened at other locations after descending to approach.  Didn't really have this issue in FSX but seems to be a reoccurring problem in P3D.  I do have Tessellation on and graphics settings are either high or ultra. 

 

Running Orbx Global, Vector, FreeMeshX.  These are installed on a SSD. 

 

Fiber Time Fraction is 0.02

 

LOD Radius is at the default 4.5

 

I did hit pause to see if the textures would load in, and they do slowly but obviously can't be doing this on VATSIM. 

 

Possibly reduce Autogen? 

 

System:

i7-4790k 4.0ghz

Nvidia 760 4GB

256 GB dedicated for P3D SSD

 

Make sure you don't have affinity Mask entry in your P3D .cfg file, which can cause this. 

Share this post


Link to post

Make sure you don't have affinity Mask entry in your P3D .cfg file, which can cause this.

That's not quite correct. An INCORRECT Affinity Mask setting can cause a lot of things, including poor texture loading but if you have the correct setting for your system, it should have no negative effect.

 

Personally, I do not use AM and let P3D assign accordingly but each setup is different.

 

OP - you are overloading your GPU - turn down some settings.

 

Vic

Share this post


Link to post

Remove your FFTF tweak and try again. Also, try enabling HT if you can.

Share this post


Link to post

Thanks,  I will turn off the tweaks and try again.  The AF setting I always used in FSX was 84 but who knows if that was the correct calculation.  And FFTF was a tweak I read on these forums as a performance enhancer. 

 

I will try again with the settings as well.  I based them off Rob's great page of P3D settings but I guess its hard to judge if someone has a much better GPU.

 

I did what I always did with FSX, found someone with specs close to mine.  Put those settings in and then tweak up or down from there.    I was trying to avoid lots of test flights to find the best performance but looks like i'll have to shelve my full flights for a while to get these settings straight. 

Share this post


Link to post

Especially with P3D, just use the default settings without any tweaks at first. Tune for smooth operation not raw FPS.. P3D usually defaults to 20fps - leave it there - adjust the visuals until you get a smooth flight with no popping or stutters. then kick up the fps if you want and readjust. With P3D, less is more.

 

If you do decide to turn HT on, then you will need an Affinity Mask - I'd leave HT off and no AM to start.

 

 

Vic

Share this post


Link to post

Less is more it seems.  Went back to default settings on Nvidia and P3D.  Only settings in Nvidia were 4x multisample and 4x SGSS.   Pushed some of the sliders back right to high or ultra.  Did a couple test flights and even while doing 400kts less than 1k feet the scenery was crisp and not slow loading so I think I will just tweak little adjustments from here.  Thanks!

 

Didn't turn HT off but will look at doing so.  Just want to make sure if any other games need it on. 

Share this post


Link to post

For some systems, HT ON is the way to go. Select what works best for you.

 

Vic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this