Sign in to follow this  
ianalm

Thrustmaster T-Flight Stick X throttle problems

Recommended Posts

Hi All. Still having issues with the throttles on my "Thrustmaster T-Flight stick X" joystick.

When you advance the thottles on the PMDG 737-800NGX they will only go back to about 40% thrust and not to zero thrust.

Have installed FSUIPC4 from Peter Dowsons website and also downloaded Simconnect directly from Lockheed Martin.

...

I have allso recalibrated Joystick and downloaed the latest driver directly from Thrustmaster website. I have uninstalled and reinstalled the stick and tried to update the driver but for some reason it will not update.

Also moved the sliders in P3D settings for the Joystick to min and max but the problem still exists.

Any help or advice would be most welcome.

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello Ianalm.  Have you had the stick long?   What operating system are you running?  

 

This might sound crazy,  But do you have the switch on the stick set correctly to PC ?  :smile:

Share this post


Link to post

Hi

 

Yes have had this stick for some years.

 

There are no on/off or PC switches. This stick has worked well in FSX up until I purchased P3D last week.

 

I have now purchased FSUIPC4 for P3D but the calibration options are confusing! Have spent 2 hours this morning uninstalling and reinstalling and playing around with settings in FSUIPC4 but still no luck. The throttles now fully retard but then jump open and shut randomly. I think its time to buy another joystick as my patience is wearing thin.

Share this post


Link to post

Such random moves can mean that the pots are indeed worn out but it can also mean that the same axis has been assigned to two different levers. The controls default settings needs a thorough check and some changes (sensitivity, null zones and all the axis assignements).

 

I had some difficulties tuning my Warthog Hotas in V3 which appears not compatible with the Thrustmaster TARGET software that I use(FSUIPC is too complicated for me :smile: ).  My CH pedals work but are not recognized as such  but as a "control manager #00"...  

Share this post


Link to post

Hello,

 

You may want to check if all assignments for your joystick are deleted in P3D. If you don't use force feedback, you can also uncheck the box on the P3D calibrstion tab and that will disable all of the controller assignments and calibration in P3D options.

 

You can assign and calibrate all of your axes in FSUIPC. Just make sure you click on the 'Send direct to FSUIPC Calibration' radio button. After assigning the axis, choose the calibration tab and go to the correct page.

 

Click the reset button on the throttle calibration section. If you want thrust reversers, make sure 'No Reverse Zone' is not checked. Push throttle fully forward (then back just a wee bit) and click on Max. Set your idle zone. Without reversers, set it from full back to about 15000. That will give you an idle range. If you have reversers on the aircraft, set the idle range from just above full back to about 149000. Pull the throttle full back and click the reverse button.

 

Do bear in mind that this should get set up for each aircraft. Takes a bit of time, but the beauty is, you will have an individual profile for each aircraft. Won't have to be one size fits all.

Share this post


Link to post

I fully agree with Graham. I had similar problems after updating from p3d v2.5 to v3.1. Delete and reassign the axes in P3D and make your selection in FSUIPC afterwards. My Saitek Mad Catz V1 is now working again after being grounded for a few days.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this