Sign in to follow this  
mikealpha

3D Camera Views screwed up

Recommended Posts

I'm more or less XPlane newbie (10.45RC1) and somehow managed to screw up my 3D Camera View.

 

Happened when entering a serial number for the Beech F33 Reality Expansion Pack. The mouse was in a "every move changes 3D view" mode, but cut/paste of the serial number didn't work. So I had to move outside the Xplane window to open Notepad for the serial number, leaving the Xplane window with the  3D view  in an awkward position. I then entered the serial number and reloaded the plane.

 

Now every plane comes up in a weird position, even the default planes. The predefined views in all Addons are wrong now.

 

How can I revert to the default state ? I have a backup of the plain XPlane installation on another disk. Where are this settings stored ? Can I just copy any file from there back to my current installation? I have a lot of Addons already installed, wouldn't really like to start from scratch.

 

I have downloaded X-Camera. Should I just use this now, or better get back to normal view  state before starting with this ?

 

Mike

 

EDIT : Ooops, sorry, wrong forum, was meant for the General Discusssion Forum.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I am not entirely sure what do you mean. If the problem seems to be the tilted camera view, try going to your rendering settings, and at the bottom there  is "SPECIAL VIEWING OPTIONS" section. 

In my understaning, all offsets (lateral, vertical, roll) should be set to 0. I guess something changed those settings for you, hence the camera seems to be so funky. 

 

Hope that helps. 

 

EDIT: Make sure to leave your lateral field of view as it it. It's your FOV, usually 75 gives the best experience). 

Share this post


Link to post
Share on other sites

If you installed X Camera than this is probably the problem,Disable it in the plugins menu.Switch to another aircraft and all should be normal.You may have to look into the X Camera Manual to set up your views correctly.

I Do not own The F33 Expansion Pack so I'm not certain if that's an issue also.

Share this post


Link to post
Share on other sites

.

I totally encourage you to use X-Camera.

you can set it up just like you want , FOV , Retain mouse look , left right key, joystick mapping etc etc , this is the add on that is gone make x-plane feel like FSX ,

Share this post


Link to post
Share on other sites

thanks for the answers. I have downloaded X-Camera, but haven't copied to the plugins folder yet. FOV is at 70, all other coordinates at 0.0

I try to show the problem with two screenshots. The first one after using the Main View from the Carenado selector at FOV 70, the second one at FOV 150. It looks like the plane center is shifted awkwardly to up and forward. I can correct it using the CTRL-Arrow Keys, but after restart of XPlane the strange views are back. This weird 3D view is the same for all planes.

Where does X-Plane store this ? I tried to copy over the Output folder from the backup installation, did not change anything.

 

Just to describe again how it happened. Serial number activation window of REP was on screen. Without pressing any mouse button, any mouse movement changed view in 3D cockpit. To get near screen edge to leave the the XPlane Window with the mouse, the 3D view necessarily changed to an awkward view. But I didn't do myself anything to store this.

After restarting XPlane, I got this views.

 

http://up.picr.de/24603978tc.jpg

 

http://up.picr.de/24603979wy.jpg

 

 

Mike

Share this post


Link to post
Share on other sites

The REP activation will not allow you to "paste" the number as you have already found out.  My suggestion would be to create another REP version - just name it different and then paste the REP contents in there again.

 

Now, when the serial blank comes up, just type in the number which you have written down on a piece of paper and hit enter.  Close the program at the prompt or just select another aircraft and then go back and select the REP.

 

If this works, just delete the one that is messed up.

 

John

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this