Sign in to follow this  
maximilianchen

T7 hangs after ~4hrs flight / during descend

Recommended Posts

Hi all,

 

Never thought I would be a victim of CTD but recently (started around 2 weeks ago) I have been experiencing P3D hangs after ~4 hours into my flight.

 

The hangs are triggered by mouse clicking, on the PFD, ND, or just looking around with middle wheel. The hangs usually take place when I am about to (or has entered into) descend into my destination.  Not too sure whether the hangs are caused by the descend, or the fact that I am approaching the 4 hours mark.

 

Up until 2 weeks ago everything works flawlessly – this is what baffles me the most.

 

Given I have no restore point saved, I have tried formatting my entire hard driver where the P3D is installed, deleting all P3D folders in all the places (AppData/Local, Appdata/Roaming, ProgramData…etc), and performed a clean reinstall for all software.

 

For the first two hangs when it started happen I had these apps running:

P3D v3.1

Latest version PMDG 777

FS2Crew v1.7

Latest version ASN

FSUIPC  v4.949f

GSX v1.9

 

After the formatting and a clean reinstall, the first two hangs I had the same apps running as above, and in the last two hangs I had these:

P3D v3.1

FS2Crew v1.7

Latest version ASN

FSUIPC  v4.949f

 

To be honest I don’t think it was those apps that caused the hangs. I am suspecting it is more like conflicts between P3D/PMDG/Windows Update - because this is as far as I can recall if anything has changed between the hang/no hang situation.

 

I will update my system spec later, but I am running P3D on Win7 SP1.

 

Has anyone experienced the same recently? Really want to practice my landings  :sad:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

do you have an affinity mask set in the cfg file? I had to change mine to 14 (even though I have a larger processor) before the freezing stopped

 

-David Lee

Share this post


Link to post
Share on other sites

Here's a shot in the dark! 

 

About 6 months ago, my machine also started to hang for no apparent reason.  Ran a ton of diagnostics,  Followed a bunch of advice (lots of bum scoop out there) and ran numerous processes, all to no avail.  After going nuts for a week or so, I noticed that the hangs seemed to occur in conjunction with mouse movement.  Got a new mouse and the problems have gone away.  Mice do fail, so you might try another one to see if the mouse is the problem.  I bought a Logitech wireless mouse and my system has been rock solid ever since.

 

Good luck, 

Share this post


Link to post
Share on other sites

do you have an affinity mask set in the cfg file? I had to change mine to 14 (even though I have a larger processor) before the freezing stopped

 

-David Lee

 

I do have the affinity mask set to 144 (or 244? I forgot...got the value using the windows calculator thingy). Will give this a shot.

 

Here's a shot in the dark! 

 

About 6 months ago, my machine also started to hang for no apparent reason.  Ran a ton of diagnostics,  Followed a bunch of advice (lots of bum scoop out there) and ran numerous processes, all to no avail.  After going nuts for a week or so, I noticed that the hangs seemed to occur in conjunction with mouse movement.  Got a new mouse and the problems have gone away.  Mice do fail, so you might try another one to see if the mouse is the problem.  I bought a Logitech wireless mouse and my system has been rock solid ever since.

 

Good luck, 

 

This indeed is interesting and surprising...I will give it a try. Hoorah   :Big Grin:

Share this post


Link to post
Share on other sites

Just an update on this issue -

 

The hang seems to go away after I uninstall the windows update KB26780838.

 

Will keep observing but for now I can finish a 3+hrs flight without any hang/crash/CTD.

Share this post


Link to post
Share on other sites

The hang seems to go away after I uninstall the windows update KB26780838.

Can you verify the KB number? I don't find anything about it, and I think there is an extra digit in it.

Share this post


Link to post
Share on other sites

Can you verify the KB number? I don't find anything about it, and I think there is an extra digit in it.

 

Sorry guys, was too excited to be finally able to land my bird.

 

The KB number should be KB2670838, and i read it from here:

https://forums.geforce.com/default/topic/573125/game-crashing-stackhash-bex-error/

 

Give it a try and let us know if it works for you. Good luck.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this